diff options
-rw-r--r-- | recipes-devtools/python/python-backports-lzma/fix_paths.patch | 17 | ||||
-rw-r--r-- | recipes-devtools/python/python-backports-lzma_0.0.3.bb | 32 |
2 files changed, 0 insertions, 49 deletions
diff --git a/recipes-devtools/python/python-backports-lzma/fix_paths.patch b/recipes-devtools/python/python-backports-lzma/fix_paths.patch deleted file mode 100644 index c2b374f6..00000000 --- a/recipes-devtools/python/python-backports-lzma/fix_paths.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | --- | ||
2 | setup.py | 4 ++-- | ||
3 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
4 | |||
5 | --- a/setup.py | ||
6 | +++ b/setup.py | ||
7 | @@ -32,8 +32,8 @@ | ||
8 | extens = [Extension('backports/lzma/_lzma', | ||
9 | ['backports/lzma/_lzmamodule.c'], | ||
10 | libraries = ['lzma'], | ||
11 | - include_dirs = [os.path.join(home, 'include'), '/opt/local/include', '/usr/local/include'], | ||
12 | - library_dirs = [os.path.join(home, 'lib'), '/opt/local/lib', '/usr/local/lib'] | ||
13 | + include_dirs = [], | ||
14 | + library_dirs = [] | ||
15 | )] | ||
16 | |||
17 | descr = "Backport of Python 3.3's 'lzma' module for XZ/LZMA compressed files." | ||
diff --git a/recipes-devtools/python/python-backports-lzma_0.0.3.bb b/recipes-devtools/python/python-backports-lzma_0.0.3.bb deleted file mode 100644 index a3586c04..00000000 --- a/recipes-devtools/python/python-backports-lzma_0.0.3.bb +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | HOMEPAGE = "https://github.com/peterjc/backports.lzma" | ||
2 | SUMMARY = "\ | ||
3 | Backport of Python 3.3's 'lzma' module for XZ/LZMA compressed files." | ||
4 | DESCRIPTION = "\ | ||
5 | This is a backport of the 'lzma' module included in Python 3.3 or later \ | ||
6 | by Nadeem Vawda and Per Oyvind Karlsen, which provides a Python wrapper \ | ||
7 | for XZ Utils (aka LZMA Utils v2) by Igor Pavlov. \ | ||
8 | . \ | ||
9 | In order to compile this, you will need to install XZ Utils from \ | ||
10 | http://tukaani.org/xz/ \ | ||
11 | " | ||
12 | SECTION = "devel/python" | ||
13 | LICENSE = "BSD" | ||
14 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=db4345b3b9524aabc8fe8c65f235c6b2" | ||
15 | |||
16 | SRC_URI[md5sum] = "c3d109746aefa86268e500c07d7e8e0f" | ||
17 | SRC_URI[sha256sum] = "bac58aec8d39ac3d22250840fb24830d0e4a0ef05ad8f3f09172dc0cc80cdbca" | ||
18 | |||
19 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
20 | |||
21 | inherit setuptools | ||
22 | |||
23 | DEPENDS += "xz" | ||
24 | |||
25 | SRCNAME = "backports.lzma" | ||
26 | |||
27 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
28 | |||
29 | SRC_URI = "\ | ||
30 | https://pypi.python.org/packages/source/b/backports.lzma/${SRCNAME}-${PV}.tar.gz \ | ||
31 | file://fix_paths.patch \ | ||
32 | " | ||