summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch')
-rw-r--r--recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch57
1 files changed, 23 insertions, 34 deletions
diff --git a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
index d30f2ac2..dc5b8977 100644
--- a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
+++ b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
@@ -1,6 +1,6 @@
1From 057d30f15e81dcc4162d6fbee06f126564596397 Mon Sep 17 00:00:00 2001 1From af679853a45fe63f680c99e70416c8ac620d23b8 Mon Sep 17 00:00:00 2001
2From: Jianchuan Wang <jianchuan.wang@windriver.com> 2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 7 Sep 2016 23:55:15 -0400 3Date: Fri, 8 Sep 2017 15:02:14 -0400
4Subject: [PATCH] criu: Fix toolchain hardcode 4Subject: [PATCH] criu: Fix toolchain hardcode
5 5
6Replace ":=" to "?=" so that the toolchain used by bitbake build system will 6Replace ":=" to "?=" so that the toolchain used by bitbake build system will
@@ -8,45 +8,32 @@ be taken.
8 8
9Signed-off-by: Yang Shi <yang.shi@windriver.com> 9Signed-off-by: Yang Shi <yang.shi@windriver.com>
10Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> 10Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
11Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11--- 12---
12 Makefile | 2 +- 13 Makefile | 2 +-
13 criu/pie/Makefile | 2 +-
14 scripts/nmk/scripts/include.mk | 2 +- 14 scripts/nmk/scripts/include.mk | 2 +-
15 scripts/nmk/scripts/tools.mk | 40 ++++++++++++++++++++-------------------- 15 scripts/nmk/scripts/tools.mk | 40 ++++++++++++++++++++--------------------
16 4 files changed, 23 insertions(+), 23 deletions(-) 16 3 files changed, 22 insertions(+), 22 deletions(-)
17 17
18diff --git a/Makefile b/Makefile 18diff --git a/Makefile b/Makefile
19index 52cbd6a..f66279b 100644 19index f2583a2..d7f51e5 100644
20--- a/Makefile 20--- a/Makefile
21+++ b/Makefile 21+++ b/Makefile
22@@ -60,7 +60,7 @@ LDARCH ?= $(SRCARCH) 22@@ -17,7 +17,7 @@ ifeq ($(origin HOSTCFLAGS), undefined)
23 23 HOSTCFLAGS := $(CFLAGS) $(USERCFLAGS)
24 export SRCARCH LDARCH VDSO 24 endif
25 25
26-UNAME-M := $(shell uname -m) 26-UNAME-M := $(shell uname -m)
27+UNAME-M ?= $(shell uname -m) 27+UNAME-M ?= $(shell uname -m)
28 export UNAME-M
29 28
30 ifeq ($(ARCH),arm)
31diff --git a/criu/pie/Makefile b/criu/pie/Makefile
32index 125b02f..9975871 100644
33--- a/criu/pie/Makefile
34+++ b/criu/pie/Makefile
35@@ -17,7 +17,7 @@ restorer-obj-e += ./$(ARCH_DIR)/syscalls.built-in.o
36 # 29 #
37 CFLAGS := $(filter-out -pg $(CFLAGS-GCOV),$(CFLAGS)) 30 # Supported Architectures
38 CFLAGS += -iquote $(SRC_DIR)/criu/pie/piegen
39-CFLAGS += -iquote $(SRC_DIR)/criu/arch/$(ARCH)/include
40+CFLAGS += -iquote $(SRC_DIR)/criu/arch/$(SRCARCH)/include
41 CFLAGS += -iquote $(SRC_DIR)/criu/include
42 CFLAGS += -iquote $(SRC_DIR)
43
44diff --git a/scripts/nmk/scripts/include.mk b/scripts/nmk/scripts/include.mk 31diff --git a/scripts/nmk/scripts/include.mk b/scripts/nmk/scripts/include.mk
45index 4c496f7..a7250cd 100644 32index 04ccb3a..0d63bc7 100644
46--- a/scripts/nmk/scripts/include.mk 33--- a/scripts/nmk/scripts/include.mk
47+++ b/scripts/nmk/scripts/include.mk 34+++ b/scripts/nmk/scripts/include.mk
48@@ -20,7 +20,7 @@ SUBARCH := $(shell uname -m | sed \ 35@@ -20,7 +20,7 @@ SUBARCH := $(shell uname -m | sed \
49 -e s/aarch64.*/arm64/) 36 -e s/aarch64.*/aarch64/)
50 37
51 ARCH ?= $(SUBARCH) 38 ARCH ?= $(SUBARCH)
52-SRCARCH := $(ARCH) 39-SRCARCH := $(ARCH)
@@ -55,16 +42,20 @@ index 4c496f7..a7250cd 100644
55 export SUBARCH ARCH SRCARCH 42 export SUBARCH ARCH SRCARCH
56 43
57diff --git a/scripts/nmk/scripts/tools.mk b/scripts/nmk/scripts/tools.mk 44diff --git a/scripts/nmk/scripts/tools.mk b/scripts/nmk/scripts/tools.mk
58index 0538dde..e4af068 100644 45index 56dba84..1698821 100644
59--- a/scripts/nmk/scripts/tools.mk 46--- a/scripts/nmk/scripts/tools.mk
60+++ b/scripts/nmk/scripts/tools.mk 47+++ b/scripts/nmk/scripts/tools.mk
61@@ -2,28 +2,28 @@ ifndef ____nmk_defined__tools 48@@ -2,30 +2,30 @@ ifndef ____nmk_defined__tools
62 49
63 # 50 #
64 # System tools shorthands 51 # System tools shorthands
65-RM := rm -f 52-RM := rm -f
66-LD := $(CROSS_COMPILE)ld 53+RM ?= rm -f
67-CC := $(CROSS_COMPILE)gcc 54 HOSTLD ?= ld
55-LD := $(CROSS_COMPILE)$(HOSTLD)
56+LD ?= $(CROSS_COMPILE)$(HOSTLD)
57 HOSTCC ?= gcc
58-CC := $(CROSS_COMPILE)$(HOSTCC)
68-CPP := $(CC) -E 59-CPP := $(CC) -E
69-AS := $(CROSS_COMPILE)as 60-AS := $(CROSS_COMPILE)as
70-AR := $(CROSS_COMPILE)ar 61-AR := $(CROSS_COMPILE)ar
@@ -79,9 +70,7 @@ index 0538dde..e4af068 100644
79-PYTHON := python 70-PYTHON := python
80-FIND := find 71-FIND := find
81-SH := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \ 72-SH := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
82+RM ?= rm -f 73+CC ?= $(CROSS_COMPILE)$(HOSTCC)
83+LD ?= $(CROSS_COMPILE)ld
84+CC ?= $(CROSS_COMPILE)gcc
85+CPP ?= $(CC) -E 74+CPP ?= $(CC) -E
86+AS ?= $(CROSS_COMPILE)as 75+AS ?= $(CROSS_COMPILE)as
87+AR ?= $(CROSS_COMPILE)ar 76+AR ?= $(CROSS_COMPILE)ar
@@ -105,8 +94,8 @@ index 0538dde..e4af068 100644
105+ETAGS ?= etags 94+ETAGS ?= etags
106+CTAGS ?= ctags 95+CTAGS ?= ctags
107 96
108 export RM LD CC CPP AS AR STRIP OBJCOPY OBJDUMP 97 export RM HOSTLD LD HOSTCC CC CPP AS AR STRIP OBJCOPY OBJDUMP
109 export NM SH MAKE MKDIR AWK PERL PYTHON SH CSCOPE 98 export NM SH MAKE MKDIR AWK PERL PYTHON SH CSCOPE
110-- 99--
1112.8.1 1002.7.4
112 101