summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files/disable-selinux.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/criu/files/disable-selinux.patch')
-rw-r--r--recipes-containers/criu/files/disable-selinux.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-containers/criu/files/disable-selinux.patch b/recipes-containers/criu/files/disable-selinux.patch
new file mode 100644
index 00000000..da881dd3
--- /dev/null
+++ b/recipes-containers/criu/files/disable-selinux.patch
@@ -0,0 +1,26 @@
1Upstream-Status: Inappropriate [disable feature]
2
3It shows warning when build crius if libselinux has been built already:
4
5 WARNING: QA Issue: criu rdepends on libselinux, but it isn't a build dependency? [build-deps]
6
7Apply this patch to disable selinux support when 'selinux' is not in PACKAGECONF.
8
9Signed-off-by: Kai Kang <kai.kang@windriver.com>
10
11diff --git a/Makefile.config b/Makefile.config
12index ce4b8d8..3ac2780 100644
13--- a/Makefile.config
14+++ b/Makefile.config
15@@ -8,11 +8,6 @@ ifeq ($(call try-cc,$(LIBBSD_DEV_TEST),-lbsd),y)
16 DEFINES += -DCONFIG_HAS_LIBBSD
17 endif
18
19-ifeq ($(call pkg-config-check,libselinux),y)
20- LIBS := -lselinux $(LIBS)
21- DEFINES += -DCONFIG_HAS_SELINUX
22-endif
23-
24 $(CONFIG): scripts/utilities.mak scripts/feature-tests.mak include/config-base.h
25 $(E) " GEN " $@
26 $(Q) @echo '#ifndef __CR_CONFIG_H__' > $@