diff options
Diffstat (limited to 'recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch')
-rw-r--r-- | recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | 29 |
1 files changed, 14 insertions, 15 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch index 2576bb1d..7205d3b5 100644 --- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch +++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |||
@@ -14,42 +14,41 @@ Signed-off-by: Ming Liu <liu.ming50@gmail.com> | |||
14 | setup.py | 24 ++++++++++++------------ | 14 | setup.py | 24 ++++++++++++------------ |
15 | 1 file changed, 12 insertions(+), 12 deletions(-) | 15 | 1 file changed, 12 insertions(+), 12 deletions(-) |
16 | 16 | ||
17 | Index: docker-compose-1.28.2/setup.py | 17 | Index: docker-compose-1.29.1/setup.py |
18 | =================================================================== | 18 | =================================================================== |
19 | --- docker-compose-1.28.2.orig/setup.py | 19 | --- docker-compose-1.29.1.orig/setup.py |
20 | +++ docker-compose-1.28.2/setup.py | 20 | +++ docker-compose-1.29.1/setup.py |
21 | @@ -25,17 +25,17 @@ | 21 | @@ -25,16 +25,21 @@ |
22 | 22 | ||
23 | 23 | ||
24 | install_requires = [ | 24 | install_requires = [ |
25 | - 'cached-property >= 1.2.0, < 2', | ||
26 | - 'docopt >= 0.6.1, < 1', | 25 | - 'docopt >= 0.6.1, < 1', |
27 | - 'PyYAML >= 3.10, < 6', | 26 | - 'PyYAML >= 3.10, < 6', |
28 | - 'requests >= 2.20.0, < 3', | 27 | - 'requests >= 2.20.0, < 3', |
29 | - 'texttable >= 0.9.0, < 2', | 28 | - 'texttable >= 0.9.0, < 2', |
30 | - 'websocket-client >= 0.32.0, < 1', | ||
31 | - 'distro >= 1.5.0, < 2', | ||
32 | - 'docker[ssh] >= 4.4.0, < 5', | ||
33 | - 'dockerpty >= 0.4.1, < 1', | ||
34 | - 'jsonschema >= 2.5.1, < 4', | ||
35 | - 'python-dotenv >= 0.13.0, < 1', | ||
36 | + 'cached-property >= 1.2.0', | ||
37 | + 'docopt >= 0.6.1', | 29 | + 'docopt >= 0.6.1', |
38 | + 'PyYAML >= 3.10', | 30 | + 'PyYAML >= 3.10', |
39 | + 'requests >= 2.20.0', | 31 | + 'requests >= 2.20.0', |
40 | + 'texttable >= 0.9.0', | 32 | + 'texttable >= 0.9.0', |
33 | 'websocket-client >= 0.32.0, < 1', | ||
34 | 'distro >= 1.5.0, < 2', | ||
35 | - 'docker[ssh] >= 5', | ||
36 | + 'docker[ssh] >= 4.4.0, < 5', | ||
37 | 'dockerpty >= 0.4.1, < 1', | ||
38 | 'jsonschema >= 2.5.1, < 4', | ||
39 | - 'python-dotenv >= 0.13.0, < 1', | ||
41 | + 'websocket-client >= 0.32.0', | 40 | + 'websocket-client >= 0.32.0', |
42 | + 'distro >= 1.5.0', | 41 | + 'distro >= 1.5.0', |
43 | + 'docker[ssh] >= 4.4.0', | 42 | + 'docker[ssh] >= 5', |
44 | + 'dockerpty >= 0.4.1', | 43 | + 'dockerpty >= 0.4.1', |
45 | + 'jsonschema >= 2.5.1', | 44 | + 'jsonschema >= 2.5.1', |
46 | + 'python-dotenv >= 0.13.0', | 45 | + 'python-dotenv >= 0.13.0', |
47 | ] | 46 | ] |
48 | 47 | ||
49 | 48 | ||
50 | @@ -51,7 +51,7 @@ | 49 | @@ -51,7 +56,7 @@ |
51 | extras_require = { | ||
52 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'], | 50 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'], |
51 | ':python_version < "3.8"': ['cached-property >= 1.2.0, < 2'], | ||
53 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], | 52 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], |
54 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], | 53 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], |
55 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], | 54 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], |