diff options
Diffstat (limited to 'recipes-containers/go-errors/go-errors_git.bb')
-rw-r--r-- | recipes-containers/go-errors/go-errors_git.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-containers/go-errors/go-errors_git.bb b/recipes-containers/go-errors/go-errors_git.bb new file mode 100644 index 00000000..3bb74a7c --- /dev/null +++ b/recipes-containers/go-errors/go-errors_git.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "Simple error handling primitives" | ||
2 | HOMEPAGE = "https://github.com/pkg/errors" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=6fe682a02df52c6653f33bd0f7126b5a" | ||
6 | |||
7 | SRCNAME = "errors" | ||
8 | |||
9 | PKG_NAME = "github.com/pkg/${SRCNAME}" | ||
10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" | ||
11 | |||
12 | SRCREV = "248dadf4e9068a0b3e79f02ed0a610d935de5302" | ||
13 | PV = "v0.8.0+git${SRCPV}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | # NO-OP the do compile rule because this recipe is source only. | ||
18 | do_compile() { | ||
19 | } | ||
20 | |||
21 | do_install() { | ||
22 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
23 | for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do | ||
24 | if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then | ||
25 | mkdir -p ${D}${prefix}/local/go/$(dirname $j) | ||
26 | fi | ||
27 | cp $j ${D}${prefix}/local/go/$j | ||
28 | done | ||
29 | cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
30 | } | ||
31 | |||
32 | SYSROOT_PREPROCESS_FUNCS += "go_errors_file_sysroot_preprocess" | ||
33 | |||
34 | go_errors_file_sysroot_preprocess () { | ||
35 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
36 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
37 | } | ||
38 | |||
39 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
40 | |||
41 | CLEANBROKEN = "1" \ No newline at end of file | ||