summaryrefslogtreecommitdiffstats
path: root/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch')
-rw-r--r--recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch b/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch
new file mode 100644
index 00000000..8098562e
--- /dev/null
+++ b/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch
@@ -0,0 +1,51 @@
1From 8ca4391a5954db168d513ba64c3791f63b044fbf Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 30 Jun 2020 23:58:22 -0400
4Subject: [PATCH] build: use to select cross compiler
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
7---
8 git/src/import/Makefile | 10 +++++-----
9 1 file changed, 5 insertions(+), 5 deletions(-)
10
11diff --git git/src/import/Makefile git/src/import/Makefile
12index c6976af..f3c8d17 100644
13--- git/src/import/Makefile
14+++ git/src/import/Makefile
15@@ -10,11 +10,11 @@ all: clean build static fmt lint test vet
16
17 build:
18 @echo "+ $@"
19- @go build -tags "$(BUILDTAGS) cgo" .
20+ @${GO} build -tags "$(BUILDTAGS) cgo" .
21
22 static:
23 @echo "+ $@"
24- CGO_ENABLED=1 go build -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static" -o riddler .
25+ CGO_ENABLED=1 ${GO} build -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static" -o riddler .
26
27 fmt:
28 @echo "+ $@"
29@@ -26,11 +26,11 @@ lint:
30
31 test: fmt lint vet
32 @echo "+ $@"
33- @go test -v -tags "$(BUILDTAGS) cgo" $(shell go list ./... | grep -v vendor)
34+ @${GO} test -v -tags "$(BUILDTAGS) cgo" $(shell go list ./... | grep -v vendor)
35
36 vet:
37 @echo "+ $@"
38- @go vet $(shell go list ./... | grep -v vendor)
39+ @${GO} vet $(shell go list ./... | grep -v vendor)
40
41 clean:
42 @echo "+ $@"
43@@ -38,4 +38,4 @@ clean:
44
45 install:
46 @echo "+ $@"
47- @go install -v .
48+ @${GO} install -v .
49--
502.19.1
51