diff options
Diffstat (limited to 'recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch')
-rw-r--r-- | recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch | 17 |
1 files changed, 7 insertions, 10 deletions
diff --git a/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch b/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch index 36d45b57..873d7ab4 100644 --- a/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch +++ b/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch | |||
@@ -11,16 +11,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
11 | gobuild/Makefile | 4 ++-- | 11 | gobuild/Makefile | 4 ++-- |
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | 12 | 1 file changed, 2 insertions(+), 2 deletions(-) |
13 | 13 | ||
14 | diff --git a/src/import/gobuild/Makefile b/src/import/gobuild/Makefile | 14 | Index: git/src/import/gobuild/Makefile |
15 | index 694d9ce..149d573 100644 | 15 | =================================================================== |
16 | --- a/src/import/gobuild/Makefile | 16 | --- git.orig/src/import/gobuild/Makefile |
17 | +++ b/src/import/gobuild/Makefile | 17 | +++ git/src/import/gobuild/Makefile |
18 | @@ -19,10 +19,10 @@ dep: ${GODEPPATHS} | 18 | @@ -19,10 +19,10 @@ |
19 | 19 | ||
20 | ${GODEPPATHS}: | 20 | ${GODEPPATHS}: |
21 | mkdir -p ${GOSRC} | 21 | mkdir -p ${GOSRC} |
22 | - GOPATH=${GOPATH} go get $(subst ${GOSRC}/,,$@) | 22 | - GOPATH=${GOPATH} go get -d $(subst ${GOSRC}/,,$@) |
23 | + GOPATH=${GOPATH} ${GO} get $(subst ${GOSRC}/,,$@) | 23 | + GOPATH=${GOPATH} ${GO} get -d $(subst ${GOSRC}/,,$@) |
24 | 24 | ||
25 | ${BIN}: ${GODEPPATHS} $(filter %/$@.go, ${MAIN}) | 25 | ${BIN}: ${GODEPPATHS} $(filter %/$@.go, ${MAIN}) |
26 | - GOPATH=${GOPATH} ${ARCH} go build $(filter %/$@.go, ${MAIN}) | 26 | - GOPATH=${GOPATH} ${ARCH} go build $(filter %/$@.go, ${MAIN}) |
@@ -28,6 +28,3 @@ index 694d9ce..149d573 100644 | |||
28 | 28 | ||
29 | clean: | 29 | clean: |
30 | rm -f ${BIN} | 30 | rm -f ${BIN} |
31 | -- | ||
32 | 2.19.1 | ||
33 | |||