diff options
Diffstat (limited to 'recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch')
-rw-r--r-- | recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch | 38 |
1 files changed, 0 insertions, 38 deletions
diff --git a/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch b/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch deleted file mode 100644 index 8b293428..00000000 --- a/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From 46e331263eb92e47510e88478b255f226d30245c Mon Sep 17 00:00:00 2001 | ||
2 | From: Keith Holman <Keith.Holman@windriver.com> | ||
3 | Date: Mon, 18 Aug 2014 15:19:35 -0400 | ||
4 | Subject: [PATCH] protobuf: allow running python scripts from anywhere | ||
5 | |||
6 | The Makefile to generate the examples with Google Protocol Buffers | ||
7 | generates some scripts for python. However, these generated scripts | ||
8 | only work if they are ran in the same directory as the source files. | ||
9 | This fix generates scripts to execute from anywhere on the system. | ||
10 | |||
11 | Signed-off-by: Keith Holman <Keith.Holman@windriver.com> | ||
12 | --- | ||
13 | examples/Makefile | 6 ++++-- | ||
14 | 1 file changed, 4 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/examples/Makefile b/examples/Makefile | ||
17 | index 8dc9083..a993d63 100644 | ||
18 | --- a/examples/Makefile | ||
19 | +++ b/examples/Makefile | ||
20 | @@ -48,11 +48,13 @@ list_people_java: javac_middleman | ||
21 | add_person_python: add_person.py protoc_middleman | ||
22 | @echo "Writing shortcut script add_person_python..." | ||
23 | @echo '#! /bin/sh' > add_person_python | ||
24 | - @echo './add_person.py "$$@"' >> add_person_python | ||
25 | + @echo 'SCRIPT_DIR=$$(dirname $$0)' >> add_person_python | ||
26 | + @echo '$$SCRIPT_DIR/add_person.py "$$@"' >> add_person_python | ||
27 | @chmod +x add_person_python | ||
28 | |||
29 | list_people_python: list_people.py protoc_middleman | ||
30 | @echo "Writing shortcut script list_people_python..." | ||
31 | @echo '#! /bin/sh' > list_people_python | ||
32 | - @echo './list_people.py "$$@"' >> list_people_python | ||
33 | + @echo 'SCRIPT_DIR=$$(dirname $$0)' >> list_people_python | ||
34 | + @echo '$$SCRIPT_DIR/list_people.py "$$@"' >> list_people_python | ||
35 | @chmod +x list_people_python | ||
36 | -- | ||
37 | 1.9.3 | ||
38 | |||