summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch')
-rw-r--r--recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch b/recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch
new file mode 100644
index 00000000..7ec705bc
--- /dev/null
+++ b/recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch
@@ -0,0 +1,32 @@
1From a61cea5053730f8180eb1fc8b4cb0f94ff4fc176 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 9 Feb 2021 21:31:19 -0500
4Subject: [PATCH] setup.py: tweak setuptools_scm version dependency
5
6The version dependency of <4 isn't showing any issues in builds.
7The oe-core version is 5+, and carrying a secondary version is
8not trivial or something we want to do.
9
10So we tweak the version to accept what we have in oe-core.
11
12Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
13---
14 setup.py | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/setup.py b/setup.py
18index ade43a9..889a74f 100644
19--- a/setup.py
20+++ b/setup.py
21@@ -132,7 +132,7 @@ kwargs = dict(
22 "git_describe_command": "git describe --dirty --tags --long --match *.*.*.*",
23 "write_to": "newrelic/version.txt",
24 },
25- setup_requires=["setuptools_scm>=3.2,<4"],
26+ setup_requires=["setuptools_scm>=3.2"],
27 description = "New Relic Python Agent",
28 long_description = open(readme_file).read(),
29 url = "https://newrelic.com/docs/python/new-relic-for-python",
30--
312.19.1
32