summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch')
-rw-r--r--recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch26
1 files changed, 14 insertions, 12 deletions
diff --git a/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch b/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch
index 3c2622c7..30c30e88 100644
--- a/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch
+++ b/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch
@@ -13,14 +13,14 @@ Signed-off-by: Martin Kletzander <mkletzan redhat com>
13[ywei: rebased to 1.3.2] 13[ywei: rebased to 1.3.2]
14Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com> 14Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com>
15--- 15---
16 setup.py | 25 ++++++++++++++++++++++--- 16 setup.py | 35 ++++++++++++++++++++++++-----------
17 1 file changed, 22 insertions(+), 3 deletions(-) 17 1 file changed, 24 insertions(+), 11 deletions(-)
18 18
19Index: libvirt-python-1.2.4/setup.py 19diff --git a/setup.py b/setup.py
20=================================================================== 20index eff9d54..48ec4fe 100755
21--- libvirt-python-1.2.4.orig/setup.py 21--- a/setup.py
22+++ libvirt-python-1.2.4/setup.py 22+++ b/setup.py
23@@ -40,13 +40,7 @@ 23@@ -43,13 +43,7 @@ def check_minimum_libvirt_version():
24 "libvirt"]) 24 "libvirt"])
25 25
26 def have_libvirt_lxc(): 26 def have_libvirt_lxc():
@@ -33,9 +33,9 @@ Index: libvirt-python-1.2.4/setup.py
33- return False 33- return False
34+ return True 34+ return True
35 35
36 def get_pkgconfig_data(args, mod, required=True): 36 def have_libvirtaio():
37 """Run pkg-config to and return content associated with it""" 37 # This depends on asyncio, which in turn depends on "yield from" syntax.
38@@ -68,7 +62,17 @@ 38@@ -77,7 +71,17 @@ def get_api_xml_files():
39 """Check with pkg-config that libvirt is present and extract 39 """Check with pkg-config that libvirt is present and extract
40 the API XML file paths we need from it""" 40 the API XML file paths we need from it"""
41 41
@@ -54,7 +54,7 @@ Index: libvirt-python-1.2.4/setup.py
54 54
55 offset = libvirt_api.index("-api.xml") 55 offset = libvirt_api.index("-api.xml")
56 libvirt_qemu_api = libvirt_api[0:offset] + "-qemu-api.xml" 56 libvirt_qemu_api = libvirt_api[0:offset] + "-qemu-api.xml"
57@@ -88,8 +92,17 @@ 57@@ -97,8 +101,17 @@ def get_module_lists():
58 58
59 c_modules = [] 59 c_modules = []
60 py_modules = [] 60 py_modules = []
@@ -74,7 +74,7 @@ Index: libvirt-python-1.2.4/setup.py
74 74
75 module = Extension('libvirtmod', 75 module = Extension('libvirtmod',
76 sources = ['libvirt-override.c', 'build/libvirt.c', 'typewrappers.c', 'libvirt-utils.c'], 76 sources = ['libvirt-override.c', 'build/libvirt.c', 'typewrappers.c', 'libvirt-utils.c'],
77@@ -138,7 +151,7 @@ 77@@ -144,7 +157,7 @@ def get_module_lists():
78 class my_build(build): 78 class my_build(build):
79 79
80 def run(self): 80 def run(self):
@@ -83,3 +83,5 @@ Index: libvirt-python-1.2.4/setup.py
83 apis = get_api_xml_files() 83 apis = get_api_xml_files()
84 84
85 self.spawn([sys.executable, "generator.py", "libvirt", apis[0]]) 85 self.spawn([sys.executable, "generator.py", "libvirt", apis[0]])
86--
872.17.0