diff options
Diffstat (limited to 'recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch')
-rw-r--r-- | recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch | 14 |
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch b/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch index 16321db5..3c2622c7 100644 --- a/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch +++ b/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch | |||
@@ -10,6 +10,8 @@ one installed in the system. This may be used for example in autotest | |||
10 | or by packagers without the need to install libvirt into the system. | 10 | or by packagers without the need to install libvirt into the system. |
11 | 11 | ||
12 | Signed-off-by: Martin Kletzander <mkletzan redhat com> | 12 | Signed-off-by: Martin Kletzander <mkletzan redhat com> |
13 | [ywei: rebased to 1.3.2] | ||
14 | Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com> | ||
13 | --- | 15 | --- |
14 | setup.py | 25 ++++++++++++++++++++++--- | 16 | setup.py | 25 ++++++++++++++++++++++--- |
15 | 1 file changed, 22 insertions(+), 3 deletions(-) | 17 | 1 file changed, 22 insertions(+), 3 deletions(-) |
@@ -56,19 +58,19 @@ Index: libvirt-python-1.2.4/setup.py | |||
56 | 58 | ||
57 | c_modules = [] | 59 | c_modules = [] |
58 | py_modules = [] | 60 | py_modules = [] |
59 | - ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False) | 61 | - ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False).split() |
60 | - cflags = get_pkgconfig_data(["--cflags"], "libvirt", False) | 62 | - cflags = get_pkgconfig_data(["--cflags"], "libvirt", False).split() |
61 | + libvirt_cflags = os.getenv("LIBVIRT_CFLAGS") | 63 | + libvirt_cflags = os.getenv("LIBVIRT_CFLAGS") |
62 | + if libvirt_cflags: | 64 | + if libvirt_cflags: |
63 | + cflags = libvirt_cflags | 65 | + cflags = libvirt_cflags.split() |
64 | + else: | 66 | + else: |
65 | + cflags = get_pkgconfig_data(["--cflags"], "libvirt", False) | 67 | + cflags = get_pkgconfig_data(["--cflags"], "libvirt", False).split() |
66 | + | 68 | + |
67 | + libvirt_libs = os.getenv("LIBVIRT_LIBS") | 69 | + libvirt_libs = os.getenv("LIBVIRT_LIBS") |
68 | + if libvirt_libs: | 70 | + if libvirt_libs: |
69 | + ldflags = libvirt_libs | 71 | + ldflags = libvirt_libs.split() |
70 | + else: | 72 | + else: |
71 | + ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False) | 73 | + ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False).split() |
72 | 74 | ||
73 | module = Extension('libvirtmod', | 75 | module = Extension('libvirtmod', |
74 | sources = ['libvirt-override.c', 'build/libvirt.c', 'typewrappers.c', 'libvirt-utils.c'], | 76 | sources = ['libvirt-override.c', 'build/libvirt.c', 'typewrappers.c', 'libvirt-utils.c'], |