summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch')
-rw-r--r--recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch
new file mode 100644
index 00000000..6504d86e
--- /dev/null
+++ b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch
@@ -0,0 +1,59 @@
1From d79dcc2002008c58683de82f06c168d6eea57991 Mon Sep 17 00:00:00 2001
2From: Maciej Pijanowski <maciej.pijanowski@3mdeb.com>
3Date: Fri, 19 Oct 2018 11:01:37 +0200
4Subject: [PATCH] python,pygrub: pass DISTUTILS env vars as setup.py args
5
6Allow to respect the target install dir (PYTHON_SITEPACKAGES_DIR)
7as well as other parameters set by the OpenEmbedded build system.
8This is especially useful when the target libdir is not the default one
9(/usr/lib), but for example /usr/lib64.
10
11Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com>
12
13Forward-ported to Xen 4.12.0
14Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
15
16diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile
17index 3063c49..513314b 100644
18--- a/tools/pygrub/Makefile
19+++ b/tools/pygrub/Makefile
20@@ -10,14 +10,15 @@ INSTALL_LOG = build/installed_files.txt
21 all: build
22 .PHONY: build
23 build:
24- CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build
25+ CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS)
26
27 .PHONY: install
28 install: all
29 $(INSTALL_DIR) $(DESTDIR)/$(bindir)
30 CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \
31 setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \
32- --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force
33+ --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force \
34+ $(DISTUTILS_INSTALL_ARGS)
35 set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \
36 "`readlink -f $(DESTDIR)/$(bindir)`" != \
37 "`readlink -f $(LIBEXEC_BIN)`" ]; then \
38diff --git a/tools/python/Makefile b/tools/python/Makefile
39index 541858e..4d4a344 100644
40--- a/tools/python/Makefile
41+++ b/tools/python/Makefile
42@@ -10,7 +10,7 @@ INSTALL_LOG = build/installed_files.txt
43
44 .PHONY: build
45 build:
46- CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build
47+ CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS)
48
49 .PHONY: install
50 install:
51@@ -18,7 +18,7 @@ install:
52
53 CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \
54 setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \
55- --root="$(DESTDIR)" --force
56+ --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS)
57
58 $(INSTALL_PROG) scripts/convert-legacy-stream $(DESTDIR)$(LIBEXEC_BIN)
59 $(INSTALL_PROG) scripts/verify-stream-v2 $(DESTDIR)$(LIBEXEC_BIN)