summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch')
-rw-r--r--recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch
index 6504d86e..96e907d5 100644
--- a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch
+++ b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch
@@ -13,11 +13,14 @@ Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com>
13Forward-ported to Xen 4.12.0 13Forward-ported to Xen 4.12.0
14Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> 14Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
15 15
16Modified to support pygrub installation with python 3
17Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
18
16diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile 19diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile
17index 3063c49..513314b 100644 20index 3063c49..513314b 100644
18--- a/tools/pygrub/Makefile 21--- a/tools/pygrub/Makefile
19+++ b/tools/pygrub/Makefile 22+++ b/tools/pygrub/Makefile
20@@ -10,14 +10,15 @@ INSTALL_LOG = build/installed_files.txt 23@@ -10,14 +10,17 @@ INSTALL_LOG = build/installed_files.txt
21 all: build 24 all: build
22 .PHONY: build 25 .PHONY: build
23 build: 26 build:
@@ -32,6 +35,8 @@ index 3063c49..513314b 100644
32- --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force 35- --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force
33+ --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force \ 36+ --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force \
34+ $(DISTUTILS_INSTALL_ARGS) 37+ $(DISTUTILS_INSTALL_ARGS)
38+ rm -f $(DESTDIR)/$(LIBEXEC_BIN)/pygrub
39+ $(INSTALL_PYTHON_PROG) src/pygrub $(DESTDIR)/$(LIBEXEC_BIN)/pygrub
35 set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \ 40 set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \
36 "`readlink -f $(DESTDIR)/$(bindir)`" != \ 41 "`readlink -f $(DESTDIR)/$(bindir)`" != \
37 "`readlink -f $(LIBEXEC_BIN)`" ]; then \ 42 "`readlink -f $(LIBEXEC_BIN)`" ]; then \