summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/dtc/files/setuptools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/dtc/files/setuptools.patch')
-rw-r--r--recipes-kernel/dtc/files/setuptools.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-kernel/dtc/files/setuptools.patch b/recipes-kernel/dtc/files/setuptools.patch
new file mode 100644
index 00000000..3d37ebdc
--- /dev/null
+++ b/recipes-kernel/dtc/files/setuptools.patch
@@ -0,0 +1,34 @@
1Upstream-Status: Backport
2Signed-off-by: Ross Burton <ross.burton@arm.com>
3
4From c691776ddb26acbd3674722caafacaf7b6e3e807 Mon Sep 17 00:00:00 2001
5From: Rob Herring <robh@kernel.org>
6Date: Wed, 10 Nov 2021 19:11:32 -0600
7Subject: [PATCH] pylibfdt: Use setuptools instead of distutils
8
9The use of setuptools is favored over distutils. setuptools is needed to
10support building Python 'wheels' and for pip support.
11
12Signed-off-by: Rob Herring <robh@kernel.org>
13Message-Id: <20211111011135.2386773-2-robh@kernel.org>
14Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
15---
16 pylibfdt/setup.py | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/pylibfdt/setup.py b/pylibfdt/setup.py
20index ef40f15..f065a59 100755
21--- a/pylibfdt/setup.py
22+++ b/pylibfdt/setup.py
23@@ -10,7 +10,7 @@ Copyright (C) 2017 Google, Inc.
24 Written by Simon Glass <sjg@chromium.org>
25 """
26
27-from distutils.core import setup, Extension
28+from setuptools import setup, Extension
29 import os
30 import re
31 import sys
32--
332.25.1
34