summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch-git
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch-git')
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch79
1 files changed, 60 insertions, 19 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch
index b79cb1bc..7e740441 100644
--- a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch
@@ -1,23 +1,38 @@
1Add test-install rule to support ptest execution 1From e20556d7cf0fc8258db77c1f3e0a160cf9fd4514 Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com>
3Date: Wed, 30 Mar 2016 06:23:45 -0400
4Subject: [PATCH] openvswitch: Add test-install rule to support ptest execution
2 5
3Signed-off-by: Radu Patriu <radu.patriu@enea.com> 6Signed-off-by: Radu Patriu <radu.patriu@enea.com>
4 7
8Fix ptest for v2.5
9 - Copy certain files from srcdir since it has been different from
10 build directory.
11 - Copy more necessary files for new added test cases.
12 - Modify config files for running on target.
13
14Signed-off-by: He Zhe <zhe.he@windriver.com>
5--- 15---
6 Makefile.am | 2 ++ 16 Makefile.am | 1 +
7 test.mk | 49 +++++++++++++++++++++++++++++++++++++++++++++++++ 17 test.mk | 72 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
8 2 files changed, 51 insertions(+) 18 2 files changed, 73 insertions(+)
19 create mode 100644 test.mk
9 20
21diff --git a/Makefile.am b/Makefile.am
22index ed43c2f..f38d278 100644
10--- a/Makefile.am 23--- a/Makefile.am
11+++ b/Makefile.am 24+++ b/Makefile.am
12@@ -401,3 +401,5 @@ 25@@ -401,3 +401,4 @@ include datapath-windows/include/automake.mk
13 include windows/automake.mk 26 include windows/automake.mk
14 include ovn/automake.mk 27 include ovn/automake.mk
15 include selinux/automake.mk 28 include selinux/automake.mk
16+include test.mk 29+include test.mk
17+ 30diff --git a/test.mk b/test.mk
31new file mode 100644
32index 0000000..b10a581
18--- /dev/null 33--- /dev/null
19+++ b/test.mk 34+++ b/test.mk
20@@ -0,0 +1,49 @@ 35@@ -0,0 +1,72 @@
21+TEST_DEST ?= ${prefix}/lib/openvswitch 36+TEST_DEST ?= ${prefix}/lib/openvswitch
22+TEST_ROOT ?= ${prefix}/lib/openvswitch 37+TEST_ROOT ?= ${prefix}/lib/openvswitch
23+TEST_DEPEND = 38+TEST_DEPEND =
@@ -29,37 +44,53 @@ Signed-off-by: Radu Patriu <radu.patriu@enea.com>
29+test-install: $(TEST_DEPEND) 44+test-install: $(TEST_DEPEND)
30+ @list='$(noinst_PROGRAMS) $(EXTRA_DIST) $(dist_check_SCRIPTS) $(TEST_DEPEND) tests/atlocal tests/atconfig' ;\ 45+ @list='$(noinst_PROGRAMS) $(EXTRA_DIST) $(dist_check_SCRIPTS) $(TEST_DEPEND) tests/atlocal tests/atconfig' ;\
31+ install -d $(TEST_DEST)/tests ;\ 46+ install -d $(TEST_DEST)/tests ;\
47+ install $(srcdir)/vtep/ovs-vtep $(TEST_DEST)/tests ;\
32+ install -d $(TEST_DEST)/python ;\ 48+ install -d $(TEST_DEST)/python ;\
33+ install -d $(TEST_DEST)/python/ovs ;\ 49+ install -d $(TEST_DEST)/python/ovs ;\
34+ install -d $(TEST_DEST)/python/ovs/db ;\ 50+ install -d $(TEST_DEST)/python/ovs/db ;\
35+ install -d $(TEST_DEST)/python/ovs/unixctl ;\ 51+ install -d $(TEST_DEST)/python/ovs/unixctl ;\
36+ install -d $(TEST_DEST)/vswitchd ;\ 52+ install -d $(TEST_DEST)/vswitchd ;\
37+ install vswitchd/vswitch.ovsschema $(TEST_DEST)/vswitchd ;\ 53+ install $(srcdir)/vswitchd/vswitch.ovsschema $(TEST_DEST)/vswitchd ;\
54+ install vswitchd/ovs-vswitchd $(TEST_DEST)/vswitchd ;\
38+ install -d $(TEST_DEST)/debian ;\ 55+ install -d $(TEST_DEST)/debian ;\
39+ install debian/ovs-monitor-ipsec $(TEST_DEST)/debian ;\ 56+ install $(srcdir)/debian/ovs-monitor-ipsec $(TEST_DEST)/debian ;\
40+ install -d $(TEST_DEST)/build-aux ;\ 57+ install -d $(TEST_DEST)/build-aux ;\
41+ install build-aux/check-structs $(TEST_DEST)/build-aux ;\ 58+ install $(srcdir)/build-aux/check-structs $(TEST_DEST)/build-aux ;\
42+ install -d $(TEST_DEST)/xenserver ;\ 59+ install -d $(TEST_DEST)/xenserver ;\
43+ install xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync $(TEST_DEST)/xenserver ;\ 60+ install $(srcdir)/xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync $(TEST_DEST)/xenserver ;\
44+ install xenserver/opt_xensource_libexec_interface-reconfigure $(TEST_DEST)/xenserver ;\ 61+ install $(srcdir)/xenserver/opt_xensource_libexec_interface-reconfigure $(TEST_DEST)/xenserver ;\
45+ install xenserver/opt_xensource_libexec_InterfaceReconfigure.py $(TEST_DEST)/xenserver ;\ 62+ install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigure.py $(TEST_DEST)/xenserver ;\
46+ install xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py $(TEST_DEST)/xenserver ;\ 63+ install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py $(TEST_DEST)/xenserver ;\
47+ install xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py $(TEST_DEST)/xenserver ;\ 64+ install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py $(TEST_DEST)/xenserver ;\
48+ install -d $(TEST_DEST)/vtep ;\ 65+ install -d $(TEST_DEST)/vtep ;\
49+ install vtep/vtep.ovsschema $(TEST_DEST)/vtep ;\ 66+ install $(srcdir)/vtep/vtep.ovsschema $(TEST_DEST)/vtep ;\
67+ install -d $(TEST_DEST)/ovn ;\
68+ install $(srcdir)/ovn/ovn-nb.ovsschema $(TEST_DEST)/ovn ;\
69+ install $(srcdir)/ovn/ovn-sb.ovsschema $(TEST_DEST)/ovn ;\
70+ install -d $(TEST_DEST)/utilities ;\
71+ install $(srcdir)/utilities/ovs-pcap.in $(TEST_DEST)/utilities ;\
72+ install $(srcdir)/utilities/ovs-pki.in $(TEST_DEST)/utilities ;\
50+ for p in $$list ; do \ 73+ for p in $$list ; do \
51+ echo $$p ;\ 74+ echo $$p ;\
52+ p=$${p#./} ;\ 75+ p=$${p#../git/} ;\
53+ pre=$${p#tests\/} ;\ 76+ pre=$${p#tests\/} ;\
54+ if test $$pre != $$p ; then \ 77+ if test $$pre != $$p ; then \
55+ echo installing $$p to $(TEST_DEST)/tests/$$pre ;\ 78+ echo installing $$p to $(TEST_DEST)/tests/$$pre ;\
56+ install $$p $(TEST_DEST)/tests/$$pre ;\ 79+ if test -f $$p ; then \
80+ install $$p $(TEST_DEST)/tests/$$pre ;\
81+ else \
82+ install $(srcdir)/$$p $(TEST_DEST)/tests/$$pre ;\
83+ fi ;\
57+ continue ;\ 84+ continue ;\
58+ fi ;\ 85+ fi ;\
59+ pre=$${p#python\/ovs\/} ;\ 86+ pre=$${p#python\/ovs\/} ;\
60+ if test $$pre != $$p ; then \ 87+ if test $$pre != $$p ; then \
61+ echo installing $$p to $(TEST_DEST)/python/ovs/$$pre ;\ 88+ echo installing $$p to $(TEST_DEST)/python/ovs/$$pre ;\
62+ install $$p $(TEST_DEST)/python/ovs/$$pre ;\ 89+ if test -f $$p ; then \
90+ install $$p $(TEST_DEST)/python/ovs/$$pre ;\
91+ else \
92+ install $(srcdir)/$$p $(TEST_DEST)/python/ovs/$$pre ;\
93+ fi ;\
63+ continue ;\ 94+ continue ;\
64+ fi; \ 95+ fi; \
65+ done ;\ 96+ done ;\
@@ -67,3 +98,13 @@ Signed-off-by: Radu Patriu <radu.patriu@enea.com>
67+ sed -i 's|abs_srcdir=.*|abs_srcdir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig 98+ sed -i 's|abs_srcdir=.*|abs_srcdir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig
68+ sed -i 's|abs_top_srcdir=.*|abs_top_srcdir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig 99+ sed -i 's|abs_top_srcdir=.*|abs_top_srcdir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig
69+ sed -i 's|abs_top_builddir=.*|abs_top_builddir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig 100+ sed -i 's|abs_top_builddir=.*|abs_top_builddir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig
101+ sed -i 's|at_srcdir=.*|at_srcdir='"'"'.'"'"'|g' $(TEST_DEST)/tests/atconfig
102+ sed -i 's|at_top_srcdir=.*|at_top_srcdir='"'"'..'"'"'|g' $(TEST_DEST)/tests/atconfig
103+ sed -i 's|at_top_build_prefix=.*|at_top_build_prefix='"'"'../'"'"'|g' $(TEST_DEST)/tests/atconfig
104+ sed -i 's|^\(.*config\.log.*\)|#\1|g' $(TEST_DEST)/tests/testsuite
105+ sed -i 's|$$srcdir|$$abs_srcdir|g' $(TEST_DEST)/tests/testsuite
106+ sed -i 's|ovs-appctl-bashcomp\.bash|/etc/bash_completion.d/ovs-appctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite
107+ sed -i 's|ovs-vsctl-bashcomp\.bash|/etc/bash_completion.d/ovs-vsctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite
108--
1091.9.1
110