summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2025-04-22 09:42:32 -0600
committerMark Hatle <mark.hatle@amd.com>2025-05-08 13:58:14 -0500
commitcd70c8d08de48963fe1a5d61d532a12b1d0730fc (patch)
tree7218f1f5cba79420203dbf78e21c2adeae729107
parent80923f7036d91b7c4ba20b19ca61f258b53295dc (diff)
downloadmeta-xilinx-scarthgap.tar.gz
meta-xilinx-mali400: xf86-video-armsoc: Only apply when libmali-xlnx is enabledscarthgap
The patches add acceleration optimizations to the build, but should only be enabled if libmali-xlnx is going to be used. So switch based on DEPENDS, and then adjust the DEPENDS to be switched based on the PREFERRED_PROVIDER of virtual/libgles1. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-mali400/dynamic-layers/openembedded-layer/recipes-graphics/xorg-driver/xf86-video-armsoc_%.bbappend7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-xilinx-mali400/dynamic-layers/openembedded-layer/recipes-graphics/xorg-driver/xf86-video-armsoc_%.bbappend b/meta-xilinx-mali400/dynamic-layers/openembedded-layer/recipes-graphics/xorg-driver/xf86-video-armsoc_%.bbappend
index e6ae6b42..ba44ca50 100644
--- a/meta-xilinx-mali400/dynamic-layers/openembedded-layer/recipes-graphics/xorg-driver/xf86-video-armsoc_%.bbappend
+++ b/meta-xilinx-mali400/dynamic-layers/openembedded-layer/recipes-graphics/xorg-driver/xf86-video-armsoc_%.bbappend
@@ -3,7 +3,10 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/xf86-video-armsoc:"
3EXTRA_MALI400_SRC = " file://0001-xf86-video-armosc-Accelerate-picture-composition.patch \ 3EXTRA_MALI400_SRC = " file://0001-xf86-video-armosc-Accelerate-picture-composition.patch \
4 file://0001-xf86-video-armosc-Option-to-control-acceleration.patch \ 4 file://0001-xf86-video-armosc-Option-to-control-acceleration.patch \
5 " 5 "
6SRC_URI:append = "${@bb.utils.contains('MACHINE_FEATURES', 'mali400', '${EXTRA_MALI400_SRC}', '', d)}" 6DEPENDS:append = "${@' libmali-xlnx' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else ''}"
7 7
8DEPENDS:append = "${@bb.utils.contains('MACHINE_FEATURES', 'mali400', ' libmali-xlnx', '', d)}" 8SRC_URI:append = "${@bb.utils.contains('DEPENDS', 'libmali-xlnx', '${EXTRA_MALI400_SRC}', '', d)}"
9 9
10# Links to libmali-xlnx, so it becomes MACHINE_ARCH specific
11DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}"
12PACKAGE_ARCH = "${@bb.utils.contains('DEPENDS', 'libmali-xlnx', '${MACHINE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}"