summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-04-17 18:35:59 -0600
committerMark Hatle <mark.hatle@amd.com>2024-04-19 09:47:30 -0600
commit0fe7863a5a587be2802bce104c9d75b6d707dcdc (patch)
tree1fab94773f1c565093d68f11ea18985045f958e0
parentf768b5cd22664552b92efba6f7e107748785c3ac (diff)
downloadmeta-xilinx-0fe7863a5a587be2802bce104c9d75b6d707dcdc.tar.gz
kernel-module-hdmi: Add historic 2022.1 version
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/recipes-kernel/hdmi/kernel-module-hdmi_2022.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-kernel/hdmi/kernel-module-hdmi_2022.1.bb b/meta-xilinx-core/recipes-kernel/hdmi/kernel-module-hdmi_2022.1.bb
new file mode 100644
index 00000000..ea649bc4
--- /dev/null
+++ b/meta-xilinx-core/recipes-kernel/hdmi/kernel-module-hdmi_2022.1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Xilinx HDMI Linux Kernel module"
2DESCRIPTION = "Out-of-tree HDMI kernel modules provider for MPSoC EG/EV devices"
3SECTION = "kernel/modules"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=b34277fe156508fd5a650609dc36d1fe"
6
7XLNX_HDMI_VERSION = "5.15.0"
8PV = "${XLNX_HDMI_VERSION}+xilinx-v${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or ''}+git${SRCPV}"
9
10S = "${WORKDIR}/git"
11
12BRANCH ?= "xlnx_rel_v2022.1"
13REPO ?= "git://github.com/Xilinx/hdmi-modules.git;protocol=https"
14SRCREV = "25b6fe7a26a975be15c002b48cfd4c291486491e"
15
16BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
17SRC_URI = "${REPO};${BRANCHARG}"
18
19inherit module
20
21EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}"
22COMPATIBLE_MACHINE = "^$"
23COMPATIBLE_MACHINE:zynqmp = "zynqmp"
24COMPATIBLE_MACHINE:versal = "versal"