diff options
author | Mark Hatle <mark.hatle@amd.com> | 2024-03-26 18:56:55 -0600 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-04-24 08:48:39 -0600 |
commit | 7965de51f877c3dff9f9ca08a2f95cc80b0ed598 (patch) | |
tree | 018d7a6e3389caabcfc1f52ab581dfca4431b4e6 | |
parent | f44129b3c4a3d45516c353f21f9331eb0993c59a (diff) | |
download | meta-xilinx-7965de51f877c3dff9f9ca08a2f95cc80b0ed598.tar.gz |
kernel-module-mali: Version based to match linux-xlnx kernel
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r-- | meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2022.1.bb (renamed from meta-xilinx-core/recipes-graphics/mali/kernel-module-mali.bb) | 7 | ||||
-rw-r--r-- | meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2022.2.bb | 54 | ||||
-rw-r--r-- | meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.1.bb | 58 | ||||
-rw-r--r-- | meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.2.bb | 58 |
4 files changed, 174 insertions, 3 deletions
diff --git a/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali.bb b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2022.1.bb index 268759c2..56431a7f 100644 --- a/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali.bb +++ b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2022.1.bb | |||
@@ -6,10 +6,11 @@ LIC_FILES_CHKSUM = " \ | |||
6 | file://linux/license/gpl/mali_kernel_license.h;md5=f5af2d61f4c1eb262cb6a557aaa1070a \ | 6 | file://linux/license/gpl/mali_kernel_license.h;md5=f5af2d61f4c1eb262cb6a557aaa1070a \ |
7 | " | 7 | " |
8 | 8 | ||
9 | PV = "r9p0-01rel0" | 9 | MALI_VERSION = "r9p0-01rel0" |
10 | PV =. "${MALI_VERSION}-v" | ||
10 | 11 | ||
11 | SRC_URI = " \ | 12 | SRC_URI = " \ |
12 | https://developer.arm.com/-/media/Files/downloads/mali-drivers/kernel/mali-utgard-gpu/DX910-SW-99002-${PV}.tgz \ | 13 | https://developer.arm.com/-/media/Files/downloads/mali-drivers/kernel/mali-utgard-gpu/DX910-SW-99002-${MALI_VERSION}.tgz \ |
13 | file://0001-Change-Makefile-to-be-compatible-with-Yocto.patch \ | 14 | file://0001-Change-Makefile-to-be-compatible-with-Yocto.patch \ |
14 | file://0002-staging-mali-r8p0-01rel0-Add-the-ZYNQ-ZYNQMP-platfor.patch \ | 15 | file://0002-staging-mali-r8p0-01rel0-Add-the-ZYNQ-ZYNQMP-platfor.patch \ |
15 | file://0003-staging-mali-r8p0-01rel0-Remove-unused-trace-macros.patch \ | 16 | file://0003-staging-mali-r8p0-01rel0-Remove-unused-trace-macros.patch \ |
@@ -42,7 +43,7 @@ inherit features_check module | |||
42 | 43 | ||
43 | PARALLEL_MAKE = "-j 1" | 44 | PARALLEL_MAKE = "-j 1" |
44 | 45 | ||
45 | S = "${WORKDIR}/DX910-SW-99002-${PV}/driver/src/devicedrv/mali" | 46 | S = "${WORKDIR}/DX910-SW-99002-${MALI_VERSION}/driver/src/devicedrv/mali" |
46 | 47 | ||
47 | REQUIRED_MACHINE_FEATURES = "mali400" | 48 | REQUIRED_MACHINE_FEATURES = "mali400" |
48 | 49 | ||
diff --git a/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2022.2.bb b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2022.2.bb new file mode 100644 index 00000000..e8e46543 --- /dev/null +++ b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2022.2.bb | |||
@@ -0,0 +1,54 @@ | |||
1 | SUMMARY = "A Mali 400 Linux Kernel module" | ||
2 | SECTION = "kernel/modules" | ||
3 | |||
4 | LICENSE = "GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://linux/license/gpl/mali_kernel_license.h;md5=f5af2d61f4c1eb262cb6a557aaa1070a \ | ||
7 | " | ||
8 | |||
9 | MALI_VERSION = "r9p0-01rel0" | ||
10 | PV =. "${MALI_VERSION}-v" | ||
11 | |||
12 | SRC_URI = " \ | ||
13 | https://developer.arm.com/-/media/Files/downloads/mali-drivers/kernel/mali-utgard-gpu/DX910-SW-99002-${MALI_VERSION}.tgz \ | ||
14 | file://0001-Change-Makefile-to-be-compatible-with-Yocto.patch \ | ||
15 | file://0002-staging-mali-r8p0-01rel0-Add-the-ZYNQ-ZYNQMP-platfor.patch \ | ||
16 | file://0003-staging-mali-r8p0-01rel0-Remove-unused-trace-macros.patch \ | ||
17 | file://0004-staging-mali-r8p0-01rel0-Don-t-include-mali_read_phy.patch \ | ||
18 | file://0005-linux-mali_kernel_linux.c-Handle-clock-when-probed-a.patch \ | ||
19 | file://0006-arm.c-global-variable-dma_ops-is-removed-from-the-ke.patch \ | ||
20 | file://0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch \ | ||
21 | file://0011-linux-mali_kernel_linux.c-Enable-disable-clock-for-r.patch\ | ||
22 | file://0012-linux-mali_memory_os_alloc-Remove-__GFP_COLD.patch\ | ||
23 | file://0013-linux-mali_memory_secure-Add-header-file-dma-direct..patch\ | ||
24 | file://0014-linux-mali_-timer-Get-rid-of-init_timer.patch\ | ||
25 | file://0015-fix-driver-failed-to-check-map-error.patch \ | ||
26 | file://0016-mali_memory_secure-Kernel-5.0-onwards-access_ok-API-.patch \ | ||
27 | file://0017-Support-for-vm_insert_pfn-deprecated-from-kernel-4.2.patch \ | ||
28 | file://0018-Change-return-type-to-vm_fault_t-for-fault-handler.patch \ | ||
29 | file://0019-get_monotonic_boottime-ts-deprecated-from-kernel-4.2.patch \ | ||
30 | file://0020-Fix-ioremap_nocache-deprecation-in-kernel-5.6.patch \ | ||
31 | file://0021-Use-updated-timekeeping-functions-in-kernel-5.6.patch \ | ||
32 | file://0022-Set-HAVE_UNLOCKED_IOCTL-default-to-true.patch \ | ||
33 | file://0023-Use-PTR_ERR_OR_ZERO-instead-of-PTR_RET.patch \ | ||
34 | " | ||
35 | SRC_URI[md5sum] = "85ea110dd6675c70b7d01af87ec9633c" | ||
36 | SRC_URI[sha256sum] = "7a67127341d17640c1fff5dad80258fb2a37c8a2121b81525fe2327e4532ce2b" | ||
37 | |||
38 | inherit features_check module | ||
39 | |||
40 | PARALLEL_MAKE = "-j 1" | ||
41 | |||
42 | S = "${WORKDIR}/DX910-SW-99002-${MALI_VERSION}/driver/src/devicedrv/mali" | ||
43 | |||
44 | REQUIRED_MACHINE_FEATURES = "mali400" | ||
45 | |||
46 | EXTRA_OEMAKE = 'KDIR="${STAGING_KERNEL_DIR}" \ | ||
47 | ARCH="${ARCH}" \ | ||
48 | BUILD=release \ | ||
49 | MALI_PLATFORM="arm" \ | ||
50 | USING_DT=1 \ | ||
51 | MALI_SHARED_INTERRUPTS=1 \ | ||
52 | CROSS_COMPILE="${TARGET_PREFIX}" \ | ||
53 | MALI_QUIET=1 \ | ||
54 | ' | ||
diff --git a/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.1.bb b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.1.bb new file mode 100644 index 00000000..56431a7f --- /dev/null +++ b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.1.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | SUMMARY = "A Mali 400 Linux Kernel module" | ||
2 | SECTION = "kernel/modules" | ||
3 | |||
4 | LICENSE = "GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://linux/license/gpl/mali_kernel_license.h;md5=f5af2d61f4c1eb262cb6a557aaa1070a \ | ||
7 | " | ||
8 | |||
9 | MALI_VERSION = "r9p0-01rel0" | ||
10 | PV =. "${MALI_VERSION}-v" | ||
11 | |||
12 | SRC_URI = " \ | ||
13 | https://developer.arm.com/-/media/Files/downloads/mali-drivers/kernel/mali-utgard-gpu/DX910-SW-99002-${MALI_VERSION}.tgz \ | ||
14 | file://0001-Change-Makefile-to-be-compatible-with-Yocto.patch \ | ||
15 | file://0002-staging-mali-r8p0-01rel0-Add-the-ZYNQ-ZYNQMP-platfor.patch \ | ||
16 | file://0003-staging-mali-r8p0-01rel0-Remove-unused-trace-macros.patch \ | ||
17 | file://0004-staging-mali-r8p0-01rel0-Don-t-include-mali_read_phy.patch \ | ||
18 | file://0005-linux-mali_kernel_linux.c-Handle-clock-when-probed-a.patch \ | ||
19 | file://0006-arm.c-global-variable-dma_ops-is-removed-from-the-ke.patch \ | ||
20 | file://0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch \ | ||
21 | file://0011-linux-mali_kernel_linux.c-Enable-disable-clock-for-r.patch\ | ||
22 | file://0012-linux-mali_memory_os_alloc-Remove-__GFP_COLD.patch\ | ||
23 | file://0013-linux-mali_memory_secure-Add-header-file-dma-direct..patch\ | ||
24 | file://0014-linux-mali_-timer-Get-rid-of-init_timer.patch\ | ||
25 | file://0015-fix-driver-failed-to-check-map-error.patch \ | ||
26 | file://0016-mali_memory_secure-Kernel-5.0-onwards-access_ok-API-.patch \ | ||
27 | file://0017-Support-for-vm_insert_pfn-deprecated-from-kernel-4.2.patch \ | ||
28 | file://0018-Change-return-type-to-vm_fault_t-for-fault-handler.patch \ | ||
29 | file://0019-get_monotonic_boottime-ts-deprecated-from-kernel-4.2.patch \ | ||
30 | file://0020-Fix-ioremap_nocache-deprecation-in-kernel-5.6.patch \ | ||
31 | file://0021-Use-updated-timekeeping-functions-in-kernel-5.6.patch \ | ||
32 | file://0022-Set-HAVE_UNLOCKED_IOCTL-default-to-true.patch \ | ||
33 | file://0023-Use-PTR_ERR_OR_ZERO-instead-of-PTR_RET.patch \ | ||
34 | file://0024-Use-community-device-tree-names.patch \ | ||
35 | file://0025-Import-DMA_BUF-module-and-update-register_shrinker-f.patch \ | ||
36 | file://0026-Fix-gpu-driver-probe-failure.patch \ | ||
37 | file://0027-Updated-clock-name-and-structure-to-match-LIMA-drive.patch \ | ||
38 | " | ||
39 | SRC_URI[md5sum] = "85ea110dd6675c70b7d01af87ec9633c" | ||
40 | SRC_URI[sha256sum] = "7a67127341d17640c1fff5dad80258fb2a37c8a2121b81525fe2327e4532ce2b" | ||
41 | |||
42 | inherit features_check module | ||
43 | |||
44 | PARALLEL_MAKE = "-j 1" | ||
45 | |||
46 | S = "${WORKDIR}/DX910-SW-99002-${MALI_VERSION}/driver/src/devicedrv/mali" | ||
47 | |||
48 | REQUIRED_MACHINE_FEATURES = "mali400" | ||
49 | |||
50 | EXTRA_OEMAKE = 'KDIR="${STAGING_KERNEL_DIR}" \ | ||
51 | ARCH="${ARCH}" \ | ||
52 | BUILD=release \ | ||
53 | MALI_PLATFORM="arm" \ | ||
54 | USING_DT=1 \ | ||
55 | MALI_SHARED_INTERRUPTS=1 \ | ||
56 | CROSS_COMPILE="${TARGET_PREFIX}" \ | ||
57 | MALI_QUIET=1 \ | ||
58 | ' | ||
diff --git a/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.2.bb b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.2.bb new file mode 100644 index 00000000..56431a7f --- /dev/null +++ b/meta-xilinx-core/recipes-graphics/mali/kernel-module-mali_2023.2.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | SUMMARY = "A Mali 400 Linux Kernel module" | ||
2 | SECTION = "kernel/modules" | ||
3 | |||
4 | LICENSE = "GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://linux/license/gpl/mali_kernel_license.h;md5=f5af2d61f4c1eb262cb6a557aaa1070a \ | ||
7 | " | ||
8 | |||
9 | MALI_VERSION = "r9p0-01rel0" | ||
10 | PV =. "${MALI_VERSION}-v" | ||
11 | |||
12 | SRC_URI = " \ | ||
13 | https://developer.arm.com/-/media/Files/downloads/mali-drivers/kernel/mali-utgard-gpu/DX910-SW-99002-${MALI_VERSION}.tgz \ | ||
14 | file://0001-Change-Makefile-to-be-compatible-with-Yocto.patch \ | ||
15 | file://0002-staging-mali-r8p0-01rel0-Add-the-ZYNQ-ZYNQMP-platfor.patch \ | ||
16 | file://0003-staging-mali-r8p0-01rel0-Remove-unused-trace-macros.patch \ | ||
17 | file://0004-staging-mali-r8p0-01rel0-Don-t-include-mali_read_phy.patch \ | ||
18 | file://0005-linux-mali_kernel_linux.c-Handle-clock-when-probed-a.patch \ | ||
19 | file://0006-arm.c-global-variable-dma_ops-is-removed-from-the-ke.patch \ | ||
20 | file://0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch \ | ||
21 | file://0011-linux-mali_kernel_linux.c-Enable-disable-clock-for-r.patch\ | ||
22 | file://0012-linux-mali_memory_os_alloc-Remove-__GFP_COLD.patch\ | ||
23 | file://0013-linux-mali_memory_secure-Add-header-file-dma-direct..patch\ | ||
24 | file://0014-linux-mali_-timer-Get-rid-of-init_timer.patch\ | ||
25 | file://0015-fix-driver-failed-to-check-map-error.patch \ | ||
26 | file://0016-mali_memory_secure-Kernel-5.0-onwards-access_ok-API-.patch \ | ||
27 | file://0017-Support-for-vm_insert_pfn-deprecated-from-kernel-4.2.patch \ | ||
28 | file://0018-Change-return-type-to-vm_fault_t-for-fault-handler.patch \ | ||
29 | file://0019-get_monotonic_boottime-ts-deprecated-from-kernel-4.2.patch \ | ||
30 | file://0020-Fix-ioremap_nocache-deprecation-in-kernel-5.6.patch \ | ||
31 | file://0021-Use-updated-timekeeping-functions-in-kernel-5.6.patch \ | ||
32 | file://0022-Set-HAVE_UNLOCKED_IOCTL-default-to-true.patch \ | ||
33 | file://0023-Use-PTR_ERR_OR_ZERO-instead-of-PTR_RET.patch \ | ||
34 | file://0024-Use-community-device-tree-names.patch \ | ||
35 | file://0025-Import-DMA_BUF-module-and-update-register_shrinker-f.patch \ | ||
36 | file://0026-Fix-gpu-driver-probe-failure.patch \ | ||
37 | file://0027-Updated-clock-name-and-structure-to-match-LIMA-drive.patch \ | ||
38 | " | ||
39 | SRC_URI[md5sum] = "85ea110dd6675c70b7d01af87ec9633c" | ||
40 | SRC_URI[sha256sum] = "7a67127341d17640c1fff5dad80258fb2a37c8a2121b81525fe2327e4532ce2b" | ||
41 | |||
42 | inherit features_check module | ||
43 | |||
44 | PARALLEL_MAKE = "-j 1" | ||
45 | |||
46 | S = "${WORKDIR}/DX910-SW-99002-${MALI_VERSION}/driver/src/devicedrv/mali" | ||
47 | |||
48 | REQUIRED_MACHINE_FEATURES = "mali400" | ||
49 | |||
50 | EXTRA_OEMAKE = 'KDIR="${STAGING_KERNEL_DIR}" \ | ||
51 | ARCH="${ARCH}" \ | ||
52 | BUILD=release \ | ||
53 | MALI_PLATFORM="arm" \ | ||
54 | USING_DT=1 \ | ||
55 | MALI_SHARED_INTERRUPTS=1 \ | ||
56 | CROSS_COMPILE="${TARGET_PREFIX}" \ | ||
57 | MALI_QUIET=1 \ | ||
58 | ' | ||