diff options
author | Mark Hatle <mark.hatle@amd.com> | 2024-05-17 15:44:37 -0600 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-05-20 09:06:12 -0600 |
commit | 7dba3fd5d227d954f1aece1d3293fb876146eee0 (patch) | |
tree | 66449d285737de5956904d3c3b15eaf9f316702a | |
parent | 60542eb1dea413c631330524836412cfefc933bb (diff) | |
download | meta-xilinx-7dba3fd5d227d954f1aece1d3293fb876146eee0.tar.gz |
bootgen: Remove obsolete version, move to recipes-devtools
While it can be built for the target it's really a tool to build other
components. So move to recipe-devtools.
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r-- | meta-xilinx-core/recipes-bsp/bootgen/bootgen_1.0.bb | 31 | ||||
-rw-r--r-- | meta-xilinx-core/recipes-bsp/bootgen/bootgen_2023.1.bb | 31 | ||||
-rw-r--r-- | meta-xilinx-core/recipes-devtools/bootgen/bootgen_2023.2.bb (renamed from meta-xilinx-core/recipes-bsp/bootgen/bootgen_2023.2.bb) | 0 |
3 files changed, 0 insertions, 62 deletions
diff --git a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_1.0.bb b/meta-xilinx-core/recipes-bsp/bootgen/bootgen_1.0.bb deleted file mode 100644 index fdf28f41..00000000 --- a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_1.0.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | SUMMARY = "Building and installing bootgen" | ||
2 | DESCRIPTION = "Building and installing bootgen, a Xilinx tool that lets you stitch binary files together and generate device boot images" | ||
3 | |||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d526b6d0807bf263b97da1da876f39b1" | ||
6 | |||
7 | S = "${WORKDIR}/git" | ||
8 | |||
9 | DEPENDS += "openssl" | ||
10 | RDEPENDS:${PN} += "openssl" | ||
11 | |||
12 | REPO ?= "git://github.com/Xilinx/bootgen.git;protocol=https" | ||
13 | BRANCH ?= "xlnx_rel_v2022.2" | ||
14 | SRCREV = "cf4ba93b99644dc4429ef633471a639e1382f0e7" | ||
15 | |||
16 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" | ||
17 | SRC_URI = "${REPO};${BRANCHARG}" | ||
18 | |||
19 | EXTRA_OEMAKE += 'CROSS_COMPILER="${CXX}" -C ${S}' | ||
20 | CXXFLAGS:append = " -std=c++0x" | ||
21 | |||
22 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}${bindir} | ||
26 | install -Dm 0755 ${S}/bootgen ${D}${bindir} | ||
27 | } | ||
28 | |||
29 | FILES:${PN} = "${bindir}/bootgen" | ||
30 | |||
31 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2023.1.bb b/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2023.1.bb deleted file mode 100644 index a934230d..00000000 --- a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2023.1.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | SUMMARY = "Building and installing bootgen" | ||
2 | DESCRIPTION = "Building and installing bootgen, a Xilinx tool that lets you stitch binary files together and generate device boot images" | ||
3 | |||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d526b6d0807bf263b97da1da876f39b1" | ||
6 | |||
7 | S = "${WORKDIR}/git" | ||
8 | |||
9 | DEPENDS += "openssl" | ||
10 | RDEPENDS:${PN} += "openssl" | ||
11 | |||
12 | REPO ?= "git://github.com/Xilinx/bootgen.git;protocol=https" | ||
13 | BRANCH = "xlnx_rel_v2023.1" | ||
14 | SRCREV = "4f1e1caf2c09cdeacc35cbeedaf2550c6e44c7fd" | ||
15 | |||
16 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" | ||
17 | SRC_URI = "${REPO};${BRANCHARG}" | ||
18 | |||
19 | EXTRA_OEMAKE += 'CROSS_COMPILER="${CXX}" -C ${S}' | ||
20 | CXXFLAGS:append = " -std=c++0x" | ||
21 | |||
22 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}${bindir} | ||
26 | install -Dm 0755 ${S}/bootgen ${D}${bindir} | ||
27 | } | ||
28 | |||
29 | FILES:${PN} = "${bindir}/bootgen" | ||
30 | |||
31 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2023.2.bb b/meta-xilinx-core/recipes-devtools/bootgen/bootgen_2023.2.bb index 03f323e1..03f323e1 100644 --- a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2023.2.bb +++ b/meta-xilinx-core/recipes-devtools/bootgen/bootgen_2023.2.bb | |||