diff options
author | Mark Hatle <mark.hatle@amd.com> | 2024-11-04 15:19:24 -0600 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-11-11 11:25:48 -0700 |
commit | c5bee8411533dbc5866c3cbe0c7cfd66d249dc15 (patch) | |
tree | 4070b3a18d5b55a4a6c4a8d04034355cd760997b | |
parent | b3583405d1f771a1efacd9b4da81454d0e0b41d3 (diff) | |
download | meta-xilinx-c5bee8411533dbc5866c3cbe0c7cfd66d249dc15.tar.gz |
xen-boot-cmd: Add xen variable as addendum
For xen boot the u-boot script environment variables needs to
be complied as part of u-boot-xlnx-scr recipe. In order to duplicate
the variables definition for xen and non-xen boot make xen variables
as addendum to u-boot-xlnx-scr recipe.
Upstream-Status: Submitted [https://lists.yoctoproject.org/g/meta-virtualization/message/8233]
Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com>
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Transfer from 2024.2 fork of meta-virtualization, as this won't be in meta-virtualization
scarthgap.
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r-- | meta-xilinx-virtualization/recipes-bsp/u-boot/mxv-xen-boot-cmd.inc | 11 | ||||
-rw-r--r-- | meta-xilinx-virtualization/recipes-bsp/u-boot/u-boot-xlnx-scr.bbappend | 5 |
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-xilinx-virtualization/recipes-bsp/u-boot/mxv-xen-boot-cmd.inc b/meta-xilinx-virtualization/recipes-bsp/u-boot/mxv-xen-boot-cmd.inc new file mode 100644 index 00000000..81f9c5f2 --- /dev/null +++ b/meta-xilinx-virtualization/recipes-bsp/u-boot/mxv-xen-boot-cmd.inc | |||
@@ -0,0 +1,11 @@ | |||
1 | # Add xen variables as addendum. | ||
2 | # Variable SCRIPT_SED_ADDENDUM id defined in meta-xilinx and set to null by | ||
3 | # default and enable only for xen builds. | ||
4 | SCRIPT_SED_ADDENDUM += "-e 's/@@XEN_IMAGE_NAME@@/${XEN_IMAGE_NAME}/' \ | ||
5 | -e 's/@@XEN_OFFSET@@/${XEN_OFFSET}/' \ | ||
6 | -e 's/@@XEN_LOAD_ADDRESS@@/${XEN_LOAD_ADDRESS}/' \ | ||
7 | -e 's/@@DOM0_MEM@@/${DOM0_MEM}/' \ | ||
8 | -e 's/@@DOM0_MAX_VCPUS@@/${DOM0_MAX_VCPUS}/' \ | ||
9 | -e 's:@@XEN_SERIAL_CONSOLES@@:${XEN_SERIAL_CONSOLES}:' \ | ||
10 | -e 's:@@XEN_CMDLINE_APPEND@@:${XEN_CMDLINE_APPEND}:' \ | ||
11 | " | ||
diff --git a/meta-xilinx-virtualization/recipes-bsp/u-boot/u-boot-xlnx-scr.bbappend b/meta-xilinx-virtualization/recipes-bsp/u-boot/u-boot-xlnx-scr.bbappend new file mode 100644 index 00000000..c8a21b3b --- /dev/null +++ b/meta-xilinx-virtualization/recipes-bsp/u-boot/u-boot-xlnx-scr.bbappend | |||
@@ -0,0 +1,5 @@ | |||
1 | # Include xen-boot-cmd.inc only if ENABLE_XEN_UBOOT_SCR is set from configuration | ||
2 | # file and xen enabled in DISTRO_FEATURES. | ||
3 | ENABLE_XEN_UBOOT_SCR ?= "" | ||
4 | include ${@'mxv-xen-boot-cmd.inc' if d.getVar('ENABLE_XEN_UBOOT_SCR') == '1' and bb.utils.contains('DISTRO_FEATURES', 'xen', True, False, d) else ''} | ||
5 | |||