summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-04-18 13:26:35 -0600
committerMark Hatle <mark.hatle@amd.com>2024-04-18 13:26:38 -0600
commitf99abb8b8c93c520348d9992b658fab9a472fd4e (patch)
tree3485ef830b70b32aea679c370c7a307feb555359
parent91f2c546e89b95337c02a9850b6ae2d010f0466f (diff)
downloadmeta-xilinx-f99abb8b8c93c520348d9992b658fab9a472fd4e.tar.gz
meta-xilinx-standalone-experimental: embeddedsw: Fix integration
Fix plm and psm firwmare integration. The class EXPORT behavior has changed in Scarthgap, so sync up to the recent changes to ensure behavior is the same as the prior langdale based system. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_2024.1.bbappend10
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_2024.1.bbappend10
2 files changed, 16 insertions, 4 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_2024.1.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_2024.1.bbappend
index cc6d757f..202764ac 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_2024.1.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_2024.1.bbappend
@@ -17,8 +17,14 @@ do_configure:prepend() {
17 ) 17 )
18} 18}
19 19
20do_compile:append() { 20do_configure() {
21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 cmake_do_configure
22}
23
24do_compile() {
25 cmake_do_compile
26
27 ${OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
22} 28}
23 29
24do_install() { 30do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_2024.1.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_2024.1.bbappend
index c4953ce7..96cd38cd 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_2024.1.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_2024.1.bbappend
@@ -17,8 +17,14 @@ do_configure:prepend() {
17 ) 17 )
18} 18}
19 19
20do_compile:append() { 20do_configure() {
21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 cmake_do_configure
22}
23
24do_compile() {
25 cmake_do_compile
26
27 ${OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
22} 28}
23 29
24do_install() { 30do_install() {