summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/dynamic-layers/virtualization-layer
diff options
context:
space:
mode:
authorSandeep Gundlupet Raju <sandeep.gundlupet-raju@xilinx.com>2022-02-22 19:13:28 -0700
committerMark Hatle <mark.hatle@xilinx.com>2022-02-24 08:20:31 -0800
commit0933332bef5f698b9ce54918b124376ba42e2f41 (patch)
treeb317fbde7527650fc1d359b80ba96317ce3bcca0 /meta-xilinx-core/dynamic-layers/virtualization-layer
parent4a0735c0a7f770df5b43dac6504ca192cb646869 (diff)
downloadmeta-xilinx-0933332bef5f698b9ce54918b124376ba42e2f41.tar.gz
lopper: Update SRCREV to upstream master
1. Update SRCREV to upstream master commit id. 2. Update do_install based on new directory structure in source. Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@xilinx.com> Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> (cherry picked from commit 09b25b908a60c030c1e374e3aa090283d71002e8) Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-core/dynamic-layers/virtualization-layer')
-rw-r--r--meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend13
1 files changed, 6 insertions, 7 deletions
diff --git a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend
index aa552fe5..034dce2d 100644
--- a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend
+++ b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend
@@ -22,28 +22,27 @@ RDEPENDS:${PN} += " \
22" 22"
23 23
24SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master" 24SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master"
25SRCREV = "4fc085c4be031996e7f48dcaf03d0782989c8d58" 25SRCREV = "17350a773a73c426a826e32e4e093effc718ecf5"
26 26
27do_install() { 27do_install() {
28 install -d "${D}/${bindir}" 28 install -d "${D}/${bindir}"
29 install -d "${D}/${datadir}/${BPN}" 29 install -d "${D}/${datadir}/${BPN}"
30 30
31 install -m 0644 "${S}/README" "${D}/${datadir}/${BPN}" 31 install -m 0644 "${S}/README.md" "${D}/${datadir}/${BPN}"
32 install -m 0644 "${S}/README-architecture.txt" "${D}/${datadir}/${BPN}" 32 install -m 0644 "${S}/README-architecture.md" "${D}/${datadir}/${BPN}"
33 install -m 0644 "${S}/README.pydoc" "${D}/${datadir}/${BPN}" 33 install -m 0644 "${S}/README.pydoc" "${D}/${datadir}/${BPN}"
34 install -m 0644 "${S}/LICENSE.md" "${D}/${datadir}/${BPN}" 34 install -m 0644 "${S}/LICENSE.md" "${D}/${datadir}/${BPN}"
35 35
36 install -d "${D}/${datadir}/${BPN}/assists" 36 install -d "${D}/${datadir}/${BPN}/assists"
37 #install -m 0644 "${S}/assists/"* "${D}/${datadir}/${BPN}/assists/" 37 cp -r "${S}/lopper/assists/"* "${D}/${datadir}/${BPN}/assists/"
38 cp -r "${S}/assists/"* "${D}/${datadir}/${BPN}/assists/"
39 38
40 install -d "${D}/${datadir}/${BPN}/lops" 39 install -d "${D}/${datadir}/${BPN}/lops"
41 install -m 0644 "${S}/lops/"* "${D}/${datadir}/${BPN}/lops/" 40 install -m 0644 "${S}/lopper/lops/"* "${D}/${datadir}/${BPN}/lops/"
42 41
43 install -d "${D}/${datadir}/${BPN}/device-trees" 42 install -d "${D}/${datadir}/${BPN}/device-trees"
44 install -m 0644 "${S}/device-trees/"* "${D}/${datadir}/${BPN}/device-trees/" 43 install -m 0644 "${S}/device-trees/"* "${D}/${datadir}/${BPN}/device-trees/"
45 44
46 install -m 0644 "${S}/"lopper.ini "${D}/${datadir}/${BPN}/" 45 install -m 0644 "${S}/lopper/"lopper.ini "${D}/${datadir}/${BPN}/"
47 46
48 install -m 0755 "${S}/"lopper*.py "${D}/${datadir}/${BPN}/" 47 install -m 0755 "${S}/"lopper*.py "${D}/${datadir}/${BPN}/"
49 sed -i 's,#!/usr/bin/python3,#!/usr/bin/env python3,' ${D}/${datadir}/${BPN}/lopper.py 48 sed -i 's,#!/usr/bin/python3,#!/usr/bin/env python3,' ${D}/${datadir}/${BPN}/lopper.py