diff options
author | Swagath Gadde <swagath.gadde@amd.com> | 2024-09-11 17:24:13 +0530 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-09-16 11:38:57 -0500 |
commit | bb8bc7aec43d159f1943f3b8b36e3bfa3ca10a00 (patch) | |
tree | a2eabe6aee0e0013dc0ee104a06c4b1c800f8849 /meta-xilinx-core/dynamic-layers/virtualization-layer | |
parent | 9cc2fb9afc62fe6221bd6e431ed54bf5e8e6b4a1 (diff) | |
download | meta-xilinx-bb8bc7aec43d159f1943f3b8b36e3bfa3ca10a00.tar.gz |
Update lopper srcrev
Changelog:
lopper: assists: xlnx_overlay_dt: Improvments in the assist.
lopper: assist: gen_domain_dts: Update the linux device-tree to delete unneeded nodes.
assists: baremetalconfig_xlnx: Remove the dead code from get_clock_prop().
lops:lop-a53-32bit.dts Add a new lops file to generate apu_map.
lopper: assists: bmcmake_metadata_xlnx: Update the driver example meta-data to take care of windows platform as well.
lopper_sanity: add openamp sanity test.
lopper: add strict mode to nodes().
lops:lop-cpu-oslist Add a new lops file to get ai_engine as cpu.
openamp: xlnx: fix syntax err.
lops: lop-microblaze-riscv: Update multilib mappings.
Signed-off-by: Swagath Gadde <swagath.gadde@amd.com>
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/dynamic-layers/virtualization-layer')
2 files changed, 1 insertions, 41 deletions
diff --git a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper/0001-openamp-xlnx-Fix-typo-in-comparison.patch b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper/0001-openamp-xlnx-Fix-typo-in-comparison.patch deleted file mode 100644 index 64dbc9ae..00000000 --- a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper/0001-openamp-xlnx-Fix-typo-in-comparison.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From 6d4d132ef591a08127895a5058d580f07124597b Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Hatle <mark.hatle@amd.com> | ||
3 | Date: Wed, 28 Aug 2024 14:35:34 -0600 | ||
4 | Subject: [PATCH] openamp: xlnx: Fix typo in comparison | ||
5 | |||
6 | Resolve issue reported as: | ||
7 | [ERROR]: could not load assist: .../usr/lib/python3.12/site-packages/lopper/assists/baremetal_bspconfig_xlnx.py: expected ':' (openamp_xlnx.py, line 200) | ||
8 | [ERROR]: could not load assist: .../usr/lib/python3.12/site-packages/lopper/assists/baremetal_bspconfig_xlnx.py: expected ':' (openamp_xlnx.py, line 1037) | ||
9 | |||
10 | Signed-off-by: Mark Hatle <mark.hatle@amd.com> | ||
11 | --- | ||
12 | lopper/assists/openamp_xlnx.py | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/lopper/assists/openamp_xlnx.py b/lopper/assists/openamp_xlnx.py | ||
16 | index 6fd77b0..5d62000 100644 | ||
17 | --- a/lopper/assists/openamp_xlnx.py | ||
18 | +++ b/lopper/assists/openamp_xlnx.py | ||
19 | @@ -197,7 +197,7 @@ def xlnx_rpmsg_construct_carveouts(tree, carveouts, rpmsg_carveouts, native, cha | ||
20 | new_node = LopperNode(-1, "/reserved-memory/"+carveout.name) | ||
21 | new_node + LopperProp(name="no-map") | ||
22 | new_node + LopperProp(name="reg", value=[0, start, 0, size]) | ||
23 | - if not reserved_mem_node_check(tree, new_node) | ||
24 | + if not reserved_mem_node_check(tree, new_node): | ||
25 | return False | ||
26 | |||
27 | if "vdev0buffer" in carveout.name: | ||
28 | @@ -1034,7 +1034,7 @@ def xlnx_remoteproc_construct_carveouts(tree, carveouts, new_ddr_nodes, verbose | ||
29 | new_node + LopperProp(name="reg", value=[0, start, 0, size]) | ||
30 | tree.add(new_node) | ||
31 | |||
32 | - if not reserved_mem_node_check(tree, new_node) | ||
33 | + if not reserved_mem_node_check(tree, new_node): | ||
34 | return False | ||
35 | |||
36 | phandle_val = new_node.phandle_or_create() | ||
37 | -- | ||
38 | 2.34.1 | ||
diff --git a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend index 1e2798d2..9aba99b3 100644 --- a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend +++ b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend | |||
@@ -1,10 +1,8 @@ | |||
1 | SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master;protocol=https" | 1 | SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master;protocol=https" |
2 | SRCREV = "3c69852c71aba0bf5711b8463fb9ab38345faa42" | 2 | SRCREV = "4644625b8665b190e03b97e3a0e2017b1015e430" |
3 | 3 | ||
4 | FILESEXTRAPATHS:prepend := "${THISDIR}/lopper:" | 4 | FILESEXTRAPATHS:prepend := "${THISDIR}/lopper:" |
5 | 5 | ||
6 | SRC_URI += "file://0001-openamp-xlnx-Fix-typo-in-comparison.patch" | ||
7 | |||
8 | BASEVERSION = "1.2.0" | 6 | BASEVERSION = "1.2.0" |
9 | 7 | ||
10 | RDEPENDS:${PN} += " \ | 8 | RDEPENDS:${PN} += " \ |