summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core
diff options
context:
space:
mode:
authorJonathan Stroud <jonathan.stroud@amd.com>2024-03-22 17:04:46 -0600
committerMark Hatle <mark.hatle@amd.com>2024-03-25 10:44:24 -0500
commit3048f2525996e582e00d8091f6a31c2088cee513 (patch)
tree1b64ccc4f17cb98fbf88ff5613db0903a56a8d49 /meta-xilinx-core
parent6ddde9a20775549f1434cba6006f84db1a223cb4 (diff)
downloadmeta-xilinx-3048f2525996e582e00d8091f6a31c2088cee513.tar.gz
Change u-boot-xlnx-scr to use copies instead of symlinks
symlinks don't work on the /boot FAT partition, so change to copy Signed-off-by: Jonathan Stroud <jonathan.stroud@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core')
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
index 6410fc25..ac391c3c 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
@@ -262,10 +262,11 @@ do_compile() {
262do_install() { 262do_install() {
263 install -d ${D}/boot 263 install -d ${D}/boot
264 install -m 0644 boot.scr ${D}/boot/${UBOOTSCR_BASE_NAME}.scr 264 install -m 0644 boot.scr ${D}/boot/${UBOOTSCR_BASE_NAME}.scr
265 ln -sf ${UBOOTSCR_BASE_NAME}.scr ${D}/boot/boot.scr 265 install -m 0644 boot.scr ${D}/boot/
266 install -d ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME} 266 install -d ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME}
267 install -m 0644 pxeboot.pxe ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME}/default 267 install -m 0644 pxeboot.pxe ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME}/default
268 ln -sf pxeboot/${UBOOTPXE_CONFIG_NAME} ${D}/boot/${UBOOTPXE_CONFIG} 268 install -d ${D}/boot/${UBOOTPXE_CONFIG}/
269 install -m 0644 pxeboot.pxe ${D}/boot/${UBOOTPXE_CONFIG}/default
269} 270}
270 271
271FILES:${PN} = "/boot/*" 272FILES:${PN} = "/boot/*"
@@ -273,10 +274,11 @@ FILES:${PN} = "/boot/*"
273do_deploy() { 274do_deploy() {
274 install -d ${DEPLOYDIR} 275 install -d ${DEPLOYDIR}
275 install -m 0644 boot.scr ${DEPLOYDIR}/${UBOOTSCR_BASE_NAME}.scr 276 install -m 0644 boot.scr ${DEPLOYDIR}/${UBOOTSCR_BASE_NAME}.scr
276 ln -sf ${UBOOTSCR_BASE_NAME}.scr ${DEPLOYDIR}/boot.scr 277 install -m 0644 boot.scr ${DEPLOYDIR}/
277 install -d ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME} 278 install -d ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}
278 install -m 0644 pxeboot.pxe ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}/default 279 install -m 0644 pxeboot.pxe ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}/default
279 ln -sf pxeboot/${UBOOTPXE_CONFIG_NAME} ${DEPLOYDIR}/${UBOOTPXE_CONFIG} 280 install -d ${DEPLOYDIR}/${UBOOTPXE_CONFIG}/
281 install -m 0644 pxeboot.pxe ${DEPLOYDIR}/${UBOOTPXE_CONFIG}/default
280} 282}
281 283
282addtask do_deploy after do_compile before do_build 284addtask do_deploy after do_compile before do_build