diff options
-rw-r--r-- | meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch | 22 |
1 files changed, 12 insertions, 10 deletions
diff --git a/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch b/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch index 08252db0..e52ecb6a 100644 --- a/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch +++ b/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch | |||
@@ -6,21 +6,23 @@ Upstream-Status: Pending | |||
6 | 6 | ||
7 | Signed-off-by: Mark Hatle <mark.hatle@amd.com> | 7 | Signed-off-by: Mark Hatle <mark.hatle@amd.com> |
8 | 8 | ||
9 | diff -ur mesa-22.2.0.orig/src/gallium/targets/dri/meson.build mesa-22.2.0/src/gallium/targets/dri/meson.build | 9 | Index: mesa-23.3.3/src/gallium/targets/dri/meson.build |
10 | --- mesa-22.2.0.orig/src/gallium/targets/dri/meson.build 2022-10-24 20:17:33.977241901 -0700 | 10 | =================================================================== |
11 | +++ mesa-22.2.0/src/gallium/targets/dri/meson.build 2022-10-24 20:19:03.217237410 -0700 | 11 | --- mesa-23.3.3.orig/src/gallium/targets/dri/meson.build |
12 | @@ -92,6 +92,7 @@ | 12 | +++ mesa-23.3.3/src/gallium/targets/dri/meson.build |
13 | @@ -93,6 +93,7 @@ foreach d : [[with_gallium_kmsro, [ | ||
13 | 'st7735r_dri.so', | 14 | 'st7735r_dri.so', |
14 | 'stm_dri.so', | 15 | 'stm_dri.so', |
15 | 'sun4i-drm_dri.so', | 16 | 'sun4i-drm_dri.so', |
16 | + 'xlnx_dri.so', | 17 | + 'xlnx_dri.so', |
17 | ]], | 18 | ]], |
18 | [with_gallium_radeonsi, 'radeonsi_dri.so'], | 19 | [with_gallium_radeonsi, 'radeonsi_dri.so'], |
19 | [with_gallium_nouveau, 'nouveau_dri.so'], | 20 | [with_gallium_nouveau, 'nouveau_dri.so'], |
20 | diff -ur mesa-22.2.0.orig/src/gallium/targets/dri/target.c mesa-22.2.0/src/gallium/targets/dri/target.c | 21 | Index: mesa-23.3.3/src/gallium/targets/dri/target.c |
21 | --- mesa-22.2.0.orig/src/gallium/targets/dri/target.c 2022-10-24 20:17:33.977241901 -0700 | 22 | =================================================================== |
22 | +++ mesa-22.2.0/src/gallium/targets/dri/target.c 2022-10-24 20:19:59.833234561 -0700 | 23 | --- mesa-23.3.3.orig/src/gallium/targets/dri/target.c |
23 | @@ -118,6 +118,7 @@ | 24 | +++ mesa-23.3.3/src/gallium/targets/dri/target.c |
25 | @@ -123,6 +123,7 @@ DEFINE_LOADER_DRM_ENTRYPOINT(st7586) | ||
24 | DEFINE_LOADER_DRM_ENTRYPOINT(st7735r) | 26 | DEFINE_LOADER_DRM_ENTRYPOINT(st7735r) |
25 | DEFINE_LOADER_DRM_ENTRYPOINT(stm) | 27 | DEFINE_LOADER_DRM_ENTRYPOINT(stm) |
26 | DEFINE_LOADER_DRM_ENTRYPOINT(sun4i_drm) | 28 | DEFINE_LOADER_DRM_ENTRYPOINT(sun4i_drm) |