diff options
16 files changed, 449 insertions, 3 deletions
diff --git a/meta-xilinx-core/dynamic-layers/openamp-layer/recipes-core/packagegroups/packagegroup-openamp.bb b/meta-xilinx-core/dynamic-layers/openamp-layer/recipes-core/packagegroups/packagegroup-openamp.bb new file mode 100644 index 00000000..ba8ef9f6 --- /dev/null +++ b/meta-xilinx-core/dynamic-layers/openamp-layer/recipes-core/packagegroups/packagegroup-openamp.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | DESCRIPTION = "OpenAMP supported packages" | ||
2 | |||
3 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
4 | |||
5 | inherit packagegroup features_check | ||
6 | |||
7 | REQUIRED_DISTRO_FEATURES = "openamp" | ||
8 | |||
9 | PACKAGES = "\ | ||
10 | packagegroup-openamp-echo-test \ | ||
11 | packagegroup-openamp-matrix-mul \ | ||
12 | packagegroup-openamp-rpc-demo \ | ||
13 | packagegroup-openamp \ | ||
14 | " | ||
15 | |||
16 | RDEPENDS:${PN}-echo-test = "rpmsg-echo-test" | ||
17 | RDEPENDS:${PN}-echo-test:append:zcu102-zynqmp = " openamp-fw-echo-testd" | ||
18 | |||
19 | RDEPENDS:${PN}-matrix-mul = "rpmsg-mat-mul" | ||
20 | RDEPENDS:${PN}-matrix-mul:append:zcu102-zynqmp = " openamp-fw-mat-muld" | ||
21 | |||
22 | RDEPENDS:${PN}-rpc-demo = "rpmsg-proxy-app" | ||
23 | RDEPENDS:${PN}-rpc-demo:append:zcu102-zynqmp = " openamp-fw-rpc-demo" | ||
24 | |||
25 | RDEPENDS:${PN}:append = " ${@'open-amp-device-tree' if d.getVar('ENABLE_OPENAMP_DTSI') != '1' else ''}" | ||
26 | |||
27 | RDEPENDS:${PN}:append = " \ | ||
28 | libmetal \ | ||
29 | libmetal-demos \ | ||
30 | open-amp \ | ||
31 | open-amp-demos \ | ||
32 | packagegroup-openamp-echo-test \ | ||
33 | packagegroup-openamp-matrix-mul \ | ||
34 | packagegroup-openamp-rpc-demo \ | ||
35 | " | ||
diff --git a/meta-xilinx-core/recipes-core/packagegroups/packagegroup-lmsensors.bb b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-lmsensors.bb new file mode 100644 index 00000000..d6df0b13 --- /dev/null +++ b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-lmsensors.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "PetaLinux packages that provides tools and drivers for monitoring temperatures, voltage" | ||
2 | |||
3 | PACKAGE_ARCH = "${TUNE_PKGARCH}" | ||
4 | |||
5 | inherit packagegroup | ||
6 | |||
7 | LMSENSORS_PACKAGES = " \ | ||
8 | lmsensors-sensors \ | ||
9 | lmsensors-libsensors \ | ||
10 | lmsensors-sensorsdetect \ | ||
11 | " | ||
12 | |||
13 | RDEPENDS:${PN} = "${LMSENSORS_PACKAGES}" | ||
diff --git a/meta-xilinx-core/recipes-core/packagegroups/packagegroup-networking-stack.bb b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-networking-stack.bb new file mode 100644 index 00000000..9378e372 --- /dev/null +++ b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-networking-stack.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | DESCRIPTION = "Packages to extend network stack" | ||
2 | |||
3 | inherit packagegroup | ||
4 | |||
5 | NETWORKING_STACK_PACKAGES = " \ | ||
6 | ethtool \ | ||
7 | phytool \ | ||
8 | netcat \ | ||
9 | net-tools \ | ||
10 | dnsmasq \ | ||
11 | iproute2 \ | ||
12 | iptables \ | ||
13 | rpcbind \ | ||
14 | iperf2 \ | ||
15 | iperf3 \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS:${PN} = "${NETWORKING_STACK_PACKAGES}" | ||
diff --git a/meta-xilinx-core/recipes-core/packagegroups/packagegroup-opencv.bb b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-opencv.bb new file mode 100644 index 00000000..2742b99e --- /dev/null +++ b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-opencv.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | DESCRIPTION = "PetaLinux opencv supported packages" | ||
2 | |||
3 | PACKAGE_ARCH = "${TUNE_PKGARCH}" | ||
4 | |||
5 | inherit packagegroup | ||
6 | |||
7 | OPENCV_PACKAGES = " \ | ||
8 | opencv \ | ||
9 | libopencv-core \ | ||
10 | libopencv-highgui \ | ||
11 | libopencv-imgproc \ | ||
12 | libopencv-objdetect \ | ||
13 | libopencv-ml \ | ||
14 | libopencv-calib3d \ | ||
15 | libopencv-ccalib \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS:${PN} = "${OPENCV_PACKAGES}" | ||
diff --git a/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-audio.bb b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-audio.bb new file mode 100644 index 00000000..45862a87 --- /dev/null +++ b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-audio.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "ASLA supported packages" | ||
2 | |||
3 | PACKAGE_ARCH = "${TUNE_PKGARCH}" | ||
4 | |||
5 | inherit packagegroup | ||
6 | |||
7 | ALSA_PACKAGES = " \ | ||
8 | libasound \ | ||
9 | alsa-plugins \ | ||
10 | alsa-tools \ | ||
11 | alsa-utils \ | ||
12 | alsa-utils-scripts \ | ||
13 | sox \ | ||
14 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \ | ||
15 | " | ||
16 | RDEPENDS:${PN} = "${ALSA_PACKAGES}" | ||
diff --git a/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-benchmarks.bb b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-benchmarks.bb new file mode 100644 index 00000000..90131e32 --- /dev/null +++ b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-benchmarks.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "Packages for Benchmarks" | ||
2 | |||
3 | inherit packagegroup | ||
4 | |||
5 | BENCHMARKS_EXTRAS = " \ | ||
6 | hdparm \ | ||
7 | iotop \ | ||
8 | nicstat \ | ||
9 | lmbench \ | ||
10 | iptraf \ | ||
11 | net-snmp \ | ||
12 | lsof \ | ||
13 | babeltrace \ | ||
14 | sysstat \ | ||
15 | dool \ | ||
16 | dhrystone \ | ||
17 | linpack \ | ||
18 | whetstone \ | ||
19 | iperf3 \ | ||
20 | " | ||
21 | RDEPENDS:${PN} = "${BENCHMARKS_EXTRAS}" | ||
diff --git a/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-gstreamer.bb b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-gstreamer.bb new file mode 100644 index 00000000..26aa26a2 --- /dev/null +++ b/meta-xilinx-core/recipes-core/packagegroups/packagegroup-xilinx-gstreamer.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "GStreamer packages" | ||
2 | |||
3 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
4 | |||
5 | inherit packagegroup | ||
6 | |||
7 | GSTREAMER_PACKAGES = " \ | ||
8 | gstreamer1.0 \ | ||
9 | gstreamer1.0-python \ | ||
10 | gstreamer1.0-meta-base \ | ||
11 | gstreamer1.0-plugins-base \ | ||
12 | gstreamer1.0-plugins-good \ | ||
13 | gstreamer1.0-plugins-bad \ | ||
14 | gstreamer1.0-rtsp-server \ | ||
15 | gst-shark \ | ||
16 | gstd \ | ||
17 | gst-perf \ | ||
18 | gstreamer1.0-omx \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS:${PN} = "${GSTREAMER_PACKAGES}" | ||
diff --git a/meta-xilinx-demos/conf/layer.conf b/meta-xilinx-demos/conf/layer.conf new file mode 100644 index 00000000..eb667304 --- /dev/null +++ b/meta-xilinx-demos/conf/layer.conf | |||
@@ -0,0 +1,15 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH .= ":${LAYERDIR}" | ||
3 | |||
4 | # We have a packages directory, add to BBFILES | ||
5 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb" | ||
6 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "xilinx-demos" | ||
9 | BBFILE_PATTERN_xilinx-demos = "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_xilinx-demos = "5" | ||
11 | |||
12 | LAYERDEPENDS_xilinx-demos = "core" | ||
13 | LAYERRECOMMENDS_xilinx-demos = "openembedded-layer" | ||
14 | |||
15 | LAYERSERIES_COMPAT_xilinx-demos = "scarthgap" | ||
diff --git a/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-matchbox.bb b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-matchbox.bb new file mode 100644 index 00000000..334f646e --- /dev/null +++ b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-matchbox.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | DESCRIPTION = "Matchbox related packages" | ||
2 | |||
3 | inherit packagegroup features_check | ||
4 | |||
5 | REQUIRED_DISTRO_FEATURES = "x11" | ||
6 | |||
7 | FILEMANAGER ?= "pcmanfm" | ||
8 | |||
9 | MATCHBOX_PACKAGES = " \ | ||
10 | matchbox-config-gtk \ | ||
11 | matchbox-desktop \ | ||
12 | matchbox-keyboard \ | ||
13 | matchbox-keyboard-applet \ | ||
14 | matchbox-panel-2 \ | ||
15 | matchbox-session \ | ||
16 | matchbox-terminal \ | ||
17 | matchbox-theme-sato \ | ||
18 | matchbox-session-sato \ | ||
19 | matchbox-wm \ | ||
20 | settings-daemon \ | ||
21 | adwaita-icon-theme \ | ||
22 | l3afpad \ | ||
23 | ${FILEMANAGER} \ | ||
24 | shutdown-desktop \ | ||
25 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \ | ||
26 | " | ||
27 | |||
28 | RDEPENDS:${PN} = "packagegroup-core-x11 ${MATCHBOX_PACKAGES}" | ||
diff --git a/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-multimedia.bb b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-multimedia.bb new file mode 100644 index 00000000..fcebff04 --- /dev/null +++ b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-multimedia.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "Packages for out of box multimedia experience" | ||
2 | |||
3 | # Can not be all arch due to libdrm | ||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
5 | |||
6 | inherit packagegroup features_check | ||
7 | |||
8 | REQUIRED_DISTRO_FEATURES = "x11" | ||
9 | |||
10 | MULTIMEDIA_PACKAGES = " \ | ||
11 | packagegroup-xilinx-gstreamer \ | ||
12 | packagegroup-xilinx-matchbox \ | ||
13 | packagegroup-core-x11 \ | ||
14 | libdrm \ | ||
15 | libdrm-tests \ | ||
16 | packagegroup-xilinx-qt \ | ||
17 | ffmpeg \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS:${PN} = "${MULTIMEDIA_PACKAGES}" | ||
diff --git a/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-qt.bb b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-qt.bb new file mode 100644 index 00000000..6b795c08 --- /dev/null +++ b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-qt.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | DESCRIPTION = "Qt packages" | ||
2 | |||
3 | # Workaround for DISTRO_FEATURES wayland only set on 64-bit ARM machines | ||
4 | PACKAGE_ARCH = "${TUNE_PKGARCH}" | ||
5 | |||
6 | inherit packagegroup features_check | ||
7 | |||
8 | PACKAGES = "${PN} ${PN}-extended" | ||
9 | PROVIDES = "${PACKAGES}" | ||
10 | |||
11 | ANY_OF_DISTRO_FEATURES = "x11 fbdev wayland" | ||
12 | |||
13 | QT_PACKAGES = " \ | ||
14 | qtbase \ | ||
15 | qtbase-plugins \ | ||
16 | qtbase-examples \ | ||
17 | qtquickcontrols-qmlplugins \ | ||
18 | qtcharts \ | ||
19 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \ | ||
20 | " | ||
21 | RDEPENDS:${PN} = "${QT_PACKAGES}" | ||
22 | |||
23 | QT_EXTENDED_PACKAGES = " \ | ||
24 | ruby \ | ||
25 | qtbase-mkspecs \ | ||
26 | qtbase-plugins \ | ||
27 | qtsystems-mkspecs \ | ||
28 | qttranslations-qtbase \ | ||
29 | qttranslations-qthelp \ | ||
30 | qtconnectivity-mkspecs \ | ||
31 | qttranslations-qtconnectivity \ | ||
32 | qtdeclarative-mkspecs \ | ||
33 | qttranslations-qtdeclarative \ | ||
34 | qtimageformats-plugins \ | ||
35 | qtlocation-mkspecs \ | ||
36 | qtlocation-plugins \ | ||
37 | qttranslations-qtmultimedia \ | ||
38 | qtscript-mkspecs \ | ||
39 | qttranslations-qtscript \ | ||
40 | qtsensors-mkspecs \ | ||
41 | qtsensors-plugins \ | ||
42 | qtserialport-mkspecs \ | ||
43 | qtsvg-mkspecs \ | ||
44 | qtsvg-plugins \ | ||
45 | qtwebsockets-mkspecs \ | ||
46 | qttranslations-qtwebsockets \ | ||
47 | qtwebchannel-mkspecs \ | ||
48 | qtxmlpatterns-mkspecs \ | ||
49 | qttranslations-qtxmlpatterns \ | ||
50 | qtwebkit-mkspecs \ | ||
51 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'qtx11extras', '', d)} \ | ||
52 | qtgraphicaleffects-qmlplugins \ | ||
53 | " | ||
54 | |||
55 | RDEPENDS:${PN}-extended = "${QT_PACKAGES} ${QT_EXTENDED_PACKAGES}" | ||
diff --git a/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-ros.bb b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-ros.bb new file mode 100644 index 00000000..d9db94ef --- /dev/null +++ b/meta-xilinx-demos/recipes-core/packagegroups/packagegroup-xilinx-ros.bb | |||
@@ -0,0 +1,165 @@ | |||
1 | DESCRIPTION = "Packages for ROS2 Base and Demos including some basic pub/sub examples" | ||
2 | |||
3 | PACKAGE_ARCH = "${TUNE_PKGARCH}" | ||
4 | |||
5 | inherit packagegroup | ||
6 | inherit ros_distro_${ROS_DISTRO} | ||
7 | |||
8 | PROVIDES = "${PACKAGES}" | ||
9 | |||
10 | PACKAGES += "${PN}-base ${PN}-demo ${PN}-control" | ||
11 | |||
12 | SUMMARY:${PN}-dev = "ROS packages required for on target development" | ||
13 | ROS_BUILDESSENTIAL_PACKAGES = "\ | ||
14 | ament-lint-auto \ | ||
15 | ament-cmake-auto \ | ||
16 | ament-cmake-core \ | ||
17 | ament-cmake-cppcheck \ | ||
18 | ament-cmake-cpplint \ | ||
19 | ament-cmake-export-definitions \ | ||
20 | ament-cmake-export-dependencies \ | ||
21 | ament-cmake-export-include-directories \ | ||
22 | ament-cmake-export-interfaces \ | ||
23 | ament-cmake-export-libraries \ | ||
24 | ament-cmake-export-link-flags \ | ||
25 | ament-cmake-export-targets \ | ||
26 | ament-cmake-gmock \ | ||
27 | ament-cmake-gtest \ | ||
28 | ament-cmake-include-directories \ | ||
29 | ament-cmake-libraries \ | ||
30 | ament-cmake \ | ||
31 | ament-cmake-pytest \ | ||
32 | ament-cmake-python \ | ||
33 | ament-cmake-ros \ | ||
34 | ament-cmake-target-dependencies \ | ||
35 | ament-cmake-test \ | ||
36 | ament-cmake-version \ | ||
37 | ament-cmake-uncrustify \ | ||
38 | ament-cmake-flake8 \ | ||
39 | ament-cmake-pep257 \ | ||
40 | ament-copyright \ | ||
41 | ament-cpplint \ | ||
42 | ament-flake8 \ | ||
43 | ament-index-python \ | ||
44 | ament-lint-cmake \ | ||
45 | ament-mypy \ | ||
46 | ament-package \ | ||
47 | ament-pclint \ | ||
48 | ament-pep257 \ | ||
49 | ament-pycodestyle \ | ||
50 | ament-pyflakes \ | ||
51 | ament-uncrustify \ | ||
52 | ament-xmllint \ | ||
53 | cmake \ | ||
54 | eigen3-cmake-module \ | ||
55 | fastcdr \ | ||
56 | fastrtps-cmake-module \ | ||
57 | fastrtps \ | ||
58 | foonathan-memory-vendor \ | ||
59 | gmock-vendor \ | ||
60 | gtest-vendor \ | ||
61 | libyaml \ | ||
62 | libyaml-vendor \ | ||
63 | packagegroup-core-buildessential \ | ||
64 | python-cmake-module \ | ||
65 | python3-catkin-pkg \ | ||
66 | python3-colcon-common-extensions \ | ||
67 | python3-empy \ | ||
68 | python3 \ | ||
69 | python3-pytest \ | ||
70 | rcutils \ | ||
71 | rmw-implementation-cmake \ | ||
72 | rosidl-cmake \ | ||
73 | rosidl-default-generators \ | ||
74 | rosidl-generator-c \ | ||
75 | rosidl-generator-cpp \ | ||
76 | rosidl-generator-dds-idl \ | ||
77 | rosidl-generator-py \ | ||
78 | rosidl-parser \ | ||
79 | rosidl-runtime-c \ | ||
80 | rosidl-runtime-cpp \ | ||
81 | rosidl-typesupport-c \ | ||
82 | rosidl-typesupport-cpp \ | ||
83 | rosidl-typesupport-fastrtps-cpp \ | ||
84 | rosidl-typesupport-interface \ | ||
85 | rosidl-typesupport-introspection-c \ | ||
86 | rosidl-typesupport-introspection-cpp \ | ||
87 | " | ||
88 | |||
89 | SUMMARY:${PN}-base = "ROS_BASE_PACKAGES includes ROS base packages" | ||
90 | ROS_BASE_PACKAGES = "\ | ||
91 | ros-base \ | ||
92 | cyclonedds \ | ||
93 | rmw-cyclonedds-cpp \ | ||
94 | tmux \ | ||
95 | python3-argcomplete \ | ||
96 | glibc-utils \ | ||
97 | localedef \ | ||
98 | rt-tests \ | ||
99 | stress \ | ||
100 | xrt-dev \ | ||
101 | xrt \ | ||
102 | kernel-module-zocl \ | ||
103 | opencl-headers-dev \ | ||
104 | opencl-clhpp-dev \ | ||
105 | " | ||
106 | |||
107 | SUMMARY:${PN}-demo = "ROS_DEMO_PACKAGES includes ROS examples demos packages" | ||
108 | ROS_DEMO_PACKAGES = "\ | ||
109 | examples-rclcpp-minimal-action-client \ | ||
110 | examples-rclcpp-minimal-action-server \ | ||
111 | examples-rclcpp-minimal-client \ | ||
112 | examples-rclcpp-minimal-composition \ | ||
113 | examples-rclcpp-minimal-publisher \ | ||
114 | examples-rclcpp-minimal-service \ | ||
115 | examples-rclcpp-minimal-subscriber \ | ||
116 | examples-rclcpp-minimal-timer \ | ||
117 | examples-rclcpp-multithreaded-executor \ | ||
118 | examples-rclpy-executors \ | ||
119 | examples-rclpy-minimal-action-server \ | ||
120 | examples-rclpy-minimal-client \ | ||
121 | examples-rclpy-minimal-publisher \ | ||
122 | examples-rclpy-minimal-service \ | ||
123 | examples-rclpy-minimal-subscriber \ | ||
124 | demo-nodes-cpp \ | ||
125 | demo-nodes-cpp-rosnative \ | ||
126 | " | ||
127 | |||
128 | SUMMARY:${PN}-control = "ROS_CONTROL_PACKAGES includes ROS control packages" | ||
129 | ROS_CONTROL_PACKAGES = "\ | ||
130 | controller-interface \ | ||
131 | controller-manager \ | ||
132 | controller-manager-msgs \ | ||
133 | hardware-interface \ | ||
134 | ros2-control \ | ||
135 | ros2controlcli \ | ||
136 | ros2-control-test-assets \ | ||
137 | transmission-interface \ | ||
138 | " | ||
139 | |||
140 | #RDEPENDS:${PN}-base:aarch64 = "\ | ||
141 | # ${ROS_BASE_PACKAGES} \ | ||
142 | #" | ||
143 | |||
144 | #RDEPENDS:${PN}-demo:aarch64 = "\ | ||
145 | # ${ROS_BASE_PACKAGES} \ | ||
146 | # ${ROS_DEMO_PACKAGES} \ | ||
147 | #" | ||
148 | |||
149 | #RDEPENDS:${PN}-control:aarch64 = "\ | ||
150 | # ${ROS_BASE_PACKAGES} \ | ||
151 | # ${ROS_CONTROL_PACKAGES} \ | ||
152 | #" | ||
153 | |||
154 | #RDEPENDS:${PN}-dev:aarch64 = "\ | ||
155 | # ${ROS_BUILDESSENTIAL_PACKAGES} \ | ||
156 | #" | ||
157 | |||
158 | #RDEPENDS:${PN}:aarch64 = "\ | ||
159 | # ${PN}-demo \ | ||
160 | # ${PN}-control \ | ||
161 | # rqt-runtime-monitor \ | ||
162 | #" | ||
163 | |||
164 | IMAGE_LINGUAS = "en-us" | ||
165 | GLIBC_GENERATE_LOCALES = "en_US.UTF-8" | ||
diff --git a/meta-xilinx-multimedia/conf/layer.conf b/meta-xilinx-multimedia/conf/layer.conf index 0787f87c..1ae4676b 100644 --- a/meta-xilinx-multimedia/conf/layer.conf +++ b/meta-xilinx-multimedia/conf/layer.conf | |||
@@ -9,7 +9,7 @@ BBFILE_COLLECTIONS += "xilinx-multimedia" | |||
9 | BBFILE_PATTERN_xilinx-multimedia = "^${LAYERDIR}/" | 9 | BBFILE_PATTERN_xilinx-multimedia = "^${LAYERDIR}/" |
10 | BBFILE_PRIORITY_xilinx-multimedia = "5" | 10 | BBFILE_PRIORITY_xilinx-multimedia = "5" |
11 | 11 | ||
12 | AYERDEPENDS_xilinx-multimedia = "core" | 12 | LAYERDEPENDS_xilinx-multimedia = "core" |
13 | LAYERRECOMMENDS_xilinx-multimedia = "openembedded-layer" | 13 | LAYERRECOMMENDS_xilinx-multimedia = "openembedded-layer" |
14 | 14 | ||
15 | LAYERSERIES_COMPAT_xilinx-multimedia = "scarthgap" | 15 | LAYERSERIES_COMPAT_xilinx-multimedia = "scarthgap" |
diff --git a/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vcu-notebooks_0.1.bb b/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vcu-notebooks_0.1.bb index c3ec3153..578f8ea8 100644 --- a/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vcu-notebooks_0.1.bb +++ b/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vcu-notebooks_0.1.bb | |||
@@ -13,7 +13,7 @@ inherit features_check | |||
13 | REQUIRED_MACHINE_FEATURES = "vcu" | 13 | REQUIRED_MACHINE_FEATURES = "vcu" |
14 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 14 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
15 | 15 | ||
16 | RDEPENDS:${PN} = "packagegroup-petalinux-jupyter packagegroup-petalinux-gstreamer gstreamer-vcu-examples start-jupyter" | 16 | RDEPENDS:${PN} = "packagegroup-petalinux-jupyter packagegroup-xilinx-gstreamer gstreamer-vcu-examples start-jupyter" |
17 | 17 | ||
18 | EXTRA_OEMAKE = 'D=${D} JUPYTER_DIR=${JUPYTER_DIR}' | 18 | EXTRA_OEMAKE = 'D=${D} JUPYTER_DIR=${JUPYTER_DIR}' |
19 | 19 | ||
diff --git a/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vdu-notebooks_0.1.bb b/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vdu-notebooks_0.1.bb index fc61d948..a055d7b7 100644 --- a/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vdu-notebooks_0.1.bb +++ b/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer-vdu-notebooks_0.1.bb | |||
@@ -13,7 +13,7 @@ inherit features_check | |||
13 | REQUIRED_MACHINE_FEATURES = "vdu" | 13 | REQUIRED_MACHINE_FEATURES = "vdu" |
14 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 14 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
15 | 15 | ||
16 | RDEPENDS:${PN} = "packagegroup-petalinux-jupyter packagegroup-petalinux-gstreamer gstreamer-vdu-examples start-jupyter" | 16 | RDEPENDS:${PN} = "packagegroup-petalinux-jupyter packagegroup-xilinx-gstreamer gstreamer-vdu-examples start-jupyter" |
17 | 17 | ||
18 | EXTRA_OEMAKE = 'D=${D} JUPYTER_DIR=${JUPYTER_DIR}' | 18 | EXTRA_OEMAKE = 'D=${D} JUPYTER_DIR=${JUPYTER_DIR}' |
19 | 19 | ||
diff --git a/meta-xilinx-virtualization/recipes-core/packagegroups/packagegroup-xen.bb b/meta-xilinx-virtualization/recipes-core/packagegroups/packagegroup-xen.bb new file mode 100644 index 00000000..4fecbcae --- /dev/null +++ b/meta-xilinx-virtualization/recipes-core/packagegroups/packagegroup-xen.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "Xen supported packages" | ||
2 | |||
3 | PACKAGE_ARCH = "${TUNE_PKGARCH}" | ||
4 | |||
5 | inherit packagegroup features_check | ||
6 | |||
7 | REQUIRED_DISTRO_FEATURES = "xen" | ||
8 | |||
9 | XEN_EXTRA_PACKAGES = " \ | ||
10 | kernel-module-xen-blkback \ | ||
11 | kernel-module-xen-gntalloc \ | ||
12 | kernel-module-xen-gntdev \ | ||
13 | kernel-module-xen-netback \ | ||
14 | kernel-module-xen-wdt \ | ||
15 | xen \ | ||
16 | xen-tools \ | ||
17 | xen-tools-xenstat \ | ||
18 | ${@bb.utils.contains('DISTRO_FEATURES', 'vmsep', 'qemu-aarch64 qemu-keymaps', 'qemu', d)} \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS:${PN} = "${XEN_EXTRA_PACKAGES}" | ||