diff options
3 files changed, 33 insertions, 2 deletions
diff --git a/meta-xilinx-core/recipes-multimedia/vdu/files/0001-include-libapp-Parser.h-Add-cstdint.patch b/meta-xilinx-core/recipes-multimedia/vdu/files/0001-include-libapp-Parser.h-Add-cstdint.patch new file mode 100644 index 00000000..04d59c60 --- /dev/null +++ b/meta-xilinx-core/recipes-multimedia/vdu/files/0001-include-libapp-Parser.h-Add-cstdint.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 79eddc5c5474c9b61bf6b2e648eba8bca61469b9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Hatle <mark.hatle@amd.com> | ||
3 | Date: Thu, 25 Jan 2024 12:30:24 -0700 | ||
4 | Subject: [PATCH] include/libapp/Parser.h: Add cstdint | ||
5 | |||
6 | Resolves usages of unit32_t being undefined | ||
7 | |||
8 | Signed-off-by: Mark Hatle <mark.hatle@amd.com> | ||
9 | --- | ||
10 | include/lib_app/Parser.h | 1 + | ||
11 | 1 file changed, 1 insertion(+) | ||
12 | |||
13 | diff --git a/include/lib_app/Parser.h b/include/lib_app/Parser.h | ||
14 | index 976a835..6fa63ce 100644 | ||
15 | --- a/include/lib_app/Parser.h | ||
16 | +++ b/include/lib_app/Parser.h | ||
17 | @@ -35,6 +35,7 @@ | ||
18 | #include <sstream> | ||
19 | #include <vector> | ||
20 | #include <iomanip> | ||
21 | +#include <cstdint> | ||
22 | |||
23 | std::deque<Token> toReversePolish(std::deque<Token>& tokens); | ||
24 | std::string parseString(std::deque<Token>& tokens); | ||
25 | -- | ||
26 | 2.34.1 | ||
27 | |||
diff --git a/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.1.bb b/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.1.bb index 602dc2fc..f9228678 100644 --- a/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.1.bb +++ b/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.1.bb | |||
@@ -16,7 +16,9 @@ REPO ?= "git://github.com/Xilinx/vdu-ctrl-sw.git;protocol=https" | |||
16 | SRCREV ?= "06fc18b303b40d4fee7549ad162c22ee1bc31582" | 16 | SRCREV ?= "06fc18b303b40d4fee7549ad162c22ee1bc31582" |
17 | 17 | ||
18 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" | 18 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
19 | SRC_URI = "${REPO};${BRANCHARG}" | 19 | SRC_URI = "${REPO};${BRANCHARG} \ |
20 | file://0001-include-libapp-Parser.h-Add-cstdint.patch \ | ||
21 | " | ||
20 | 22 | ||
21 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |
22 | 24 | ||
diff --git a/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.2.bb b/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.2.bb index 2b9af94f..f8b36a93 100644 --- a/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.2.bb +++ b/meta-xilinx-core/recipes-multimedia/vdu/libvdu-ctrlsw_2023.2.bb | |||
@@ -16,7 +16,9 @@ REPO ?= "git://github.com/Xilinx/vdu-ctrl-sw.git;protocol=https" | |||
16 | SRCREV ?= "1beb8f247d01b1a728faea36ce8f7847c895482f" | 16 | SRCREV ?= "1beb8f247d01b1a728faea36ce8f7847c895482f" |
17 | 17 | ||
18 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" | 18 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
19 | SRC_URI = "${REPO};${BRANCHARG}" | 19 | SRC_URI = "${REPO};${BRANCHARG} \ |
20 | file://0001-include-libapp-Parser.h-Add-cstdint.patch \ | ||
21 | " | ||
20 | 22 | ||
21 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |
22 | 24 | ||