summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-demos/recipes-firmware/zcu104-pl-vcu-fw/zcu104-pl-vcu-fw_1.0-2024.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-xilinx-demos/recipes-firmware/zcu104-pl-vcu-fw/zcu104-pl-vcu-fw_1.0-2024.2.bb b/meta-xilinx-demos/recipes-firmware/zcu104-pl-vcu-fw/zcu104-pl-vcu-fw_1.0-2024.2.bb
new file mode 100644
index 00000000..870ee823
--- /dev/null
+++ b/meta-xilinx-demos/recipes-firmware/zcu104-pl-vcu-fw/zcu104-pl-vcu-fw_1.0-2024.2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "ZCU104 full pl firmware using dfx_user_dts bbclass"
2DESCRIPTION = "ZCU104 full PL VCU firmware application"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6inherit dfx_user_dts
7
8SRC_URI = "https://petalinux.xilinx.com/sswreleases/rel-v2024.2/sdt/2024.2/2024.2_1025_1_10240249/external/zcu104-pl-vcu-fw/zcu104-pl-vcu-fw_2024.2_1025_1.tar.gz"
9
10SRC_URI[sha256sum] = "4aaedc9bfc39c4e779beace5b875243185bec42e2864a7038c5fd620a105d248"
11
12
13COMPATIBLE_MACHINE:zynqmp-zcu104-sdt-full = "${MACHINE}"
14
15# When do_upack is exectuted it will extract tar file with original directory
16# name so set the FW_DIR pointing to pdi and dtsi files.
17FW_DIR = "zcu104-pl-vcu-fw"
18
19# fw files doesn't install on rootfs using dfx_user_dts bbclass using artifactory
20# method. To workaround this issue we are using copy_fw_files pre-functions.
21# copy_fw_files prefuncs needs to be called before find_firmware_file to update
22# the firmware-name to ${PN}.
23do_configure[prefuncs] =+ "copy_fw_files"
24python copy_fw_files () {
25 import shutil
26 fw_file_src = d.getVar('WORKDIR') + '/' + d.getVar("FW_DIR")
27 fw_file_dest = d.getVar('S')
28 shutil.copytree(fw_file_src, fw_file_dest, dirs_exist_ok=True)
29}