summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc1
-rw-r--r--meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch33
-rw-r--r--meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb (renamed from meta-xilinx-core/recipes-apps/image-update/image-update_1.0.bb)4
-rw-r--r--meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-header.bb54
-rw-r--r--meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-string.bb32
-rw-r--r--meta-xilinx-core/recipes-bsp/bootbin/machine-xilinx-versal.inc3
-rw-r--r--meta-xilinx-core/recipes-bsp/bootbin/xilinx-bootbin_1.0.bb4
-rw-r--r--meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb2
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc2
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb10
-rw-r--r--meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.cfg1
-rw-r--r--meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.scc2
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_git.bb29
-rw-r--r--meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass6
14 files changed, 172 insertions, 11 deletions
diff --git a/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc b/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
index 5eae0577..d3618229 100644
--- a/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
+++ b/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
@@ -13,4 +13,5 @@ SRC_URI:append:microblaze = " \
13 file://0006-Patch-MicroBlaze-these-changes-will-make-64-bit-vect.patch \ 13 file://0006-Patch-MicroBlaze-these-changes-will-make-64-bit-vect.patch \
14 file://0007-Patch-MicroBlaze-Added-m64-abi-for-64-bit-target-des.patch \ 14 file://0007-Patch-MicroBlaze-Added-m64-abi-for-64-bit-target-des.patch \
15 file://0008-Patch-MicroBlaze.patch \ 15 file://0008-Patch-MicroBlaze.patch \
16 file://0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch \
16 " 17 "
diff --git a/meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch b/meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch
new file mode 100644
index 00000000..93f67800
--- /dev/null
+++ b/meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch
@@ -0,0 +1,33 @@
1From 53b76bb548720367032a51a6d604c975b10bb30e Mon Sep 17 00:00:00 2001
2From: Aayush Misra <aayushm@amd.com>
3Date: Fri, 29 Mar 2024 14:59:16 +0530
4Subject: [PATCH] gdb/gdserver: Fix ABI settings for gdbserver
5
6---
7 gdb/microblaze-tdep.c | 7 ++++---
8 1 file changed, 4 insertions(+), 3 deletions(-)
9
10diff --git a/gdb/microblaze-tdep.c b/gdb/microblaze-tdep.c
11index 38ba38e8c7d..35cec286d8f 100644
12--- a/gdb/microblaze-tdep.c
13+++ b/gdb/microblaze-tdep.c
14@@ -1120,12 +1120,13 @@ void _initialize_microblaze_tdep ();
15 void
16 _initialize_microblaze_tdep ()
17 {
18+ //Setting abi to auto manually, should be able to modify in 'arch'_gdbarch_init function
19+ microblaze_abi_string = microblaze_abi_strings[0];
20+
21 register_gdbarch_init (bfd_arch_microblaze, microblaze_gdbarch_init);
22-// static struct cmd_list_element *setmicroblazecmdlist = NULL;
23-// static struct cmd_list_element *showmicroblazecmdlist = NULL;
24
25- /* Add root prefix command for all "set microblaze"/"show microblaze" commands. */
26
27+ /* Add root prefix command for all "set microblaze"/"show microblaze" commands. */
28 add_setshow_prefix_cmd ("microblaze", no_class,
29 _("Various microblaze specific commands."),
30 _("Various microblaze specific commands."),
31--
322.34.1
33
diff --git a/meta-xilinx-core/recipes-apps/image-update/image-update_1.0.bb b/meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb
index 8a707df4..f053a9bd 100644
--- a/meta-xilinx-core/recipes-apps/image-update/image-update_1.0.bb
+++ b/meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb
@@ -6,9 +6,9 @@ SUMMARY = "Image update is used to update alternate image on compatible firmware
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSES/MIT;md5=2ac09a7a37dd6ee0ba23ce497d57d09b" 7LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSES/MIT;md5=2ac09a7a37dd6ee0ba23ce497d57d09b"
8 8
9BRANCH = "xlnx_rel_v2023.2" 9BRANCH = "master"
10SRC_URI = "git://github.com/Xilinx/linux-image_update.git;branch=${BRANCH};protocol=https" 10SRC_URI = "git://github.com/Xilinx/linux-image_update.git;branch=${BRANCH};protocol=https"
11SRCREV = "4f0b7b1b20933ddc454124fc3472f1b8894ddf08" 11SRCREV = "a68308f329578d3585fd335071a9184aa7f46d2e"
12 12
13RDEPENDS:${PN} += "freeipmi" 13RDEPENDS:${PN} += "freeipmi"
14 14
diff --git a/meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-header.bb b/meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-header.bb
new file mode 100644
index 00000000..98eebc3e
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-header.bb
@@ -0,0 +1,54 @@
1DESCRIPTION = "Bootbin version string file"
2SUMMARY = "The BIF file for bootbin requires a version file in a specific format"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6COMPATIBLE_MACHINE = "^$"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10BOOTBIN_VER_MAIN ?= ""
11
12BOOTBIN_VER_SUFFIX ?= "${@(d.getVar('XILINX_VER_BUILD') or '')[:8] if d.getVar('XILINX_VER_UPDATE') != 'release' and not d.getVar('XILINX_VER_UPDATE').startswith('update') else ''}"
13BOOTBIN_VER_FILE = "bootbin-version-header.txt"
14BOOTBIN_VER_MAX_LEN = "36"
15
16BOOTBIN_MANIFEST_FILE ?= "bootbin-version-header.manifest"
17
18inherit deploy image-artifact-names
19
20python do_configure() {
21 if d.getVar("BOOTBIN_VER_SUFFIX"):
22 version = version + "-" + d.getVar("BOOTBIN_VER_SUFFIX")
23
24 if len(version) > int(d.getVar("BOOTBIN_VER_MAX_LEN")):
25 bb.error("version string too long")
26
27 with open(d.expand("${B}/${BOOTBIN_VER_FILE}"), "w") as f:
28 f.write(version.encode("utf-8").hex())
29
30 with open(d.expand("${B}/${BOOTBIN_MANIFEST_FILE}"), "w") as f:
31 f.write("* %s\n" % d.getVar('PN'))
32 f.write("VERSION: %s\n" % version)
33 f.write("PV: %s\n" % d.getVar('PV'))
34 f.write("XILINX_VER_MAIN: %s\n" % d.getVar('XILINX_VER_MAIN'))
35 f.write("XILINX_VER_UPDATE: %s\n" % d.getVar('XILINX_VER_UPDATE'))
36 f.write("XILINX_VER_BUILD: %s\n\n" % d.getVar('XILINX_VER_BUILD'))
37}
38
39do_install() {
40 install -d ${D}/boot
41 install -m 0644 ${B}/${BOOTBIN_VER_FILE} ${D}/boot/
42}
43
44do_deploy() {
45 install -m 0644 ${B}/${BOOTBIN_VER_FILE} ${DEPLOYDIR}/${IMAGE_NAME}.txt
46 ln -s ${IMAGE_NAME}.txt ${DEPLOYDIR}/${IMAGE_LINK_NAME}.txt
47 install -m 0644 ${B}/${BOOTBIN_MANIFEST_FILE} ${DEPLOYDIR}/${IMAGE_NAME}.manifest
48 ln -s ${IMAGE_NAME}.manifest ${DEPLOYDIR}/${IMAGE_LINK_NAME}.manifest
49}
50
51addtask deploy after do_compile
52
53SYSROOT_DIRS += "/boot"
54FILES:${PN} += "/boot/${BOOTBIN_VER_FILE}"
diff --git a/meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-string.bb b/meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-string.bb
new file mode 100644
index 00000000..af30a17d
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/bootbin/bootbin-version-string.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Bootbin version file - text format"
2SUMMARY = "The BIF file for bootbin requires a version file in a text format"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6COMPATIBLE_MACHINE = "^$"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10BOOTBIN_VER_MAIN ?= ""
11BOOTBIN_VER_SUFFIX ?= "${@(d.getVar('XILINX_VER_BUILD') or '')[:8] if d.getVar('XILINX_VER_UPDATE') != 'release' and not d.getVar('XILINX_VER_UPDATE').startswith('update') else ''}"
12BOOTBIN_VER_FILE = "bootbin-version-string.txt"
13
14#BOOTBIN_MANIFEST_FILE ?= "bootbin-version-header.manifest"
15
16inherit deploy image-artifact-names
17
18python do_configure() {
19 if d.getVar("BOOTBIN_VER_SUFFIX"):
20 version = version + "-" + d.getVar("BOOTBIN_VER_SUFFIX")
21 with open(d.expand("${B}/${BOOTBIN_VER_FILE}"), "w") as f:
22 f.write(version)
23}
24
25do_deploy() {
26 install -m 0644 ${B}/${BOOTBIN_VER_FILE} ${DEPLOYDIR}/${IMAGE_NAME}.txt
27 ln -s ${IMAGE_NAME}.txt ${DEPLOYDIR}/${IMAGE_LINK_NAME}.txt
28# install -m 0644 ${B}/${BOOTBIN_MANIFEST_FILE} ${DEPLOYDIR}/${IMAGE_NAME}.manifest
29# ln -s ${IMAGE_NAME}.manifest ${DEPLOYDIR}/${IMAGE_LINK_NAME}.manifest
30}
31
32addtask deploy after do_compile
diff --git a/meta-xilinx-core/recipes-bsp/bootbin/machine-xilinx-versal.inc b/meta-xilinx-core/recipes-bsp/bootbin/machine-xilinx-versal.inc
index fff2c7a3..cd6adcef 100644
--- a/meta-xilinx-core/recipes-bsp/bootbin/machine-xilinx-versal.inc
+++ b/meta-xilinx-core/recipes-bsp/bootbin/machine-xilinx-versal.inc
@@ -4,6 +4,9 @@ BOOTGEN_EXTRA_ARGS += "-dump bh"
4# specify BIF common attribute for FSBL 4# specify BIF common attribute for FSBL
5BIF_COMMON_ATTR ?= "" 5BIF_COMMON_ATTR ?= ""
6 6
7# specify BIF optional attributes
8BIF_OPTIONAL_DATA ?= ""
9
7#specify BIF partition attributes required for BOOT.bin 10#specify BIF partition attributes required for BOOT.bin
8BIF_FSBL_ATTR ??= "base-pdi plmfw psmfw" 11BIF_FSBL_ATTR ??= "base-pdi plmfw psmfw"
9BIF_ATF_ATTR ??= "arm-trusted-firmware" 12BIF_ATF_ATTR ??= "arm-trusted-firmware"
diff --git a/meta-xilinx-core/recipes-bsp/bootbin/xilinx-bootbin_1.0.bb b/meta-xilinx-core/recipes-bsp/bootbin/xilinx-bootbin_1.0.bb
index 4c8bfa0e..e0e1e506 100644
--- a/meta-xilinx-core/recipes-bsp/bootbin/xilinx-bootbin_1.0.bb
+++ b/meta-xilinx-core/recipes-bsp/bootbin/xilinx-bootbin_1.0.bb
@@ -125,6 +125,10 @@ python do_configure() {
125 biffd.write("the_ROM_image:\n") 125 biffd.write("the_ROM_image:\n")
126 biffd.write("{\n") 126 biffd.write("{\n")
127 127
128 if d.getVar("BIF_OPTIONAL_DATA"):
129 opt_data = d.getVar("BIF_OPTIONAL_DATA") or ""
130 biffd.write("\toptionaldata { %s }\n" % opt_data)
131
128 arch = d.getVar("SOC_FAMILY") 132 arch = d.getVar("SOC_FAMILY")
129 bifattr = (d.getVar("BIF_COMMON_ATTR") or "").split() 133 bifattr = (d.getVar("BIF_COMMON_ATTR") or "").split()
130 if bifattr: 134 if bifattr:
diff --git a/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb b/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb
index 8d7211f5..26a10677 100644
--- a/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb
+++ b/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb
@@ -130,7 +130,7 @@ devicetree_do_install:append() {
130 fi 130 fi
131 if [ -e "${D}/boot/devicetree/${DTB_FILE_NAME}" ]; then 131 if [ -e "${D}/boot/devicetree/${DTB_FILE_NAME}" ]; then
132 # We need the output to be system.dtb for WIC setup to match XSCT flow 132 # We need the output to be system.dtb for WIC setup to match XSCT flow
133 ln -sf devicetree/${DTB_FILE_NAME} ${D}/boot/system.dtb 133 cp ${D}/boot/devicetree/${DTB_FILE_NAME} ${D}/boot/system.dtb
134 else 134 else
135 bberror "Expected filename ${DTB_FILE_NAME} doesn't exist in ${DEPLOYDIR}/devicetree" 135 bberror "Expected filename ${DTB_FILE_NAME} doesn't exist in ${DEPLOYDIR}/devicetree"
136 fi 136 fi
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc
index 0a813d69..a7b1c9dc 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc
@@ -2,7 +2,7 @@ UBOOT_VERSION = "v2023.01"
2 2
3UBRANCH = "xlnx_rebase_v2023.01" 3UBRANCH = "xlnx_rebase_v2023.01"
4 4
5SRCREV = "4da834fc7644b4124f7417e0e2789c7afcb40352" 5SRCREV = "2b54ad6f1d278c419b927d10db2edf323d844578"
6 6
7LICENSE = "GPL-2.0-or-later" 7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897" 8LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897"
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
index 6410fc25..ac391c3c 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
@@ -262,10 +262,11 @@ do_compile() {
262do_install() { 262do_install() {
263 install -d ${D}/boot 263 install -d ${D}/boot
264 install -m 0644 boot.scr ${D}/boot/${UBOOTSCR_BASE_NAME}.scr 264 install -m 0644 boot.scr ${D}/boot/${UBOOTSCR_BASE_NAME}.scr
265 ln -sf ${UBOOTSCR_BASE_NAME}.scr ${D}/boot/boot.scr 265 install -m 0644 boot.scr ${D}/boot/
266 install -d ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME} 266 install -d ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME}
267 install -m 0644 pxeboot.pxe ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME}/default 267 install -m 0644 pxeboot.pxe ${D}/boot/pxeboot/${UBOOTPXE_CONFIG_NAME}/default
268 ln -sf pxeboot/${UBOOTPXE_CONFIG_NAME} ${D}/boot/${UBOOTPXE_CONFIG} 268 install -d ${D}/boot/${UBOOTPXE_CONFIG}/
269 install -m 0644 pxeboot.pxe ${D}/boot/${UBOOTPXE_CONFIG}/default
269} 270}
270 271
271FILES:${PN} = "/boot/*" 272FILES:${PN} = "/boot/*"
@@ -273,10 +274,11 @@ FILES:${PN} = "/boot/*"
273do_deploy() { 274do_deploy() {
274 install -d ${DEPLOYDIR} 275 install -d ${DEPLOYDIR}
275 install -m 0644 boot.scr ${DEPLOYDIR}/${UBOOTSCR_BASE_NAME}.scr 276 install -m 0644 boot.scr ${DEPLOYDIR}/${UBOOTSCR_BASE_NAME}.scr
276 ln -sf ${UBOOTSCR_BASE_NAME}.scr ${DEPLOYDIR}/boot.scr 277 install -m 0644 boot.scr ${DEPLOYDIR}/
277 install -d ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME} 278 install -d ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}
278 install -m 0644 pxeboot.pxe ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}/default 279 install -m 0644 pxeboot.pxe ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}/default
279 ln -sf pxeboot/${UBOOTPXE_CONFIG_NAME} ${DEPLOYDIR}/${UBOOTPXE_CONFIG} 280 install -d ${DEPLOYDIR}/${UBOOTPXE_CONFIG}/
281 install -m 0644 pxeboot.pxe ${DEPLOYDIR}/${UBOOTPXE_CONFIG}/default
280} 282}
281 283
282addtask do_deploy after do_compile before do_build 284addtask do_deploy after do_compile before do_build
diff --git a/meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.cfg b/meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.cfg
new file mode 100644
index 00000000..a5b23e3f
--- /dev/null
+++ b/meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.cfg
@@ -0,0 +1 @@
CONFIG_VERSAL_SYSMON_I2C=y
diff --git a/meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.scc b/meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.scc
new file mode 100644
index 00000000..c1830956
--- /dev/null
+++ b/meta-xilinx-core/recipes-kernel/linux/linux-xlnx/linux-xlnx-kmeta/features/versal-sysmon/versal-sysmon.scc
@@ -0,0 +1,2 @@
1# SPDX-License-Identifier: MIT
2kconf hardware versal-sysmon.cfg
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_git.bb b/meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_git.bb
new file mode 100644
index 00000000..e0edbb7b
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/xrt/xclbinutil-native_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Xilinx Runtime(XRT) - minimal native build for xclbinutil"
2DESCRIPTION = "Native build of xclbinutil using XRT codebase"
3
4require xrt.inc
5
6FILESEXTRAPATHS:append := ":${THISDIR}/xrt"
7
8LICENSE = "GPL-2.0-or-later & Apache-2.0 & MIT"
9LIC_FILES_CHKSUM = " \
10 file://../LICENSE;md5=de2c993ac479f02575bcbfb14ef9b485 \
11 file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
12 file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
14 file://runtime_src/core/tools/xbutil2/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
15 file://runtime_src/core/common/elf/LICENSE.txt;md5=b996e8b74af169e7e72e22d9e7d05b06 \
16"
17
18S = "${WORKDIR}/git/src"
19
20inherit cmake pkgconfig native
21
22DEPENDS = "libdrm-native ocl-icd-native boost-native rapidjson-native protobuf-native python3-pybind11-native systemtap-native"
23
24EXTRA_OECMAKE += " -DCMAKE_BUILD_TYPE=Release -DCMAKE_EXPORT_COMPILE_COMANDS=ON"
25
26do_install() {
27 install -d ${D}${bindir}
28 install -Dm 0755 ${WORKDIR}/build/runtime_src/tools/xclbinutil/xclbinutil ${D}${bindir}
29}
diff --git a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
index 15b91fdb..b1e1929f 100644
--- a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
+++ b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
@@ -6,13 +6,13 @@ REPO ??= "git://github.com/Xilinx/embeddedsw.git;protocol=https"
6ESW_BRANCH[2022.1] = "xlnx_rel_v2022.1_update" 6ESW_BRANCH[2022.1] = "xlnx_rel_v2022.1_update"
7ESW_BRANCH[2022.2] = "xlnx_rel_v2022.2" 7ESW_BRANCH[2022.2] = "xlnx_rel_v2022.2"
8ESW_BRANCH[2023.1] = "xlnx_rel_v2023.1_update" 8ESW_BRANCH[2023.1] = "xlnx_rel_v2023.1_update"
9ESW_BRANCH[2023.2] = "xlnx_rel_v2023.2" 9ESW_BRANCH[2023.2] = "xlnx_rel_v2023.2_update"
10BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}" 10BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}"
11 11
12ESW_REV[2022.1] = "56d94a506fd9f80949f4cff08e13015928603f01" 12ESW_REV[2022.1] = "56d94a506fd9f80949f4cff08e13015928603f01"
13ESW_REV[2022.2] = "5330a64c8efd14f0eef09befdbb8d3d738c33ec2" 13ESW_REV[2022.2] = "5330a64c8efd14f0eef09befdbb8d3d738c33ec2"
14ESW_REV[2023.1] = "af784f742dad0ca6e69e05baf8de51152c396b9a" 14ESW_REV[2023.1] = "af784f742dad0ca6e69e05baf8de51152c396b9a"
15ESW_REV[2023.2] = "c9a0ee31b2a14cbcfcb56ca369037319b4ad4847" 15ESW_REV[2023.2] = "e847e1935dca630615e5f7dc694365a44b89699c"
16SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or 'invalid'}" 16SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or 'invalid'}"
17 17
18EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}" 18EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}"
@@ -22,7 +22,7 @@ LICENSE = "MIT"
22LIC_FILES_CHKSUM[xlnx_rel_v2022.1_update] = 'e62cb7a722c4430999e0a55a7234035d' 22LIC_FILES_CHKSUM[xlnx_rel_v2022.1_update] = 'e62cb7a722c4430999e0a55a7234035d'
23LIC_FILES_CHKSUM[xlnx_rel_v2022.2] = 'ce611484168a6000bd35df68fc4f4290' 23LIC_FILES_CHKSUM[xlnx_rel_v2022.2] = 'ce611484168a6000bd35df68fc4f4290'
24LIC_FILES_CHKSUM[xlnx_rel_v2023.1_update] = '3c310a3ee2197a4c92c6a0e2937c207c' 24LIC_FILES_CHKSUM[xlnx_rel_v2023.1_update] = '3c310a3ee2197a4c92c6a0e2937c207c'
25LIC_FILES_CHKSUM[xlnx_rel_v2023.2] = '9fceecdbcad88698f265578f3d4cb26c' 25LIC_FILES_CHKSUM[xlnx_rel_v2023.2_update] = '9fceecdbcad88698f265578f3d4cb26c'
26LIC_FILES_CHKSUM ??= "file://license.txt;md5=${@d.getVarFlag('LIC_FILES_CHKSUM', d.getVar('BRANCH')) or '0'}" 26LIC_FILES_CHKSUM ??= "file://license.txt;md5=${@d.getVarFlag('LIC_FILES_CHKSUM', d.getVar('BRANCH')) or '0'}"
27 27
28SRC_URI = "${EMBEDDEDSW_SRCURI}" 28SRC_URI = "${EMBEDDEDSW_SRCURI}"