diff options
Diffstat (limited to 'meta-xilinx-core/recipes-devtools/python')
6 files changed, 107 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-devtools/python/python3-bokeh_3.5.1.bb b/meta-xilinx-core/recipes-devtools/python/python3-bokeh_3.5.1.bb new file mode 100644 index 00000000..75295dec --- /dev/null +++ b/meta-xilinx-core/recipes-devtools/python/python3-bokeh_3.5.1.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | SUMMARY = "Interactive plots and applications in the browser from Python" | ||
2 | HOMEPAGE = "https://bokeh.org" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4d2241e774601133cb2c58ae1277f9a5" | ||
5 | |||
6 | DEPENDS += " \ | ||
7 | python3-colorama-native \ | ||
8 | python3-setuptools-git-versioning-native \ | ||
9 | " | ||
10 | |||
11 | SRC_URI[sha256sum] = "21dbe86842b24d83c73a1aef2de346a1a7c11c437015d6e9d180a1637e6e8197" | ||
12 | |||
13 | inherit pypi python_setuptools_build_meta | ||
14 | |||
15 | RDEPENDS:${PN} = " \ | ||
16 | python3-colorama \ | ||
17 | python3-contourpy \ | ||
18 | python3-jinja2 \ | ||
19 | python3-numpy \ | ||
20 | python3-packaging \ | ||
21 | python3-pandas \ | ||
22 | python3-pillow \ | ||
23 | python3-pyyaml \ | ||
24 | python3-tornado \ | ||
25 | python3-typing-extensions \ | ||
26 | python3-xyzservices \ | ||
27 | " | ||
diff --git a/meta-xilinx-core/recipes-devtools/python/python3-contourpy_1.2.1.bb b/meta-xilinx-core/recipes-devtools/python/python3-contourpy_1.2.1.bb new file mode 100644 index 00000000..5f21b002 --- /dev/null +++ b/meta-xilinx-core/recipes-devtools/python/python3-contourpy_1.2.1.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "Python library for calculating contours of 2D quadrilateral grids" | ||
2 | HOMEPAGE = "https://github.com/contourpy/contourpy" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a051d5dfc6ccbc7bbe3e626d65156784" | ||
5 | |||
6 | DEPENDS += " \ | ||
7 | meson-native \ | ||
8 | python3-pybind11-native \ | ||
9 | " | ||
10 | |||
11 | SRC_URI[sha256sum] = "4d8908b3bee1c889e547867ca4cdc54e5ab6be6d3e078556814a22457f49423c" | ||
12 | |||
13 | inherit pypi python_mesonpy | ||
14 | |||
15 | RDEPENDS:${PN} = "python3-numpy" | ||
diff --git a/meta-xilinx-core/recipes-devtools/python/python3-mercantile_1.2.1.bb b/meta-xilinx-core/recipes-devtools/python/python3-mercantile_1.2.1.bb new file mode 100644 index 00000000..33987e68 --- /dev/null +++ b/meta-xilinx-core/recipes-devtools/python/python3-mercantile_1.2.1.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Web mercator XYZ tile utilities" | ||
2 | HOMEPAGE = "https://github.com/mapbox/mercantile" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=11e1a3a1ec3801b170b9152c135e8f74 \ | ||
5 | file://docs/license.rst;md5=083a4719b463be5b728fd0e3f47db7e7" | ||
6 | |||
7 | SRC_URI[sha256sum] = "fa3c6db15daffd58454ac198b31887519a19caccee3f9d63d17ae7ff61b3b56b" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS:${PN} += " \ | ||
12 | python3-click \ | ||
13 | python3-core \ | ||
14 | python3-json \ | ||
15 | python3-logging \ | ||
16 | " | ||
diff --git a/meta-xilinx-core/recipes-devtools/python/python3-pybind11_2.13.1.bb b/meta-xilinx-core/recipes-devtools/python/python3-pybind11_2.13.1.bb new file mode 100644 index 00000000..3c03069b --- /dev/null +++ b/meta-xilinx-core/recipes-devtools/python/python3-pybind11_2.13.1.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | SUMMARY = "Seamless operability between C++11 and Python" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f" | ||
4 | |||
5 | SRC_URI[sha256sum] = "65be498b1cac516161add1508e65375674916bebf2570d057dc9c3c7bcbbc7b0" | ||
6 | |||
7 | inherit pypi python_setuptools_build_meta | ||
8 | |||
9 | BBCLASSEXTEND += "native" | ||
diff --git a/meta-xilinx-core/recipes-devtools/python/python3-setuptools-git-versioning_2.0.0.bb b/meta-xilinx-core/recipes-devtools/python/python3-setuptools-git-versioning_2.0.0.bb new file mode 100644 index 00000000..53f04b77 --- /dev/null +++ b/meta-xilinx-core/recipes-devtools/python/python3-setuptools-git-versioning_2.0.0.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Use git repo data for building a version number according PEP-440" | ||
2 | HOMEPAGE = "https://setuptools-git-versioning.readthedocs.io" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=92e79e3a844e66731724600f3ac9c0d8" | ||
5 | |||
6 | SRC_URI[sha256sum] = "85b5fbe7bda8e9c24bbd9e587a9d4b91129417f4dd3e11e3c0d5f3f835fc4d4d" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | RDEPENDS:${PN} += " \ | ||
11 | python3-core \ | ||
12 | python3-datetime \ | ||
13 | python3-logging \ | ||
14 | python3-packaging \ | ||
15 | python3-pprint \ | ||
16 | python3-setuptools \ | ||
17 | python3-tomllib \ | ||
18 | " | ||
19 | |||
20 | BBCLASSEXTEND += "native" | ||
diff --git a/meta-xilinx-core/recipes-devtools/python/python3-xyzservices_2024.6.0.bb b/meta-xilinx-core/recipes-devtools/python/python3-xyzservices_2024.6.0.bb new file mode 100644 index 00000000..3e9b7ee1 --- /dev/null +++ b/meta-xilinx-core/recipes-devtools/python/python3-xyzservices_2024.6.0.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Source of XYZ tiles providers" | ||
2 | HOMEPAGE = "https://github.com/geopandas/xyzservices" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6a3e440ffacb99f21fa410467c048574" | ||
5 | |||
6 | DEPENDS += "python3-setuptools-scm-native" | ||
7 | |||
8 | SRC_URI[sha256sum] = "58c1bdab4257d2551b9ef91cd48571f77b7c4d2bc45bf5e3c05ac97b3a4d7282" | ||
9 | |||
10 | inherit pypi python_setuptools_build_meta | ||
11 | |||
12 | FILES:${PN} += "${prefix}" | ||
13 | |||
14 | RDEPENDS:${PN} += " \ | ||
15 | python3-core \ | ||
16 | python3-json \ | ||
17 | python3-mercantile \ | ||
18 | python3-netclient \ | ||
19 | python3-requests \ | ||
20 | " | ||