summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-virtualization/recipes-devtools/qemu/qemu-xilinx-7.1/0002-xen-mapcache-move-xen-mapcache.c-to-hw-xen.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-virtualization/recipes-devtools/qemu/qemu-xilinx-7.1/0002-xen-mapcache-move-xen-mapcache.c-to-hw-xen.patch')
-rw-r--r--meta-xilinx-virtualization/recipes-devtools/qemu/qemu-xilinx-7.1/0002-xen-mapcache-move-xen-mapcache.c-to-hw-xen.patch88
1 files changed, 0 insertions, 88 deletions
diff --git a/meta-xilinx-virtualization/recipes-devtools/qemu/qemu-xilinx-7.1/0002-xen-mapcache-move-xen-mapcache.c-to-hw-xen.patch b/meta-xilinx-virtualization/recipes-devtools/qemu/qemu-xilinx-7.1/0002-xen-mapcache-move-xen-mapcache.c-to-hw-xen.patch
deleted file mode 100644
index 35ca6df4..00000000
--- a/meta-xilinx-virtualization/recipes-devtools/qemu/qemu-xilinx-7.1/0002-xen-mapcache-move-xen-mapcache.c-to-hw-xen.patch
+++ /dev/null
@@ -1,88 +0,0 @@
1From 423468bdb3728154e95af18ef755bc75c5d59a3a Mon Sep 17 00:00:00 2001
2From: Vikram Garhwal <vikram.garhwal@amd.com>
3Date: Thu, 30 Jun 2022 18:19:50 -0700
4Subject: [PATCH 02/16] xen-mapcache: move xen-mapcache.c to hw/xen
5
6xen-mapcache.c contains common functions which are useful for Xen on ARM
7IOREQ handling. Moving it out of i386 to hw/xen for commong access.
8
9Signed-off-by: Vikram Garhwal <vikram.garhwal@amd.com>
10Reviewed-by: Stefano Stabellini <stefano.stabellini@xilinx.com>
11Signed-off-by: Stefano Stabellini <stefano.stabellini@xilinx.com>
12---
13 hw/i386/meson.build | 1 +
14 hw/i386/xen/meson.build | 1 -
15 hw/i386/xen/trace-events | 5 -----
16 hw/xen/meson.build | 4 ++++
17 hw/xen/trace-events | 5 +++++
18 hw/{i386 => }/xen/xen-mapcache.c | 0
19 6 files changed, 10 insertions(+), 6 deletions(-)
20 rename hw/{i386 => }/xen/xen-mapcache.c (100%)
21
22diff --git a/hw/i386/meson.build b/hw/i386/meson.build
23index 213e2e82b3..cfdbfdcbcb 100644
24--- a/hw/i386/meson.build
25+++ b/hw/i386/meson.build
26@@ -33,5 +33,6 @@ subdir('kvm')
27 subdir('xen')
28
29 i386_ss.add_all(xenpv_ss)
30+i386_ss.add_all(xen_ss)
31
32 hw_arch += {'i386': i386_ss}
33diff --git a/hw/i386/xen/meson.build b/hw/i386/xen/meson.build
34index be84130300..2fcc46e6ca 100644
35--- a/hw/i386/xen/meson.build
36+++ b/hw/i386/xen/meson.build
37@@ -1,6 +1,5 @@
38 i386_ss.add(when: 'CONFIG_XEN', if_true: files(
39 'xen-hvm.c',
40- 'xen-mapcache.c',
41 'xen_apic.c',
42 'xen_platform.c',
43 'xen_pvdevice.c',
44diff --git a/hw/i386/xen/trace-events b/hw/i386/xen/trace-events
45index 5d6be61090..a0c89d91c4 100644
46--- a/hw/i386/xen/trace-events
47+++ b/hw/i386/xen/trace-events
48@@ -21,8 +21,3 @@ xen_map_resource_ioreq(uint32_t id, void *addr) "id: %u addr: %p"
49 cpu_ioreq_config_read(void *req, uint32_t sbdf, uint32_t reg, uint32_t size, uint32_t data) "I/O=%p sbdf=0x%x reg=%u size=%u data=0x%x"
50 cpu_ioreq_config_write(void *req, uint32_t sbdf, uint32_t reg, uint32_t size, uint32_t data) "I/O=%p sbdf=0x%x reg=%u size=%u data=0x%x"
51
52-# xen-mapcache.c
53-xen_map_cache(uint64_t phys_addr) "want 0x%"PRIx64
54-xen_remap_bucket(uint64_t index) "index 0x%"PRIx64
55-xen_map_cache_return(void* ptr) "%p"
56-
57diff --git a/hw/xen/meson.build b/hw/xen/meson.build
58index ae0ace3046..19d0637c46 100644
59--- a/hw/xen/meson.build
60+++ b/hw/xen/meson.build
61@@ -22,3 +22,7 @@ else
62 endif
63
64 specific_ss.add_all(when: ['CONFIG_XEN', xen], if_true: xen_specific_ss)
65+
66+xen_ss = ss.source_set()
67+
68+xen_ss.add(when: 'CONFIG_XEN', if_true: files('xen-mapcache.c'))
69diff --git a/hw/xen/trace-events b/hw/xen/trace-events
70index 3da3fd8348..2c8f238f42 100644
71--- a/hw/xen/trace-events
72+++ b/hw/xen/trace-events
73@@ -41,3 +41,8 @@ xs_node_vprintf(char *path, char *value) "%s %s"
74 xs_node_vscanf(char *path, char *value) "%s %s"
75 xs_node_watch(char *path) "%s"
76 xs_node_unwatch(char *path) "%s"
77+
78+# xen-mapcache.c
79+xen_map_cache(uint64_t phys_addr) "want 0x%"PRIx64
80+xen_remap_bucket(uint64_t index) "index 0x%"PRIx64
81+xen_map_cache_return(void* ptr) "%p"
82diff --git a/hw/i386/xen/xen-mapcache.c b/hw/xen/xen-mapcache.c
83similarity index 100%
84rename from hw/i386/xen/xen-mapcache.c
85rename to hw/xen/xen-mapcache.c
86--
872.17.1
88