summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/diffstat/diffstat_1.68.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/diffstat/diffstat_1.68.bb')
-rw-r--r--meta/recipes-devtools/diffstat/diffstat_1.68.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/diffstat/diffstat_1.68.bb b/meta/recipes-devtools/diffstat/diffstat_1.68.bb
new file mode 100644
index 0000000000..488f0834d6
--- /dev/null
+++ b/meta/recipes-devtools/diffstat/diffstat_1.68.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "X11"
8LIC_FILES_CHKSUM = "file://COPYING;md5=0c432d3aeb935855b2ca1ad2a0542ce4"
9
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
13 "
14
15SRC_URI[sha256sum] = "89f9294a8ac74fcef6f1b9ac408f43ebedf8d208e3efe0b99b4acc16dc6582c7"
16
17inherit autotools gettext ptest
18
19EXTRA_AUTORECONF += "--exclude=aclocal"
20
21LDFLAGS += "${TOOLCHAIN_OPTIONS}"
22
23do_install_ptest() {
24 cp -r ${S}/testing ${D}${PTEST_PATH}
25}
26
27BBCLASSEXTEND = "nativesdk"