diff options
author | Peter Kjellerstedt <pkj@axis.com> | 2021-04-15 01:32:40 +0200 |
---|---|---|
committer | Mike Frysinger <vapier@google.com> | 2021-06-03 11:34:17 +0000 |
commit | a3b2edf1af4854881c763010d1083e8c76ac7535 (patch) | |
tree | 0a42ec1a817f733567a4b3d8a4ce533a1380fc30 /setup.py | |
parent | e253b43e17de114f1efafa9a3e3929f23115ae99 (diff) | |
download | git-repo-a3b2edf1af4854881c763010d1083e8c76ac7535.tar.gz |
Drop support for Python 3.5
Running repo with Python 3.5 fails due to the use of the encoding
parameter to subprocess.run(). There are also f-strings being used in
some of the tests.
This drops support for these systems:
* Ubuntu Xenial: released Apr 2016, EOS Apr 2021, EOL Apr 2024
* Debian Stretch: released Jun 2017, EOL Jun 2022
So the minimum required distros now are:
* Ubuntu Bionic: released Apr 2018 w/Python 3.6
* Debian Buster: released Jul 2019 w/Python 3.7
Change-Id: I1144f7ab6f882b10cac0131982df081fe4ac44f9
Reviewed-on: https://gerrit-review.googlesource.com/c/git-repo/+/303363
Reviewed-by: Mike Frysinger <vapier@google.com>
Tested-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -56,6 +56,6 @@ setuptools.setup( | |||
56 | 'Programming Language :: Python :: 3 :: Only', | 56 | 'Programming Language :: Python :: 3 :: Only', |
57 | 'Topic :: Software Development :: Version Control :: Git', | 57 | 'Topic :: Software Development :: Version Control :: Git', |
58 | ], | 58 | ], |
59 | python_requires='>=3.5', | 59 | python_requires='>=3.6', |
60 | packages=['subcmds'], | 60 | packages=['subcmds'], |
61 | ) | 61 | ) |