summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGavin Mak <gavinmak@google.com>2023-03-11 06:46:20 +0000
committerLUCI <gerrit-scoped@luci-project-accounts.iam.gserviceaccount.com>2023-03-22 17:46:28 +0000
commitea2e330e43c182dc16b0111ebc69ee5a71ee4ce1 (patch)
treedc33ba0e56825b3e007d0589891756724725a465 /setup.py
parent1604cf255f8c1786a23388db6d5277ac7949a24a (diff)
downloadgit-repo-ea2e330e43c182dc16b0111ebc69ee5a71ee4ce1.tar.gz
Format codebase with black and check formatting in CQ
Apply rules set by https://gerrit-review.googlesource.com/c/git-repo/+/362954/ across the codebase and fix any lingering errors caught by flake8. Also check black formatting in run_tests (and CQ). Bug: b/267675342 Change-Id: I972d77649dac351150dcfeb1cd1ad0ea2efc1956 Reviewed-on: https://gerrit-review.googlesource.com/c/git-repo/+/363474 Reviewed-by: Mike Frysinger <vapier@google.com> Tested-by: Gavin Mak <gavinmak@google.com> Commit-Queue: Gavin Mak <gavinmak@google.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py48
1 files changed, 24 insertions, 24 deletions
diff --git a/setup.py b/setup.py
index 848b3f60..f50eb473 100755
--- a/setup.py
+++ b/setup.py
@@ -23,39 +23,39 @@ TOPDIR = os.path.dirname(os.path.abspath(__file__))
23 23
24 24
25# Rip out the first intro paragraph. 25# Rip out the first intro paragraph.
26with open(os.path.join(TOPDIR, 'README.md')) as fp: 26with open(os.path.join(TOPDIR, "README.md")) as fp:
27 lines = fp.read().splitlines()[2:] 27 lines = fp.read().splitlines()[2:]
28 end = lines.index('') 28 end = lines.index("")
29 long_description = ' '.join(lines[0:end]) 29 long_description = " ".join(lines[0:end])
30 30
31 31
32# https://packaging.python.org/tutorials/packaging-projects/ 32# https://packaging.python.org/tutorials/packaging-projects/
33setuptools.setup( 33setuptools.setup(
34 name='repo', 34 name="repo",
35 version='2', 35 version="2",
36 maintainer='Various', 36 maintainer="Various",
37 maintainer_email='repo-discuss@googlegroups.com', 37 maintainer_email="repo-discuss@googlegroups.com",
38 description='Repo helps manage many Git repositories', 38 description="Repo helps manage many Git repositories",
39 long_description=long_description, 39 long_description=long_description,
40 long_description_content_type='text/plain', 40 long_description_content_type="text/plain",
41 url='https://gerrit.googlesource.com/git-repo/', 41 url="https://gerrit.googlesource.com/git-repo/",
42 project_urls={ 42 project_urls={
43 'Bug Tracker': 'https://bugs.chromium.org/p/gerrit/issues/list?q=component:Applications%3Erepo', 43 "Bug Tracker": "https://bugs.chromium.org/p/gerrit/issues/list?q=component:Applications%3Erepo", # noqa: E501
44 }, 44 },
45 # https://pypi.org/classifiers/ 45 # https://pypi.org/classifiers/
46 classifiers=[ 46 classifiers=[
47 'Development Status :: 6 - Mature', 47 "Development Status :: 6 - Mature",
48 'Environment :: Console', 48 "Environment :: Console",
49 'Intended Audience :: Developers', 49 "Intended Audience :: Developers",
50 'License :: OSI Approved :: Apache Software License', 50 "License :: OSI Approved :: Apache Software License",
51 'Natural Language :: English', 51 "Natural Language :: English",
52 'Operating System :: MacOS :: MacOS X', 52 "Operating System :: MacOS :: MacOS X",
53 'Operating System :: Microsoft :: Windows :: Windows 10', 53 "Operating System :: Microsoft :: Windows :: Windows 10",
54 'Operating System :: POSIX :: Linux', 54 "Operating System :: POSIX :: Linux",
55 'Programming Language :: Python :: 3', 55 "Programming Language :: Python :: 3",
56 'Programming Language :: Python :: 3 :: Only', 56 "Programming Language :: Python :: 3 :: Only",
57 'Topic :: Software Development :: Version Control :: Git', 57 "Topic :: Software Development :: Version Control :: Git",
58 ], 58 ],
59 python_requires='>=3.6', 59 python_requires=">=3.6",
60 packages=['subcmds'], 60 packages=["subcmds"],
61) 61)