diff options
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -1,4 +1,4 @@ | |||
1 | #!/usr/bin/env python | 1 | #!/usr/bin/env python3 |
2 | # -*- coding:utf-8 -*- | 2 | # -*- coding:utf-8 -*- |
3 | # Copyright 2019 The Android Open Source Project | 3 | # Copyright 2019 The Android Open Source Project |
4 | # | 4 | # |
@@ -55,9 +55,10 @@ setuptools.setup( | |||
55 | 'Operating System :: MacOS :: MacOS X', | 55 | 'Operating System :: MacOS :: MacOS X', |
56 | 'Operating System :: Microsoft :: Windows :: Windows 10', | 56 | 'Operating System :: Microsoft :: Windows :: Windows 10', |
57 | 'Operating System :: POSIX :: Linux', | 57 | 'Operating System :: POSIX :: Linux', |
58 | 'Programming Language :: Python :: 3', | ||
59 | 'Programming Language :: Python :: 3 :: Only', | ||
58 | 'Topic :: Software Development :: Version Control :: Git', | 60 | 'Topic :: Software Development :: Version Control :: Git', |
59 | ], | 61 | ], |
60 | # We support Python 2.7 and Python 3.6+. | 62 | python_requires='>=3.6', |
61 | python_requires='>=2.7, ' + ', '.join('!=3.%i.*' % x for x in range(0, 6)), | ||
62 | packages=['subcmds'], | 63 | packages=['subcmds'], |
63 | ) | 64 | ) |