diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2025-04-02 17:02:21 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-04-02 12:50:10 -0700 |
commit | 7d376c4a0cb45d34f45a26a843b57b3c21cf59fc (patch) | |
tree | bba813a9ed60765484cbc15897e2ada952404abc /recipes-devtools/clang/clang.inc | |
parent | 6ec8e778edf8eea06b381b0b30d6ee036f650e7d (diff) | |
download | meta-clang-7d376c4a0cb45d34f45a26a843b57b3c21cf59fc.tar.gz |
clang: add whitespace around assignments
With:
https://lists.openembedded.org/g/bitbake-devel/message/17508
there are many WARNINGs from this layer
Most of them are caused by this LLVM_LIBDIR_SUFFIX=" which is included
everywhere.
WARNING: meta-clang/recipes-devtools/clang/clang-cross-canadian_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/clang-crosssdk_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/clang_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/compiler-rt-sanitizers_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/compiler-rt-sanitizers_git.bb: meta-clang/recipes-devtools/clang/compiler-rt-sanitizers_git.bb:31 has a lack of whitespace around the assignment: 'PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"'
WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:47 has a lack of whitespace around the assignment: 'PACKAGECONFIG[profile] ="-DCOMPILER_RT_BUILD_PROFILE=ON,-DCOMPILER_RT_BUILD_PROFILE=OFF"'
WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:49 has a lack of whitespace around the assignment: 'PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"'
WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:47 has a lack of whitespace around the assignment: 'PACKAGECONFIG[profile] ="-DCOMPILER_RT_BUILD_PROFILE=ON,-DCOMPILER_RT_BUILD_PROFILE=OFF"'
WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:49 has a lack of whitespace around the assignment: 'PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"'
WARNING: meta-clang/recipes-devtools/clang/libclc_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/libcxx_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/llvm-project-source.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
WARNING: meta-clang/recipes-devtools/clang/openmp_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"'
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/clang.inc')
-rw-r--r-- | recipes-devtools/clang/clang.inc | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang.inc b/recipes-devtools/clang/clang.inc index 784b1b1..59735cd 100644 --- a/recipes-devtools/clang/clang.inc +++ b/recipes-devtools/clang/clang.inc | |||
@@ -16,7 +16,7 @@ CLANGMD5SUM = "ff42885ed2ab98f1ecb8c1fc41205343" | |||
16 | LLDMD5SUM = "ae7dc7c027b1fa89b5b013d391d3ee2b" | 16 | LLDMD5SUM = "ae7dc7c027b1fa89b5b013d391d3ee2b" |
17 | LLDBMD5SUM = "2e0d44968471fcde980034dbb826bea9" | 17 | LLDBMD5SUM = "2e0d44968471fcde980034dbb826bea9" |
18 | 18 | ||
19 | LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}" | 19 | LLVM_LIBDIR_SUFFIX = "${@d.getVar('baselib').replace('lib', '')}" |
20 | 20 | ||
21 | # set the default pigz thread | 21 | # set the default pigz thread |
22 | export PIGZ = "-p ${@oe.utils.cpu_count(at_least=2)}" | 22 | export PIGZ = "-p ${@oe.utils.cpu_count(at_least=2)}" |