diff options
author | Khem Raj <raj.khem@gmail.com> | 2025-04-17 18:25:18 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-05 10:24:26 -0700 |
commit | b6d7ecd8905b0a41c9f06c017d16851c784f02cc (patch) | |
tree | 65926761f78e4a883cdcd7eadeeb4a35faa92c12 /recipes-devtools/clang/openmp_git.bb | |
parent | c378a777aefd192eae797ef633de817e29426667 (diff) | |
download | meta-clang-b6d7ecd8905b0a41c9f06c017d16851c784f02cc.tar.gz |
clang: Delete recipes
They are in core layer now
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/openmp_git.bb')
-rw-r--r-- | recipes-devtools/clang/openmp_git.bb | 67 |
1 files changed, 0 insertions, 67 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb deleted file mode 100644 index 398479b..0000000 --- a/recipes-devtools/clang/openmp_git.bb +++ /dev/null | |||
@@ -1,67 +0,0 @@ | |||
1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "LLVM OpenMP compiler Runtime" | ||
5 | HOMEPAGE = "https://openmp.llvm.org/" | ||
6 | SECTION = "libs" | ||
7 | |||
8 | require clang.inc | ||
9 | require common-source.inc | ||
10 | |||
11 | BPN = "openmp" | ||
12 | |||
13 | TOOLCHAIN = "clang" | ||
14 | |||
15 | LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" | ||
16 | |||
17 | inherit cmake pkgconfig perlnative python3native python3targetconfig | ||
18 | |||
19 | DEPENDS += "elfutils libffi clang" | ||
20 | |||
21 | EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RelWithDebInfo \ | ||
22 | -DLLVM_APPEND_VC_REV=OFF \ | ||
23 | -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR=OFF \ | ||
24 | -DOPENMP_LIBDIR_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \ | ||
25 | -DOPENMP_STANDALONE_BUILD=ON \ | ||
26 | -DCLANG_TOOL=${STAGING_BINDIR_NATIVE}/clang \ | ||
27 | -DLINK_TOOL=${STAGING_BINDIR_NATIVE}/llvm-link \ | ||
28 | -DOPT_TOOL=${STAGING_BINDIR_NATIVE}/opt \ | ||
29 | -DOPENMP_LLVM_LIT_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-lit \ | ||
30 | -DEXTRACT_TOOL=${STAGING_BINDIR_NATIVE}/llvm-extract \ | ||
31 | -DPACKAGER_TOOL=${STAGING_BINDIR_NATIVE}/clang-offload-packager \ | ||
32 | -DCMAKE_POSITION_INDEPENDENT_CODE=ON \ | ||
33 | " | ||
34 | |||
35 | OECMAKE_SOURCEPATH = "${S}/openmp" | ||
36 | |||
37 | PACKAGECONFIG ?= "ompt-tools offloading-plugin" | ||
38 | |||
39 | PACKAGECONFIG:remove:arm = "ompt-tools offloading-plugin" | ||
40 | PACKAGECONFIG:remove:powerpc = "ompt-tools offloading-plugin" | ||
41 | |||
42 | PACKAGECONFIG:append:mipsarcho32 = " no-atomics" | ||
43 | |||
44 | PACKAGECONFIG[ompt-tools] = "-DOPENMP_ENABLE_OMPT_TOOLS=ON,-DOPENMP_ENABLE_OMPT_TOOLS=OFF," | ||
45 | PACKAGECONFIG[aliases] = "-DLIBOMP_INSTALL_ALIASES=ON,-DLIBOMP_INSTALL_ALIASES=OFF," | ||
46 | PACKAGECONFIG[offloading-plugin] = ",,elfutils libffi,libelf libffi" | ||
47 | PACKAGECONFIG[no-atomics] = "-DLIBOMP_HAVE_BUILTIN_ATOMIC=OFF -DLIBOMP_LIBFLAGS='-latomic',," | ||
48 | |||
49 | PACKAGES += "${PN}-libomptarget ${PN}-gdb-plugin" | ||
50 | FILES_SOLIBSDEV = "" | ||
51 | FILES:${PN} += "${libdir}/lib*${SOLIBSDEV}" | ||
52 | FILES:${PN}-libomptarget = "${libdir}/libomptarget-*.bc" | ||
53 | FILES:${PN}-gdb-plugin = "${datadir}/gdb/python/ompd" | ||
54 | |||
55 | RDEPENDS:${PN}-gdb-plugin += "python3-core" | ||
56 | |||
57 | INSANE_SKIP:${PN} = "dev-so" | ||
58 | # Currently the static libraries contain buildpaths | ||
59 | INSANE_SKIP:${PN}-staticdev += "buildpaths" | ||
60 | |||
61 | COMPATIBLE_HOST:mips64 = "null" | ||
62 | COMPATIBLE_HOST:riscv32 = "null" | ||
63 | COMPATIBLE_HOST:powerpc = "null" | ||
64 | |||
65 | BBCLASSEXTEND = "native nativesdk" | ||
66 | |||
67 | CVE_STATUS[CVE-2022-26345] = "cpe-incorrect: specific to the Intel distribution before 2022.1" | ||