summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/openmp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/openmp_git.bb')
-rw-r--r--recipes-devtools/clang/openmp_git.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
deleted file mode 100644
index 398479b..0000000
--- a/recipes-devtools/clang/openmp_git.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "LLVM OpenMP compiler Runtime"
5HOMEPAGE = "https://openmp.llvm.org/"
6SECTION = "libs"
7
8require clang.inc
9require common-source.inc
10
11BPN = "openmp"
12
13TOOLCHAIN = "clang"
14
15LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79"
16
17inherit cmake pkgconfig perlnative python3native python3targetconfig
18
19DEPENDS += "elfutils libffi clang"
20
21EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RelWithDebInfo \
22 -DLLVM_APPEND_VC_REV=OFF \
23 -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR=OFF \
24 -DOPENMP_LIBDIR_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
25 -DOPENMP_STANDALONE_BUILD=ON \
26 -DCLANG_TOOL=${STAGING_BINDIR_NATIVE}/clang \
27 -DLINK_TOOL=${STAGING_BINDIR_NATIVE}/llvm-link \
28 -DOPT_TOOL=${STAGING_BINDIR_NATIVE}/opt \
29 -DOPENMP_LLVM_LIT_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-lit \
30 -DEXTRACT_TOOL=${STAGING_BINDIR_NATIVE}/llvm-extract \
31 -DPACKAGER_TOOL=${STAGING_BINDIR_NATIVE}/clang-offload-packager \
32 -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
33 "
34
35OECMAKE_SOURCEPATH = "${S}/openmp"
36
37PACKAGECONFIG ?= "ompt-tools offloading-plugin"
38
39PACKAGECONFIG:remove:arm = "ompt-tools offloading-plugin"
40PACKAGECONFIG:remove:powerpc = "ompt-tools offloading-plugin"
41
42PACKAGECONFIG:append:mipsarcho32 = " no-atomics"
43
44PACKAGECONFIG[ompt-tools] = "-DOPENMP_ENABLE_OMPT_TOOLS=ON,-DOPENMP_ENABLE_OMPT_TOOLS=OFF,"
45PACKAGECONFIG[aliases] = "-DLIBOMP_INSTALL_ALIASES=ON,-DLIBOMP_INSTALL_ALIASES=OFF,"
46PACKAGECONFIG[offloading-plugin] = ",,elfutils libffi,libelf libffi"
47PACKAGECONFIG[no-atomics] = "-DLIBOMP_HAVE_BUILTIN_ATOMIC=OFF -DLIBOMP_LIBFLAGS='-latomic',,"
48
49PACKAGES += "${PN}-libomptarget ${PN}-gdb-plugin"
50FILES_SOLIBSDEV = ""
51FILES:${PN} += "${libdir}/lib*${SOLIBSDEV}"
52FILES:${PN}-libomptarget = "${libdir}/libomptarget-*.bc"
53FILES:${PN}-gdb-plugin = "${datadir}/gdb/python/ompd"
54
55RDEPENDS:${PN}-gdb-plugin += "python3-core"
56
57INSANE_SKIP:${PN} = "dev-so"
58# Currently the static libraries contain buildpaths
59INSANE_SKIP:${PN}-staticdev += "buildpaths"
60
61COMPATIBLE_HOST:mips64 = "null"
62COMPATIBLE_HOST:riscv32 = "null"
63COMPATIBLE_HOST:powerpc = "null"
64
65BBCLASSEXTEND = "native nativesdk"
66
67CVE_STATUS[CVE-2022-26345] = "cpe-incorrect: specific to the Intel distribution before 2022.1"