summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2024-08-19 07:03:58 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2024-08-19 07:16:16 -0700
commit1963104c4ad7367686c910c70a07cbc7df3cd6c5 (patch)
treee972fd992f78fcc26723e387fae1928761d80452
parente4a09a4c5a1a10ec0ed96facaa9a8b1a2f506d7b (diff)
downloadmeta-freescale-1963104c4ad7367686c910c70a07cbc7df3cd6c5.tar.gz
weston-init: Fix RDP support
The modification of the weston.ini command line necessary for RDP support is missing. The problem is the weston.ini template contains `@bindir@`, while the sed operation for the modification contains `${bindir}`. Fix the problem by moving the replacement of `@bindir@` to the top of the function `do_install:append()`. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 07a4ea86..27a5b947 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -58,6 +58,9 @@ PACKAGECONFIG[use-g2d] = ",,"
58PACKAGECONFIG[xwayland] = ",," 58PACKAGECONFIG[xwayland] = ",,"
59 59
60do_install:append() { 60do_install:append() {
61 # Replace the template variables
62 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini
63
61 if [ -f "${UNPACKDIR}/weston.config" ]; then 64 if [ -f "${UNPACKDIR}/weston.config" ]; then
62 install -Dm0755 ${UNPACKDIR}/weston.config ${D}${sysconfdir}/default/weston 65 install -Dm0755 ${UNPACKDIR}/weston.config ${D}${sysconfdir}/default/weston
63 fi 66 fi
@@ -88,6 +91,4 @@ do_install:append() {
88 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "no" ]; then 91 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "no" ]; then
89 sed -i -e "s/^xwayland=true/#xwayland=true/g" ${D}${sysconfdir}/xdg/weston/weston.ini 92 sed -i -e "s/^xwayland=true/#xwayland=true/g" ${D}${sysconfdir}/xdg/weston/weston.ini
90 fi 93 fi
91
92 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini
93} 94}