summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 07a4ea86..27a5b947 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -58,6 +58,9 @@ PACKAGECONFIG[use-g2d] = ",,"
58PACKAGECONFIG[xwayland] = ",," 58PACKAGECONFIG[xwayland] = ",,"
59 59
60do_install:append() { 60do_install:append() {
61 # Replace the template variables
62 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini
63
61 if [ -f "${UNPACKDIR}/weston.config" ]; then 64 if [ -f "${UNPACKDIR}/weston.config" ]; then
62 install -Dm0755 ${UNPACKDIR}/weston.config ${D}${sysconfdir}/default/weston 65 install -Dm0755 ${UNPACKDIR}/weston.config ${D}${sysconfdir}/default/weston
63 fi 66 fi
@@ -88,6 +91,4 @@ do_install:append() {
88 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "no" ]; then 91 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "no" ]; then
89 sed -i -e "s/^xwayland=true/#xwayland=true/g" ${D}${sysconfdir}/xdg/weston/weston.ini 92 sed -i -e "s/^xwayland=true/#xwayland=true/g" ${D}${sysconfdir}/xdg/weston/weston.ini
90 fi 93 fi
91
92 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini
93} 94}