summaryrefslogtreecommitdiffstats
path: root/recipes-extended/secure-obj
diff options
context:
space:
mode:
authorFlora Hu <flora.hu@nxp.com>2024-11-04 16:56:19 +0800
committerFlora Hu <flora.hu@nxp.com>2024-11-05 11:06:23 +0800
commit1e3e3eb90e58a652899c9e9a9c49cecccc586b9c (patch)
tree7157dcf2923c6c75f8afa016b199e1f04b92f534 /recipes-extended/secure-obj
parent412acc27c60d325d43919e74d9124336931360be (diff)
downloadmeta-freescale-1e3e3eb90e58a652899c9e9a9c49cecccc586b9c.tar.gz
secure-obj: Update to latest from NXP 6.6.36-2.1.0
- secure-obj: update license; update revision to 4706a65; make it compatible with OPTEE 3.17+ - secure-obj-module: update license; update revision to 4706a65 Signed-off-by: Flora Hu <flora.hu@nxp.com>
Diffstat (limited to 'recipes-extended/secure-obj')
-rw-r--r--recipes-extended/secure-obj/secure-obj-module_git.bb2
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc4
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb13
3 files changed, 11 insertions, 8 deletions
diff --git a/recipes-extended/secure-obj/secure-obj-module_git.bb b/recipes-extended/secure-obj/secure-obj-module_git.bb
index 3866dde4..1e5709b6 100644
--- a/recipes-extended/secure-obj/secure-obj-module_git.bb
+++ b/recipes-extended/secure-obj/secure-obj-module_git.bb
@@ -1,6 +1,6 @@
1require secure-obj.inc 1require secure-obj.inc
2 2
3LIC_FILES_CHKSUM = "file://../README;md5=82b72e88f23cded9dd23f0fb1790b8d2" 3LIC_FILES_CHKSUM = "file://../LICENSE;md5=751419260aa954499f7abaabaa882bbe"
4 4
5DEPENDS += "virtual/kernel" 5DEPENDS += "virtual/kernel"
6 6
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 64e4a6b7..16115ff0 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -1,5 +1,5 @@
1DESCRIPTION = "Secure Object" 1DESCRIPTION = "Secure Object"
2LICENSE = "BSD" 2LICENSE = "BSD-3-Clause"
3 3
4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" 4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq"
5RDEPENDS:${PN} = "bash libcrypto libssl" 5RDEPENDS:${PN} = "bash libcrypto libssl"
@@ -11,7 +11,7 @@ inherit python3native
11LDFLAGS += "${TOOLCHAIN_OPTIONS}" 11LDFLAGS += "${TOOLCHAIN_OPTIONS}"
12 12
13SRC_URI = "git://github.com/nxp-qoriq/secure_obj;protocol=https;nobranch=1" 13SRC_URI = "git://github.com/nxp-qoriq/secure_obj;protocol=https;nobranch=1"
14SRCREV = "5ff1231f74b4b01744be95a3137a14ad0a483e61" 14SRCREV = "4706a6534ec09f9a46bfe305c5e49badca32b4c6"
15 15
16WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 16WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
17export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" 17export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 84ecea1e..64f59f47 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -1,9 +1,11 @@
1require secure-obj.inc 1require secure-obj.inc
2 2
3LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
4 4
5S = "${WORKDIR}/git" 5S = "${WORKDIR}/git"
6 6
7DEPENDS:remove = " python3-pycryptodomex-native"
8DEPENDS:append = " python3-cryptography-native optee-os-qoriq-tadevkit"
7RDEPENDS:{PN} += "secure-obj-module" 9RDEPENDS:{PN} += "secure-obj-module"
8 10
9WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 11WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
@@ -17,14 +19,15 @@ CFLAGS += "${TOOLCHAIN_OPTIONS}"
17 19
18do_compile() { 20do_compile() {
19 unset LDFLAGS 21 unset LDFLAGS
20 export TA_DEV_KIT_DIR="${RECIPE_SYSROOT}/usr/include/optee/export-user_ta" 22 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta/
21 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" 23 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}"
22 export OPENSSL_PATH="${RECIPE_SYSROOT}/usr" 24 export OPENSSL_PATH="${RECIPE_SYSROOT}/usr"
23 for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do 25 export OPENSSL_MODULES=${STAGING_LIBDIR_NATIVE}/ossl-modules
26 for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do
24 cd ${APP} 27 cd ${APP}
25 oe_runmake 28 oe_runmake
26 cd .. 29 cd ..
27 done 30 done
28} 31}
29 32
30do_install() { 33do_install() {