summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-parser/imx-parser_4.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-parser/imx-parser_4.9.3.bb')
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.9.3.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.9.3.bb b/recipes-multimedia/imx-parser/imx-parser_4.9.3.bb
new file mode 100644
index 00000000..15df0aeb
--- /dev/null
+++ b/recipes-multimedia/imx-parser/imx-parser_4.9.3.bb
@@ -0,0 +1,46 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2012-2016 Freescale Semiconductor
3# Copyright (C) 2017-2023 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia parser libs"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb372b5d7f12181de23ef480f225f3"
9
10# For backwards compatibility
11PROVIDES += "libfslparser"
12RREPLACES:${PN} = "libfslparser"
13RPROVIDES:${PN} = "libfslparser"
14RCONFLICTS:${PN} = "libfslparser"
15
16SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true"
17IMX_SRCREV_ABBREV = "c296eb2"
18S = "${WORKDIR}/${BP}-${IMX_SRCREV_ABBREV}"
19
20SRC_URI[sha256sum] = "997a7f79f291ef4b3c8dd3ba6f2f32c430c63feb4bb29d923f71da0d1ccf20a9"
21
22inherit fsl-eula-unpack autotools pkgconfig
23
24# Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point
25EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \
26 bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d), d)}"
27
28INHIBIT_PACKAGE_STRIP = "1"
29INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
30
31python __set_insane_skip() {
32 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
33 # the source we cannot fix it. Disable the insane check for now.
34 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
35 for p in d.getVar('PACKAGES').split():
36 d.setVar("INSANE_SKIP:%s" % p, "ldflags dev-so textrel")
37}
38
39do_package_qa[prefuncs] += "__set_insane_skip"
40
41# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
42FILES:${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
43
44INHIBIT_SYSROOT_STRIP = "1"
45
46COMPATIBLE_MACHINE = "(imx-nxp-bsp)"