summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/alsa/alsa-lib_%.bbappend3
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_git.bb6
-rw-r--r--recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch37
-rw-r--r--recipes-multimedia/gstreamer/gst-examples/gst-player.desktop10
-rw-r--r--recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb38
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.7.imx.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.0.imx.bb)2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb8
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb4
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb4
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb4
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb8
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.9.3.bb (renamed from recipes-multimedia/imx-codec/imx-codec_4.9.0.bb)12
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp_2.1.10.bb (renamed from recipes-multimedia/imx-dsp/imx-dsp_2.1.9.bb)6
-rw-r--r--recipes-multimedia/imx-opencl-converter/imx-opencl-converter_0.7.0.bb (renamed from recipes-multimedia/imx-opencl-converter/imx-opencl-converter_0.6.0.bb)6
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.9.3.bb (renamed from recipes-multimedia/imx-parser/imx-parser_4.9.2.bb)6
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb10
16 files changed, 125 insertions, 39 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib_%.bbappend b/recipes-multimedia/alsa/alsa-lib_%.bbappend
index 65498aed..230cf095 100644
--- a/recipes-multimedia/alsa/alsa-lib_%.bbappend
+++ b/recipes-multimedia/alsa/alsa-lib_%.bbappend
@@ -10,6 +10,3 @@ IMX_PATCH = " \
10SRC_URI:append:imx-nxp-bsp = "${IMX_PATCH}" 10SRC_URI:append:imx-nxp-bsp = "${IMX_PATCH}"
11 11
12PACKAGE_ARCH:imx-nxp-bsp = "${MACHINE_SOCARCH}" 12PACKAGE_ARCH:imx-nxp-bsp = "${MACHINE_SOCARCH}"
13
14GLIBC_64BIT_TIME_FLAGS = ""
15INSANE_SKIP:append = " 32bit-time"
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_git.bb b/recipes-multimedia/alsa/imx-alsa-plugins_git.bb
index 7b17ccb0..7ad815b1 100644
--- a/recipes-multimedia/alsa/imx-alsa-plugins_git.bb
+++ b/recipes-multimedia/alsa/imx-alsa-plugins_git.bb
@@ -1,5 +1,5 @@
1# Copyright 2013-2016 Freescale Semiconductor 1# Copyright 2013-2016 Freescale Semiconductor
2# Copyright 2017-2023 NXP 2# Copyright 2017-2024 NXP
3# Released under the MIT license (see COPYING.MIT for the terms) 3# Released under the MIT license (see COPYING.MIT for the terms)
4 4
5DESCRIPTION = "Freescale alsa-lib plugins" 5DESCRIPTION = "Freescale alsa-lib plugins"
@@ -20,8 +20,8 @@ inherit autotools pkgconfig use-imx-headers
20PV = "1.0.26+${SRCPV}" 20PV = "1.0.26+${SRCPV}"
21 21
22SRC_URI = "git://github.com/nxp-imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}" 22SRC_URI = "git://github.com/nxp-imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}"
23SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 23SRCBRANCH = "MM_04.09.03_2412_L6.12.y"
24SRCREV = "b2ba082e70333f187972ee4e85f63f9d2f608331" 24SRCREV = "eaf0900662d6381bcc433165219280cca1752890"
25 25
26S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
27 27
diff --git a/recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch b/recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch
new file mode 100644
index 00000000..828c87dc
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch
@@ -0,0 +1,37 @@
1From 7924016fce2d0b435891a335cdae52fc939c7e3b Mon Sep 17 00:00:00 2001
2From: Jussi Kukkonen <jussi.kukkonen@intel.com>
3Date: Thu, 17 Aug 2017 11:07:02 +0300
4Subject: [PATCH] Make player examples installable
5
6Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
7Upstream-Status: Denied [Upstream considers these code examples, for now a least]
8
9https://bugzilla.gnome.org/show_bug.cgi?id=777827
10
11---
12 playback/player/gst-play/meson.build | 1 +
13 playback/player/gtk/meson.build | 1 +
14 2 files changed, 2 insertions(+)
15
16Index: gst-examples/playback/player/gst-play/meson.build
17===================================================================
18--- gst-examples.orig/playback/player/gst-play/meson.build
19+++ gst-examples/playback/player/gst-play/meson.build
20@@ -2,5 +2,6 @@ executable('gst-play',
21 ['gst-play.c',
22 'gst-play-kb.c',
23 'gst-play-kb.h'],
24+ install: true,
25 dependencies : [gst_dep, dependency('gstreamer-play-1.0'), m_dep])
26
27Index: gst-examples/playback/player/gtk/meson.build
28===================================================================
29--- gst-examples.orig/playback/player/gtk/meson.build
30+++ gst-examples/playback/player/gtk/meson.build
31@@ -20,5 +20,6 @@ if gtk_dep.found()
32 'gtk-video-renderer.h',
33 'gtk-video-renderer.c'],
34 c_args : extra_c_args,
35+ install: true,
36 dependencies : [gst_dep, gsttag_dep, gstplay_dep, gtk_dep, x11_dep])
37 endif
diff --git a/recipes-multimedia/gstreamer/gst-examples/gst-player.desktop b/recipes-multimedia/gstreamer/gst-examples/gst-player.desktop
new file mode 100644
index 00000000..d165e5d9
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-examples/gst-player.desktop
@@ -0,0 +1,10 @@
1[Desktop Entry]
2Name=Media Player
3Comment=Basic media player
4Icon=video-player
5TryExec=gtk-play
6Exec=gtk-play
7StartupNotify=true
8Terminal=false
9Type=Application
10Categories=GTK;AudioVideo;
diff --git a/recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb
new file mode 100644
index 00000000..3830846b
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb
@@ -0,0 +1,38 @@
1# This builds an older version which is compatible with the gstreamer NXP fork 1.24.7.imx,
2# thus the version is appended with '.imx'
3
4SUMMARY = "GStreamer examples (including gtk-play, gst-play)"
5DESCRIPTION = "GStreamer example applications."
6HOMEPAGE = "https://gitlab.freedesktop.org/gstreamer/gst-examples"
7BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-examples/-/issues"
8LICENSE = "LGPL-2.0-or-later"
9LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9"
10
11DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 json-glib glib-2.0-native"
12
13SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gstreamer.git;protocol=https;branch=1.24 \
14 file://0001-Make-player-examples-installable.patch \
15 file://gst-player.desktop \
16 "
17
18SRCREV = "0f1e984e41ce8d6d0758265d35e8b10d5815fde2"
19
20S = "${WORKDIR}/git/subprojects/gst-examples"
21
22inherit meson pkgconfig features_check
23
24UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
25
26ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
27
28do_install:append() {
29 install -m 0644 -D ${UNPACKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
30}
31
32RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback"
33RRECOMMENDS:${PN} = "gstreamer1.0-plugins-base-meta \
34 gstreamer1.0-plugins-good-meta \
35 gstreamer1.0-plugins-bad-meta \
36 ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "gstreamer1.0-libav", "", d)} \
37 ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
38RPROVIDES:${PN} += "gst-player gst-player-bin"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.7.imx.bb
index ab542cb5..accca06a 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.7.imx.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770 \
12 " 12 "
13 13
14SRC_URI = "https://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${@get_gst_ver('${PV}')}.tar.xz" 14SRC_URI = "https://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${@get_gst_ver('${PV}')}.tar.xz"
15SRC_URI[sha256sum] = "ab775d5b9a7c84176b29822b68c7a34731280039a20b7db5eb639eddd1466178" 15SRC_URI[sha256sum] = "c3e4179ba183c2d3101edf87ff70dd07e728c766a5fee34e6ecded76ca5802df"
16 16
17S = "${WORKDIR}/gst-libav-${@get_gst_ver('${PV}')}" 17S = "${WORKDIR}/gst-libav-${@get_gst_ver('${PV}')}"
18 18
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb
index 4b707875..7f5cd0b3 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb
@@ -187,8 +187,8 @@ SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plug
187 " 187 "
188SRC_URI:prepend = "${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} " 188SRC_URI:prepend = "${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} "
189GST1.0-PLUGINS-BAD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-bad.git;protocol=https" 189GST1.0-PLUGINS-BAD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-bad.git;protocol=https"
190SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 190SRCBRANCH = "MM_04.09.03_2412_L6.12.y"
191SRCREV = "bba296b75dfb3e7ae4c836255edbd2b3c085c269" 191SRCREV = "7bb1254fcb0a0dcb1ecb4ac21efbc5068151943d"
192 192
193S = "${WORKDIR}/git" 193S = "${WORKDIR}/git"
194 194
@@ -219,9 +219,5 @@ EXTRA_OEMESON:remove = " \
219 -Dkate=disabled \ 219 -Dkate=disabled \
220" 220"
221 221
222# it uses nested functions sadly, in ext/wayland/gstwaylandsink.c for GST_ELEMENT_REGISTER_DEFINE
223#
224TOOLCHAIN = "gcc"
225
226COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 222COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
227########### End of i.MX overrides ######### 223########### End of i.MX overrides #########
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb
index c15457ca..6859d26b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb
@@ -118,8 +118,8 @@ SRC_URI:remove = " \
118SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} " 118SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} "
119 119
120GST1.0-PLUGINS-BASE_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-base.git;protocol=https" 120GST1.0-PLUGINS-BASE_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-base.git;protocol=https"
121SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 121SRCBRANCH = "MM_04.09.03_2412_L6.12.y"
122SRCREV = "031d262e65333e58b2ce01aaf47ab1012f93b21e" 122SRCREV = "858ae5a1fb2bd2692ca7ebbd5bde2eee14e1842d"
123 123
124S = "${WORKDIR}/git" 124S = "${WORKDIR}/git"
125 125
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb
index 5dd71743..933adb5e 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb
@@ -111,8 +111,8 @@ SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plu
111 111
112SRC_URI:prepend = "${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} " 112SRC_URI:prepend = "${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} "
113GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-good.git;protocol=https" 113GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-good.git;protocol=https"
114SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 114SRCBRANCH = "MM_04.09.03_2412_L6.12.y"
115SRCREV = "33b2732b873758a302064818b35dcad41b5bbc14" 115SRCREV = "626a972e9ef448f1017cfad07a3486a0fb340a0d"
116 116
117S = "${WORKDIR}/git" 117S = "${WORKDIR}/git"
118 118
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb
index 51a12f30..8daeed66 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb
@@ -100,8 +100,8 @@ SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV
100" 100"
101SRC_URI:prepend = "${GST1.0_SRC};branch=${SRCBRANCH} " 101SRC_URI:prepend = "${GST1.0_SRC};branch=${SRCBRANCH} "
102GST1.0_SRC ?= "gitsm://github.com/nxp-imx/gstreamer.git;protocol=https" 102GST1.0_SRC ?= "gitsm://github.com/nxp-imx/gstreamer.git;protocol=https"
103SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 103SRCBRANCH = "MM_04.09.03_2412_L6.12.y"
104SRCREV = "1a8f23da16cd224574ab2386803149c76f2cb628" 104SRCREV = "e0d37a7d773a502956f54eced8cd701ec7fa5ff5"
105 105
106S = "${WORKDIR}/git" 106S = "${WORKDIR}/git"
107 107
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
index 81d9ac0b..a96b5b31 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
@@ -27,18 +27,20 @@ DEPENDS_IMXGPU:imxgpu = "${DEPENDS_IMX_OPENCL_CONVERTER}"
27DEPENDS_IMX_OPENCL_CONVERTER = "imx-opencl-converter" 27DEPENDS_IMX_OPENCL_CONVERTER = "imx-opencl-converter"
28DEPENDS_IMX_OPENCL_CONVERTER:mx6-nxp-bsp = "" 28DEPENDS_IMX_OPENCL_CONVERTER:mx6-nxp-bsp = ""
29DEPENDS_IMX_OPENCL_CONVERTER:mx7-nxp-bsp = "" 29DEPENDS_IMX_OPENCL_CONVERTER:mx7-nxp-bsp = ""
30DEPENDS_IMX_OPENCL_CONVERTER:mx8-nxp-bsp = "imx-opencl-converter"
30DEPENDS_IMX_OPENCL_CONVERTER:mx8mm-nxp-bsp = "" 31DEPENDS_IMX_OPENCL_CONVERTER:mx8mm-nxp-bsp = ""
32DEPENDS_IMX_OPENCL_CONVERTER:mx95-nxp-bsp = "imx-opencl-converter"
31 33
32# For backwards compatibility 34# For backwards compatibility
33RREPLACES:${PN} = "gst1.0-fsl-plugin" 35RREPLACES:${PN} = "gst1.0-fsl-plugin"
34RPROVIDES:${PN} = "gst1.0-fsl-plugin" 36RPROVIDES:${PN} = "gst1.0-fsl-plugin"
35RCONFLICTS:${PN} = "gst1.0-fsl-plugin" 37RCONFLICTS:${PN} = "gst1.0-fsl-plugin"
36 38
37PV = "4.9.2+git${SRCPV}" 39PV = "4.9.3+git${SRCPV}"
38 40
39SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}" 41SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}"
40SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 42SRCBRANCH = "MM_04.09.03_2412_L6.12.y"
41SRCREV = "ef9c1a080e739e6f0be878148d9f4a050dc83bec" 43SRCREV = "370510ef8137874339df18a2a35ec1d04d98fa0b"
42 44
43S = "${WORKDIR}/git" 45S = "${WORKDIR}/git"
44 46
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.9.0.bb b/recipes-multimedia/imx-codec/imx-codec_4.9.3.bb
index c2386efc..b435dacd 100644
--- a/recipes-multimedia/imx-codec/imx-codec_4.9.0.bb
+++ b/recipes-multimedia/imx-codec/imx-codec_4.9.3.bb
@@ -1,20 +1,24 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor 1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright 2017 NXP-2023 2# Copyright (C) 2017-2024 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA. 3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms) 4# Released under the MIT license (see COPYING.MIT for the terms)
5
5DESCRIPTION = "Freescale Multimedia codec libs" 6DESCRIPTION = "Freescale Multimedia codec libs"
6LICENSE = "Proprietary" 7LICENSE = "Proprietary"
7SECTION = "multimedia" 8SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=10c0fda810c63b052409b15a5445671a" 9LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb372b5d7f12181de23ef480f225f3"
9 10
10# Backward compatibility 11# Backward compatibility
11PROVIDES += "libfslcodec" 12PROVIDES += "libfslcodec"
12 13
13SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" 14SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true"
14SRC_URI[sha256sum] = "1a41a3cad9e0f4baa904fcec896105d3474e18d13f169dad1172d5691fc11c9a" 15SRC_URI[sha256sum] = "61b40623e1c2322f1ba85da57ab6949f749d02b3b5cbc2b1ef583a99b59e8968"
16IMX_SRCREV_ABBREV = "394336b"
15 17
16inherit fsl-eula-unpack autotools pkgconfig 18inherit fsl-eula-unpack autotools pkgconfig
17 19
20S = "${WORKDIR}/${BPN}-${PV}-${IMX_SRCREV_ABBREV}"
21
18PACKAGECONFIG ??= "${PACKAGECONFIG_VPU}" 22PACKAGECONFIG ??= "${PACKAGECONFIG_VPU}"
19# Support Chips&Media VPU only 23# Support Chips&Media VPU only
20PACKAGECONFIG_VPU = "" 24PACKAGECONFIG_VPU = ""
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_2.1.9.bb b/recipes-multimedia/imx-dsp/imx-dsp_2.1.10.bb
index 73321ddc..4e42110b 100644
--- a/recipes-multimedia/imx-dsp/imx-dsp_2.1.9.bb
+++ b/recipes-multimedia/imx-dsp/imx-dsp_2.1.10.bb
@@ -2,16 +2,16 @@
2 2
3DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries" 3DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" 5LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb372b5d7f12181de23ef480f225f3"
6 6
7inherit fsl-eula-unpack autotools pkgconfig 7inherit fsl-eula-unpack autotools pkgconfig
8 8
9IMX_SRCREV_ABBREV = "a3074e2" 9IMX_SRCREV_ABBREV = "ea4fe3f"
10SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true" 10SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true"
11 11
12S = "${WORKDIR}/${BP}-${IMX_SRCREV_ABBREV}" 12S = "${WORKDIR}/${BP}-${IMX_SRCREV_ABBREV}"
13 13
14SRC_URI[sha256sum] = "1f763c21f20abfbb013a0d1acb5846fec55241e9fa8c8aae47fd95b007d800fe" 14SRC_URI[sha256sum] = "fc6e6a7c2417730b39eeddc26606c3d58a8f5d0a1521f44bbbd505657046858b"
15 15
16EXTRA_OECONF = " \ 16EXTRA_OECONF = " \
17 -datadir=${base_libdir}/firmware \ 17 -datadir=${base_libdir}/firmware \
diff --git a/recipes-multimedia/imx-opencl-converter/imx-opencl-converter_0.6.0.bb b/recipes-multimedia/imx-opencl-converter/imx-opencl-converter_0.7.0.bb
index 7f0c2256..07ea662c 100644
--- a/recipes-multimedia/imx-opencl-converter/imx-opencl-converter_0.6.0.bb
+++ b/recipes-multimedia/imx-opencl-converter/imx-opencl-converter_0.7.0.bb
@@ -2,13 +2,13 @@
2DESCRIPTION = "NXP Multimedia opencl converter lib" 2DESCRIPTION = "NXP Multimedia opencl converter lib"
3LICENSE = "Proprietary" 3LICENSE = "Proprietary"
4SECTION = "multimedia" 4SECTION = "multimedia"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" 5LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb372b5d7f12181de23ef480f225f3"
6DEPENDS = "virtual/opencl-icd" 6DEPENDS = "virtual/opencl-icd"
7 7
8SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true" 8SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true"
9IMX_SRCREV_ABBREV = "605ef75" 9IMX_SRCREV_ABBREV = "ad0094a"
10 10
11SRC_URI[sha256sum] = "777f49805d5455ebc27e63d19552e2924174011d2ae7d9b392febfa8794d4dc6" 11SRC_URI[sha256sum] = "d23ad4234f34ffcfb37d77c91345b935894937913a68995223d2f9f421eade46"
12 12
13S = "${WORKDIR}/${BP}-${IMX_SRCREV_ABBREV}" 13S = "${WORKDIR}/${BP}-${IMX_SRCREV_ABBREV}"
14inherit fsl-eula-unpack autotools pkgconfig meson 14inherit fsl-eula-unpack autotools pkgconfig meson
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.9.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.9.3.bb
index 78b48da0..15df0aeb 100644
--- a/recipes-multimedia/imx-parser/imx-parser_4.9.2.bb
+++ b/recipes-multimedia/imx-parser/imx-parser_4.9.3.bb
@@ -5,7 +5,7 @@
5DESCRIPTION = "Freescale Multimedia parser libs" 5DESCRIPTION = "Freescale Multimedia parser libs"
6LICENSE = "Proprietary" 6LICENSE = "Proprietary"
7SECTION = "multimedia" 7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" 8LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb372b5d7f12181de23ef480f225f3"
9 9
10# For backwards compatibility 10# For backwards compatibility
11PROVIDES += "libfslparser" 11PROVIDES += "libfslparser"
@@ -14,10 +14,10 @@ RPROVIDES:${PN} = "libfslparser"
14RCONFLICTS:${PN} = "libfslparser" 14RCONFLICTS:${PN} = "libfslparser"
15 15
16SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true" 16SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true"
17IMX_SRCREV_ABBREV = "828fcb7" 17IMX_SRCREV_ABBREV = "c296eb2"
18S = "${WORKDIR}/${BP}-${IMX_SRCREV_ABBREV}" 18S = "${WORKDIR}/${BP}-${IMX_SRCREV_ABBREV}"
19 19
20SRC_URI[sha256sum] = "7414db9e2cce2cb2d6fe63ac7d193a0ea65ad8a184e6a2e2ce2785e43acbb339" 20SRC_URI[sha256sum] = "997a7f79f291ef4b3c8dd3ba6f2f32c430c63feb4bb29d923f71da0d1ccf20a9"
21 21
22inherit fsl-eula-unpack autotools pkgconfig 22inherit fsl-eula-unpack autotools pkgconfig
23 23
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
index de9b0daf..98e9ea4d 100644
--- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
@@ -1,11 +1,11 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor 1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2017-2023 NXP 2# Copyright (C) 2017-2023 NXP
3# Released under the MIT license (see COPYING.MIT for the terms) 3# Released under the MIT license (see COPYING.MIT for the terms)
4 4
5DESCRIPTION = "Freescale Multimedia VPU wrapper" 5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6LICENSE = "Proprietary" 6LICENSE = "Proprietary"
7SECTION = "multimedia" 7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" 8LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb372b5d7f12181de23ef480f225f3"
9 9
10DEPENDS = "virtual/imxvpu" 10DEPENDS = "virtual/imxvpu"
11DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc" 11DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
@@ -14,13 +14,15 @@ SRC_URI = " \
14 git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \ 14 git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \
15 file://0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch \ 15 file://0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch \
16" 16"
17SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 17SRCBRANCH = "MM_04.09.03_2412_L6.12.y"
18SRCREV = "378e33989cf72d6c2eb57a585072ba9abe87c6ff" 18SRCREV = "d8703ee3245797111ad21c52982efa8b6db33241"
19 19
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21 21
22inherit autotools pkgconfig 22inherit autotools pkgconfig
23 23
24CFLAGS += " -Wno-error=implicit-function-declaration"
25
24do_install:append() { 26do_install:append() {
25 # FIXME: Drop examples for now 27 # FIXME: Drop examples for now
26 rm -r ${D}${datadir} 28 rm -r ${D}${datadir}