summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2024-11-26 14:54:38 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2024-11-27 15:28:02 +0800
commit7092e592319d9f05293ea8d6f3b0fcf0407425e7 (patch)
treedc144afb11112db48b4d20d1d3db4109ea73b2ea
parent31ebf1b3469dd2cf2d45fc8f9eea5e0c449a0b09 (diff)
downloadmeta-intel-7092e592319d9f05293ea8d6f3b0fcf0407425e7.tar.gz
intel-media-driver: upgrade 24.3.2 -> 24.4.1
Add bug fixed: - 0001-Add-Y210-caps-for-BMG-HEVC-encode.patch - 0001-Change-RGB-mask-and-order.patch - 0001-Change-RGB-mask-and-order-for-BMG.patch Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-multimedia/libva/files/0001-Add-Y210-caps-for-BMG-HEVC-encode.patch26
-rw-r--r--recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch45
-rw-r--r--recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order.patch126
-rw-r--r--recipes-multimedia/libva/intel-media-driver_24.4.1.bb (renamed from recipes-multimedia/libva/intel-media-driver_24.3.2.bb)5
4 files changed, 201 insertions, 1 deletions
diff --git a/recipes-multimedia/libva/files/0001-Add-Y210-caps-for-BMG-HEVC-encode.patch b/recipes-multimedia/libva/files/0001-Add-Y210-caps-for-BMG-HEVC-encode.patch
new file mode 100644
index 00000000..2fd74390
--- /dev/null
+++ b/recipes-multimedia/libva/files/0001-Add-Y210-caps-for-BMG-HEVC-encode.patch
@@ -0,0 +1,26 @@
1From 273986f0944cd8e42c676e10700015c093e1c102 Mon Sep 17 00:00:00 2001
2From: "Hoe, Sheng Yang" <sheng.yang.hoe@intel.com>
3Date: Mon, 4 Nov 2024 08:53:46 +0000
4Subject: [PATCH] Add Y210 caps for BMG HEVC encode
5
6Upstream-Status: Backport [https://github.com/intel/media-driver/commit/e66314103cfec73d0bd4b8f687973d094e129838]
7Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com>
8---
9 .../hevc/ddi/capstable_data_hevc_encode_xe2_hpm_r0_specific.h | 1 +
10 1 file changed, 1 insertion(+)
11
12diff --git a/media_softlet/linux/xe2_hpm_r0/encode/hevc/ddi/capstable_data_hevc_encode_xe2_hpm_r0_specific.h b/media_softlet/linux/xe2_hpm_r0/encode/hevc/ddi/capstable_data_hevc_encode_xe2_hpm_r0_specific.h
13index bfcba8277..4c4464917 100644
14--- a/media_softlet/linux/xe2_hpm_r0/encode/hevc/ddi/capstable_data_hevc_encode_xe2_hpm_r0_specific.h
15+++ b/media_softlet/linux/xe2_hpm_r0/encode/hevc/ddi/capstable_data_hevc_encode_xe2_hpm_r0_specific.h
16@@ -486,6 +486,7 @@ static const ProfileSurfaceAttribInfo surfaceAttribInfo_VAProfileHEVCMain10_VAEn
17 static const ProfileSurfaceAttribInfo surfaceAttribInfo_VAProfileHEVCMain422_10_VAEntrypointEncSlice_Xe2_Hpm_r0 =
18 {
19 {VASurfaceAttribPixelFormat, VA_SURFACE_ATTRIB_GETTABLE | VA_SURFACE_ATTRIB_SETTABLE, {VAGenericValueTypeInteger, {VA_FOURCC_YUY2}}},
20+ {VASurfaceAttribPixelFormat, VA_SURFACE_ATTRIB_GETTABLE | VA_SURFACE_ATTRIB_SETTABLE, {VAGenericValueTypeInteger, {VA_FOURCC_Y210}}},
21 {VASurfaceAttribMaxWidth, VA_SURFACE_ATTRIB_GETTABLE, {VAGenericValueTypeInteger, {CODEC_16K_MAX_PIC_WIDTH}}},
22 {VASurfaceAttribMaxHeight, VA_SURFACE_ATTRIB_GETTABLE, {VAGenericValueTypeInteger, {CODEC_12K_MAX_PIC_HEIGHT}}},
23 {VASurfaceAttribMinWidth, VA_SURFACE_ATTRIB_GETTABLE, {VAGenericValueTypeInteger, {CODEC_128_MIN_PIC_WIDTH}}},
24--
252.43.2
26
diff --git a/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch b/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch
new file mode 100644
index 00000000..0b3277b0
--- /dev/null
+++ b/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch
@@ -0,0 +1,45 @@
1From 8e7b263729bec520cf830cbf85216c2d6466421d Mon Sep 17 00:00:00 2001
2From: "Hoe, Sheng Yang" <sheng.yang.hoe@intel.com>
3Date: Fri, 22 Nov 2024 10:11:14 +0000
4Subject: [PATCH] Change RGB mask and order for BMG
5
6Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1884]
7
8Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com>
9---
10 .../ddi/capstable_data_image_format_definition.h | 11 ++++++-----
11 1 file changed, 6 insertions(+), 5 deletions(-)
12
13diff --git a/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h b/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h
14index af28653a5..ec99164ce 100644
15--- a/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h
16+++ b/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h
17@@ -29,13 +29,14 @@
18
19 #include "va/va.h"
20
21-static VAImageFormat formatBGRA = {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x0000ff00, 0x00ff0000, 0xff000000, 0x000000ff }; /* [31:0] B:G:R:A 8:8:8:8 little endian */
22+// "VA_LSB_FIRST" is to identify how following bit masks mapped to address instead of char order in VA_FOURCC_RGBA naming.
23+static VAImageFormat formatBGRA = {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000}; /* [31:0] A:R:G:B 8:8:8:8 little endian */
24 static VAImageFormat formatARGB = {VA_FOURCC_ARGB, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000 }; /* [31:0] A:R:G:B 8:8:8:8 little endian */
25-static VAImageFormat formatRGBA = {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0xff000000, 0x00ff0000, 0x0000ff00, 0x000000ff }; /* [31:0] R:G:B:A 8:8:8:8 little endian */
26+static VAImageFormat formatRGBA = {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000}; /* [31:0] A:B:G:R 8:8:8:8 little endian */
27 static VAImageFormat formatABGR = {VA_FOURCC_ABGR, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000 }; /* [31:0] A:B:G:R 8:8:8:8 little endian */
28-static VAImageFormat formatBGRX = {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x0000ff00, 0x00ff0000, 0xff000000, 0 }; /* [31:0] B:G:R:x 8:8:8:8 little endian */
29+static VAImageFormat formatBGRX = {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0}; /* [31:0] X:R:G:B 8:8:8:8 little endian */
30 static VAImageFormat formatXRGB = {VA_FOURCC_XRGB, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0 }; /* [31:0] x:R:G:B 8:8:8:8 little endian */
31-static VAImageFormat formatRGBX = {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0xff000000, 0x00ff0000, 0x0000ff00, 0 }; /* [31:0] R:G:B:x 8:8:8:8 little endian */
32+static VAImageFormat formatRGBX = {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0}; /* [31:0] X:B:G:R 8:8:8:8 little endian */
33 static VAImageFormat formatXBGR = {VA_FOURCC_XBGR, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0 }; /* [31:0] x:B:G:R 8:8:8:8 little endian */
34 static VAImageFormat formatA2R10G10B10 = {VA_FOURCC_A2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0x30000000 }; /* [31:0] A:R:G:B 2:10:10:10 little endian */
35 static VAImageFormat formatA2B10G10R10 = {VA_FOURCC_A2B10G10R10, VA_LSB_FIRST, 32, 30, 0x000003ff, 0x000ffc00, 0x3ff00000, 0x30000000 }; /* [31:0] A:B:G:R 2:10:10:10 little endian */
36@@ -70,4 +71,4 @@ static VAImageFormat formatY416 = {VA_FOURCC_Y416, VA_LSB_FIRST,
37 static VAImageFormat formatRGBP = {VA_FOURCC_RGBP, VA_LSB_FIRST, 24, 24,0,0,0,0};
38 static VAImageFormat formatBGRP = {VA_FOURCC_BGRP, VA_LSB_FIRST, 24, 24,0,0,0,0};
39
40-#endif //__CAPSTABLE_DATA_IMAGE_FORMAT_DEFINITION_H__
41\ No newline at end of file
42+#endif //__CAPSTABLE_DATA_IMAGE_FORMAT_DEFINITION_H__
43--
442.34.1
45
diff --git a/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order.patch b/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order.patch
new file mode 100644
index 00000000..08d15529
--- /dev/null
+++ b/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order.patch
@@ -0,0 +1,126 @@
1From 3e4c7a15148178e670c46bcccd89e48c4c10f370 Mon Sep 17 00:00:00 2001
2From: WenshengZhang <wensheng.zhang@intel.com>
3Date: Tue, 22 Oct 2024 14:49:11 +0800
4Subject: [PATCH] Change RGB mask and order
5
6Change RGB mask and order.
7
8Upstream-Status: Backport [https://github.com/intel/media-driver/commit/8c7b05bf8a81961c1f111b75cae99818a8bd8aa9]
9Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
10
11---
12 media_driver/linux/gen11/ddi/media_libva_caps_g11.cpp | 10 ++++++----
13 media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp | 10 ++++++----
14 media_driver/linux/gen8/ddi/media_libva_caps_g8.cpp | 10 ++++++----
15 media_driver/linux/gen9/ddi/media_libva_caps_g9.cpp | 10 ++++++----
16 .../linux/Xe_M_plus/ddi/media_libva_caps_mtl_base.cpp | 10 ++++++----
17 5 files changed, 30 insertions(+), 20 deletions(-)
18
19diff --git a/media_driver/linux/gen11/ddi/media_libva_caps_g11.cpp b/media_driver/linux/gen11/ddi/media_libva_caps_g11.cpp
20index 49d252a6b..a04a73a6d 100755
21--- a/media_driver/linux/gen11/ddi/media_libva_caps_g11.cpp
22+++ b/media_driver/linux/gen11/ddi/media_libva_caps_g11.cpp
23@@ -36,10 +36,12 @@
24 #include "media_libva_vp.h"
25
26 const VAImageFormat m_supportedImageformatsG11[] =
27-{ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x0000ff00, 0x00ff0000, 0xff000000, 0x000000ff}, /* [31:0] B:G:R:A 8:8:8:8 little endian */
28- {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0xff000000, 0x00ff0000, 0x0000ff00, 0x000000ff}, /* [31:0] R:G:B:A 8:8:8:8 little endian */
29- {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x0000ff00, 0x00ff0000, 0xff000000, 0}, /* [31:0] B:G:R:x 8:8:8:8 little endian */
30- {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0xff000000, 0x00ff0000, 0x0000ff00, 0}, /* [31:0] R:G:B:x 8:8:8:8 little endian */
31+{
32+ // "VA_LSB_FIRST" is to identify how following bit masks mapped to address instead of char order in VA_FOURCC_RGBA naming.
33+ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000}, /* [31:0] A:R:G:B 8:8:8:8 little endian */
34+ {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000}, /* [31:0] A:B:G:R 8:8:8:8 little endian */
35+ {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0}, /* [31:0] X:R:G:B 8:8:8:8 little endian */
36+ {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0}, /* [31:0] X:B:G:R 8:8:8:8 little endian */
37 {VA_FOURCC_A2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0x30000000}, /* [31:0] A:R:G:B 2:10:10:10 little endian */
38 {VA_FOURCC_A2B10G10R10, VA_LSB_FIRST, 32, 30, 0x000003ff, 0x000ffc00, 0x3ff00000, 0x30000000}, /* [31:0] A:B:G:R 2:10:10:10 little endian */
39 {VA_FOURCC_X2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0}, /* [31:0] X:R:G:B 2:10:10:10 little endian */
40diff --git a/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp b/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp
41index 39b069c78..870e8dcc8 100644
42--- a/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp
43+++ b/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp
44@@ -48,10 +48,12 @@
45 #endif
46
47 const VAImageFormat m_supportedImageformatsG12[] =
48-{ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x0000ff00, 0x00ff0000, 0xff000000, 0x000000ff}, /* [31:0] B:G:R:A 8:8:8:8 little endian */
49- {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0xff000000, 0x00ff0000, 0x0000ff00, 0x000000ff}, /* [31:0] R:G:B:A 8:8:8:8 little endian */
50- {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x0000ff00, 0x00ff0000, 0xff000000, 0}, /* [31:0] B:G:R:x 8:8:8:8 little endian */
51- {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0xff000000, 0x00ff0000, 0x0000ff00, 0}, /* [31:0] R:G:B:x 8:8:8:8 little endian */
52+{
53+ // "VA_LSB_FIRST" is to identify how following bit masks mapped to address instead of char order in VA_FOURCC_RGBA naming.
54+ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000}, /* [31:0] A:R:G:B 8:8:8:8 little endian */
55+ {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000}, /* [31:0] A:B:G:R 8:8:8:8 little endian */
56+ {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0}, /* [31:0] X:R:G:B 8:8:8:8 little endian */
57+ {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0}, /* [31:0] X:B:G:R 8:8:8:8 little endian */
58 {VA_FOURCC_A2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0x30000000}, /* [31:0] A:R:G:B 2:10:10:10 little endian */
59 {VA_FOURCC_A2B10G10R10, VA_LSB_FIRST, 32, 30, 0x000003ff, 0x000ffc00, 0x3ff00000, 0x30000000}, /* [31:0] A:B:G:R 2:10:10:10 little endian */
60 {VA_FOURCC_X2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0}, /* [31:0] X:R:G:B 2:10:10:10 little endian */
61diff --git a/media_driver/linux/gen8/ddi/media_libva_caps_g8.cpp b/media_driver/linux/gen8/ddi/media_libva_caps_g8.cpp
62index 3ec2e1e39..b31315cf4 100644
63--- a/media_driver/linux/gen8/ddi/media_libva_caps_g8.cpp
64+++ b/media_driver/linux/gen8/ddi/media_libva_caps_g8.cpp
65@@ -31,10 +31,12 @@
66 #include "media_libva_caps_factory.h"
67
68 const VAImageFormat m_supportedImageformatsG8[] =
69-{ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000},
70- {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000},
71- {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0},
72- {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0},
73+{
74+ // "VA_LSB_FIRST" is to identify how following bit masks mapped to address instead of char order in VA_FOURCC_RGBA naming.
75+ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000}, /* [31:0] A:R:G:B 8:8:8:8 little endian */
76+ {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000}, /* [31:0] A:B:G:R 8:8:8:8 little endian */
77+ {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0}, /* [31:0] X:R:G:B 8:8:8:8 little endian */
78+ {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0}, /* [31:0] X:B:G:R 8:8:8:8 little endian */
79 {VA_FOURCC_RGB565, VA_LSB_FIRST, 16, 16, 0xf800, 0x07e0, 0x001f, 0},
80 {VA_FOURCC_NV12, VA_LSB_FIRST, 12, 0,0,0,0,0},
81 {VA_FOURCC_NV21, VA_LSB_FIRST, 12, 0,0,0,0,0},
82diff --git a/media_driver/linux/gen9/ddi/media_libva_caps_g9.cpp b/media_driver/linux/gen9/ddi/media_libva_caps_g9.cpp
83index cdf891a26..4c2f82041 100755
84--- a/media_driver/linux/gen9/ddi/media_libva_caps_g9.cpp
85+++ b/media_driver/linux/gen9/ddi/media_libva_caps_g9.cpp
86@@ -32,10 +32,12 @@
87 #include "media_libva_caps_factory.h"
88
89 const VAImageFormat m_supportedImageformatsG9[] =
90-{ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x0000ff00, 0x00ff0000, 0xff000000, 0x000000ff}, /* [31:0] B:G:R:A 8:8:8:8 little endian */
91- {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0xff000000, 0x00ff0000, 0x0000ff00, 0x000000ff}, /* [31:0] R:G:B:A 8:8:8:8 little endian */
92- {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x0000ff00, 0x00ff0000, 0xff000000, 0}, /* [31:0] B:G:R:x 8:8:8:8 little endian */
93- {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0xff000000, 0x00ff0000, 0x0000ff00, 0}, /* [31:0] R:G:B:x 8:8:8:8 little endian */
94+{
95+ // "VA_LSB_FIRST" is to identify how following bit masks mapped to address instead of char order in VA_FOURCC_RGBA naming.
96+ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000}, /* [31:0] A:R:G:B 8:8:8:8 little endian */
97+ {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000}, /* [31:0] A:B:G:R 8:8:8:8 little endian */
98+ {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0}, /* [31:0] X:R:G:B 8:8:8:8 little endian */
99+ {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0}, /* [31:0] X:B:G:R 8:8:8:8 little endian */
100 {VA_FOURCC_A2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0x30000000}, /* [31:0] A:R:G:B 2:10:10:10 little endian */
101 {VA_FOURCC_A2B10G10R10, VA_LSB_FIRST, 32, 30, 0x000003ff, 0x000ffc00, 0x3ff00000, 0x30000000}, /* [31:0] A:B:G:R 2:10:10:10 little endian */
102 {VA_FOURCC_X2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0}, /* [31:0] X:R:G:B 2:10:10:10 little endian */
103diff --git a/media_softlet/linux/Xe_M_plus/ddi/media_libva_caps_mtl_base.cpp b/media_softlet/linux/Xe_M_plus/ddi/media_libva_caps_mtl_base.cpp
104index d985fccba..ac9bb5c62 100644
105--- a/media_softlet/linux/Xe_M_plus/ddi/media_libva_caps_mtl_base.cpp
106+++ b/media_softlet/linux/Xe_M_plus/ddi/media_libva_caps_mtl_base.cpp
107@@ -39,10 +39,12 @@
108 #include "drm_fourcc.h"
109
110 const VAImageFormat m_supportedImageformatsXe_Lpm_Plus_Base[] =
111-{ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x0000ff00, 0x00ff0000, 0xff000000, 0x000000ff}, /* [31:0] B:G:R:A 8:8:8:8 little endian */
112- {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0xff000000, 0x00ff0000, 0x0000ff00, 0x000000ff}, /* [31:0] R:G:B:A 8:8:8:8 little endian */
113- {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x0000ff00, 0x00ff0000, 0xff000000, 0}, /* [31:0] B:G:R:x 8:8:8:8 little endian */
114- {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0xff000000, 0x00ff0000, 0x0000ff00, 0}, /* [31:0] R:G:B:x 8:8:8:8 little endian */
115+{
116+ // "VA_LSB_FIRST" is to identify how following bit masks mapped to address instead of char order in VA_FOURCC_RGBA naming.
117+ {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000}, /* [31:0] A:R:G:B 8:8:8:8 little endian */
118+ {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000}, /* [31:0] A:B:G:R 8:8:8:8 little endian */
119+ {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0}, /* [31:0] X:R:G:B 8:8:8:8 little endian */
120+ {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0}, /* [31:0] X:B:G:R 8:8:8:8 little endian */
121 {VA_FOURCC_A2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0x30000000}, /* [31:0] A:R:G:B 2:10:10:10 little endian */
122 {VA_FOURCC_A2B10G10R10, VA_LSB_FIRST, 32, 30, 0x000003ff, 0x000ffc00, 0x3ff00000, 0x30000000}, /* [31:0] A:B:G:R 2:10:10:10 little endian */
123 {VA_FOURCC_X2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0}, /* [31:0] X:R:G:B 2:10:10:10 little endian */
124--
1252.43.2
126
diff --git a/recipes-multimedia/libva/intel-media-driver_24.3.2.bb b/recipes-multimedia/libva/intel-media-driver_24.4.1.bb
index eaadcd59..4c1fd02c 100644
--- a/recipes-multimedia/libva/intel-media-driver_24.3.2.bb
+++ b/recipes-multimedia/libva/intel-media-driver_24.4.1.bb
@@ -21,9 +21,12 @@ DEPENDS += "libva gmmlib"
21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \ 21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \
22 file://0001-Force-ARGB-surface-to-tile4-for-ACM.patch \ 22 file://0001-Force-ARGB-surface-to-tile4-for-ACM.patch \
23 file://0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch \ 23 file://0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch \
24 file://0001-Change-RGB-mask-and-order.patch \
25 file://0001-Add-Y210-caps-for-BMG-HEVC-encode.patch \
26 file://0001-Change-RGB-mask-and-order-for-BMG.patch \
24 " 27 "
25 28
26SRCREV = "f40b45dd7355f5f739c75bfd793fa2f1ead30f02" 29SRCREV = "105a308ea3d86596f9b90853f9d4fc83671e8a5e"
27S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"
28 31
29COMPATIBLE_HOST:x86-x32 = "null" 32COMPATIBLE_HOST:x86-x32 = "null"