diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2025-01-14 10:34:38 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2025-01-15 09:51:32 +0800 |
commit | c7c7dface32f187bb0ba724b8eb79152f7453f0c (patch) | |
tree | 04986204d0d15953e71fce3ff6a7467122e22e52 | |
parent | c4cd14c32faeff945515418434a4d7206b870ba2 (diff) | |
download | meta-intel-c7c7dface32f187bb0ba724b8eb79152f7453f0c.tar.gz |
intel-compute-runtime : upgrade 24.26.30049.6 -> 24.39.31294.12
Refresh patch 0002-Build-not-able-to-locate-cpp_generation_tool.patch
Release Notes:
https://github.com/intel/compute-runtime/releases/tag/24.39.31294.12
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0002-Build-not-able-to-locate-cpp_generation_tool.patch | 26 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.26.30049.6.bb) | 4 |
2 files changed, 10 insertions, 20 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0002-Build-not-able-to-locate-cpp_generation_tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0002-Build-not-able-to-locate-cpp_generation_tool.patch index 1ac21766..45288ce1 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0002-Build-not-able-to-locate-cpp_generation_tool.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0002-Build-not-able-to-locate-cpp_generation_tool.patch | |||
@@ -11,12 +11,12 @@ Signed-off-by: Dongwon Kim <dongwon.kim@intel.com> | |||
11 | shared/source/built_ins/kernels/CMakeLists.txt | 10 +++++----- | 11 | shared/source/built_ins/kernels/CMakeLists.txt | 10 +++++----- |
12 | 1 file changed, 5 insertions(+), 5 deletions(-) | 12 | 1 file changed, 5 insertions(+), 5 deletions(-) |
13 | 13 | ||
14 | diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt | 14 | Index: git/shared/source/built_ins/kernels/CMakeLists.txt |
15 | index ed85a37c52..f7c9e79137 100644 | 15 | =================================================================== |
16 | --- a/shared/source/built_ins/kernels/CMakeLists.txt | 16 | --- git.orig/shared/source/built_ins/kernels/CMakeLists.txt |
17 | +++ b/shared/source/built_ins/kernels/CMakeLists.txt | 17 | +++ git/shared/source/built_ins/kernels/CMakeLists.txt |
18 | @@ -107,9 +107,9 @@ function(compile_builtin core_type platform_it builtin bits builtin_options mode | 18 | @@ -122,9 +122,9 @@ function(compile_builtin core_type platf |
19 | ) | 19 | endif() |
20 | add_custom_command( | 20 | add_custom_command( |
21 | OUTPUT ${OUTPUT_FILE_CPP} | 21 | OUTPUT ${OUTPUT_FILE_CPP} |
22 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --device ${RELEASE_FILENAME} | 22 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${BINARY_OUTPUT}.bin --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --device ${RELEASE_FILENAME} |
@@ -27,8 +27,8 @@ index ed85a37c52..f7c9e79137 100644 | |||
27 | ) | 27 | ) |
28 | list(APPEND BUILTINS_COMMANDS "${OUTPUT_FILE_CPP}") | 28 | list(APPEND BUILTINS_COMMANDS "${OUTPUT_FILE_CPP}") |
29 | else() | 29 | else() |
30 | @@ -159,9 +159,9 @@ function(generate_cpp_spirv builtin) | 30 | @@ -176,9 +176,9 @@ function(generate_cpp_spirv builtin) |
31 | ) | 31 | endif() |
32 | add_custom_command( | 32 | add_custom_command( |
33 | OUTPUT ${OUTPUT_FILE_CPP} | 33 | OUTPUT ${OUTPUT_FILE_CPP} |
34 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${GENERATED_SPV_INPUT} --output ${OUTPUT_FILE_CPP} --array ${BASENAME} | 34 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${GENERATED_SPV_INPUT} --output ${OUTPUT_FILE_CPP} --array ${BASENAME} |
@@ -39,13 +39,3 @@ index ed85a37c52..f7c9e79137 100644 | |||
39 | ) | 39 | ) |
40 | set(OUTPUT_LIST_CPP_FILES ${OUTPUT_LIST_CPP_FILES} ${OUTPUT_FILE_CPP} PARENT_SCOPE) | 40 | set(OUTPUT_LIST_CPP_FILES ${OUTPUT_LIST_CPP_FILES} ${OUTPUT_FILE_CPP} PARENT_SCOPE) |
41 | else() | 41 | else() |
42 | @@ -277,4 +277,4 @@ if(NOT "${OUTPUT_LIST_CPP_FILES}" STREQUAL "") | ||
43 | ) | ||
44 | endif() | ||
45 | |||
46 | -apply_macro_for_each_core_type("SUPPORTED") | ||
47 | \ No newline at end of file | ||
48 | +apply_macro_for_each_core_type("SUPPORTED") | ||
49 | -- | ||
50 | 2.34.1 | ||
51 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.26.30049.6.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb index 688ee029..1d3c4951 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.26.30049.6.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb | |||
@@ -8,13 +8,13 @@ LICENSE = "MIT & Apache-2.0" | |||
8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ | 8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ |
9 | file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 9 | file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/24.26 \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/24.39 \ |
12 | file://0001-intel-compute-runtime-fix-build-with-gcc13.patch \ | 12 | file://0001-intel-compute-runtime-fix-build-with-gcc13.patch \ |
13 | file://0002-Build-not-able-to-locate-cpp_generation_tool.patch \ | 13 | file://0002-Build-not-able-to-locate-cpp_generation_tool.patch \ |
14 | file://0003-external-ocloc.patch \ | 14 | file://0003-external-ocloc.patch \ |
15 | " | 15 | " |
16 | 16 | ||
17 | SRCREV = "e16f47e375e4324dae07aadbfe953002a1c45195" | 17 | SRCREV = "625e7e0d87e3df7a0eb5dae88452092366c8f85b" |
18 | 18 | ||
19 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
20 | 20 | ||