summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-21 16:23:03 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-25 16:55:03 -0200
commit58c5f41799bec30a5576137d5477e8ba14a0a802 (patch)
tree86d60d7698625cada9aa5c55f70307864d38a3b8 /recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch
parent7b66216905c9420032e8a7b97e6a4466f6ec6118 (diff)
downloadmeta-java-58c5f41799bec30a5576137d5477e8ba14a0a802.tar.gz
openjdk-6: Remove currency data generation expiration date
As the openjdk source was extracted during 'make patch-ecj' in do_configure, apply the patch via do_configure_append. icedtea6-1.13.4/Makefile.am:1200:stamps/extract-openjdk.stamp: stamps/download.stamp | if OPENJDK_SRC_DIR_FOUND | if ! test -d openjdk ; then \ | cp -pPR $(OPENJDK_SRC_DIR_LINK) $(OPENJDK_SRC_DIR) openjdk ; \ | fi | else | if USE_HG | if ! test -d openjdk ; then \ | cp -pPRl openjdk.hg openjdk ; \ | fi | else | set -e ; \ | if ! test -d openjdk ; \ | then \ | mkdir openjdk ; \ | $(TAR) xf $(OPENJDK_SRC_ZIP) -C openjdk; \ | chmod -R ug+w openjdk ; \ | sh $(abs_top_srcdir)/fsg.sh ; \ | fi | endif | endif Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch')
-rw-r--r--recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch b/recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch
new file mode 100644
index 0000000..6dd36af
--- /dev/null
+++ b/recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch
@@ -0,0 +1,25 @@
1From 7df2fd1014a0c31f518be4f6a0018533f469d584 Mon Sep 17 00:00:00 2001
2From: Alex Gonzalez <alex.gonzalez@digi.com>
3Date: Wed, 31 Dec 2014 16:07:32 +0100
4Subject: [PATCH] icedtea: openjdk: remove currency data generation expiration
5 date
6
7Signed-off-by: Alex Gonzalez <alex.gonzalez@digi.com>
8---
9 .../src/build/tools/generatecurrencydata/GenerateCurrencyData.java | 3 ---
10 1 file changed, 3 deletions(-)
11
12diff --git openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
13index bf335fa22c1d..0e421360fef9 100644
14--- openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
15+++ openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
16@@ -281,9 +281,6 @@ public class GenerateCurrencyData {
17 checkCurrencyCode(newCurrency);
18 String timeString = currencyInfo.substring(4, length - 4);
19 long time = format.parse(timeString).getTime();
20- if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) {
21- throw new RuntimeException("time is more than 10 years from present: " + time);
22- }
23 specialCaseCutOverTimes[specialCaseCount] = time;
24 specialCaseOldCurrencies[specialCaseCount] = oldCurrency;
25 specialCaseOldCurrenciesDefaultFractionDigits[specialCaseCount] = getDefaultFractionDigits(oldCurrency);