diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2017-05-21 16:25:53 -0700 |
---|---|---|
committer | Maxin B. John <maxin.john@intel.com> | 2017-05-29 13:47:18 +0300 |
commit | 27c6cf23cd9db1eae2e5068b6cacdeff47ce3e30 (patch) | |
tree | 9d5ab8a6d6fd748bcdca805517dc9f4b3872a261 /recipes-core/xml-commons | |
parent | c45ed0f8ddf613ce7f1ad9e5c80b8b2db3df4912 (diff) | |
download | meta-java-27c6cf23cd9db1eae2e5068b6cacdeff47ce3e30.tar.gz |
jaxen: unblacklist and update to v1.1.6
- Add SUMMARY and expand DESCRIPTION
- Upstream moved to github, use git not ephemeral archive tarball
- Fix path for 'find org ...'
- Move SRC_URI checksums to recommended location in recipe
- Add virtual/javac-native to DEPENDS for RSS
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/xml-commons')
-rw-r--r-- | recipes-core/xml-commons/jaxen_1.1.1.bb | 35 | ||||
-rw-r--r-- | recipes-core/xml-commons/jaxen_1.1.6.bb | 40 |
2 files changed, 40 insertions, 35 deletions
diff --git a/recipes-core/xml-commons/jaxen_1.1.1.bb b/recipes-core/xml-commons/jaxen_1.1.1.bb deleted file mode 100644 index 4853683..0000000 --- a/recipes-core/xml-commons/jaxen_1.1.1.bb +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | DESCRIPTION = "XPath library written in Java" | ||
2 | LICENSE = "BSD" | ||
3 | |||
4 | HOMEPAGE = "http://jaxen.codehaus.org/" | ||
5 | |||
6 | DEPENDS = "fastjar-native xerces-j xom" | ||
7 | |||
8 | SRC_URI = "\ | ||
9 | http://dist.codehaus.org/jaxen/distributions/jaxen-${PV}-src.tar.gz;name=archive \ | ||
10 | http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \ | ||
11 | " | ||
12 | |||
13 | PNBLACKLIST[jaxen] ?= "BROKEN: depends on broken 'xom'" | ||
14 | |||
15 | inherit java-library | ||
16 | |||
17 | do_compile() { | ||
18 | mkdir -p build | ||
19 | |||
20 | oe_makeclasspath cp -s xercesImpl xom | ||
21 | scp="src/java/main:${WORKDIR}/jdom-1.1/src/java" | ||
22 | |||
23 | javac -sourcepath $scp -cp $cp -d build `find src/java/main -name "*.java" -and -not -wholename "*dom4j*"` | ||
24 | (cd src && find org -name "*.properties" -exec cp {} ../build/{} \;) | ||
25 | |||
26 | rm -rf build/org/jdom | ||
27 | |||
28 | fastjar -C build -c -f ${JARFILENAME} . | ||
29 | } | ||
30 | |||
31 | |||
32 | SRC_URI[archive.md5sum] = "b598ae6b7e765a92e13667b0a80392f4" | ||
33 | SRC_URI[archive.sha256sum] = "f24ae604a20da87e3716bb1d441c483e56479eaef4e99888f41be06059790bca" | ||
34 | SRC_URI[jdom.md5sum] = "22745cbaaddb12884ed8ee09083d8fe2" | ||
35 | SRC_URI[jdom.sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056" | ||
diff --git a/recipes-core/xml-commons/jaxen_1.1.6.bb b/recipes-core/xml-commons/jaxen_1.1.6.bb new file mode 100644 index 0000000..2e313fa --- /dev/null +++ b/recipes-core/xml-commons/jaxen_1.1.6.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | SUMMARY = "XPath library written in Java" | ||
2 | DESCRIPTION = "Adaptable to many different object models, including \ | ||
3 | DOM, XOM, dom4j, and JDOM. Is it also possible to write adapters that \ | ||
4 | treat non-XML trees such as compiled Java byte code or Java beans as XML, \ | ||
5 | thus enabling you to query these trees with XPath too.\ | ||
6 | " | ||
7 | LICENSE = "BSD" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a2e66c2e2482aa23c11342f1469fa3b6" | ||
9 | |||
10 | HOMEPAGE = "http://jaxen.org/" | ||
11 | |||
12 | DEPENDS = "fastjar-native xerces-j xom" | ||
13 | |||
14 | # upstream has moved to github, do not rely on ephemeral tarball, use git | ||
15 | SRCREV = "7d7755ac8b19daa2ff6f319f432b864cc72d89b6" | ||
16 | |||
17 | SRC_URI = "\ | ||
18 | git://github.com/codehaus/${BPN} \ | ||
19 | http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \ | ||
20 | " | ||
21 | SRC_URI[jdom.md5sum] = "22745cbaaddb12884ed8ee09083d8fe2" | ||
22 | SRC_URI[jdom.sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056" | ||
23 | |||
24 | S = "${WORKDIR}/git/jaxen" | ||
25 | |||
26 | inherit java-library | ||
27 | |||
28 | do_compile() { | ||
29 | mkdir -p build | ||
30 | |||
31 | oe_makeclasspath cp -s xercesImpl xom | ||
32 | scp="src/java/main:${WORKDIR}/jdom-1.1/src/java" | ||
33 | |||
34 | javac -sourcepath $scp -cp $cp -d build `find src/java/main -name "*.java" -and -not -wholename "*dom4j*"` | ||
35 | (cd src/java/main && find org -name "*.properties" -exec cp {} ../../../build/{} \;) | ||
36 | |||
37 | rm -rf build/org/jdom | ||
38 | |||
39 | fastjar -C build -c -f ${JARFILENAME} . | ||
40 | } | ||