diff options
author | Niko Mauno <niko.mauno@vaisala.com> | 2023-12-19 16:44:40 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-20 11:13:00 -0800 |
commit | d44d4206b5bb52f102b89a7ae922c4b7f64a70db (patch) | |
tree | 67c0fa32f4ad2d6332a60ffe2fa4b60b6ef030e1 | |
parent | 10f1890af03dbb804bffd4fa7eda7729e08f12cb (diff) | |
download | meta-openembedded-d44d4206b5bb52f102b89a7ae922c4b7f64a70db.tar.gz |
pkcs11-provider: Add recipe
Starting with version 3.0 the OpenSSL project introduced a new modular
system to extend OpenSSL that replaces the deprecated Engine modules.
Providers are loaded via configuration directives in the openssl
configuration file (or directly loaded by applications).
The pkcs11 provider allows applications linked to openssl to use keys
and cryptographic operations from a hardware or software token via
their PKCS #11 driver and the use of PCKS #11 URIs.
The pkcs11 provider can be configured to be automatically loaded via
openssl.cnf
For more details, visit
https://github.com/latchset/pkcs11-provider/blob/main/docs/provider-pkcs11.7.md
Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb b/meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb new file mode 100644 index 0000000000..19412a517e --- /dev/null +++ b/meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "An OpenSSL provider that allows direct interfacing with pkcs11 drivers" | ||
2 | DESCRIPTION = "\ | ||
3 | This is an Openssl 3.x provider to access Hardware or Software Tokens using \ | ||
4 | the PKCS#11 Cryptographic Token Interface\ | ||
5 | \ | ||
6 | This code targets version 3.1 of the interface but should be backwards \ | ||
7 | compatible to previous versions as well.\ | ||
8 | " | ||
9 | HOMEPAGE = "https://github.com/latchset/pkcs11-provider" | ||
10 | SECTION = "libs" | ||
11 | LICENSE = "Apache-2.0" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=b53b787444a60266932bd270d1cf2d45" | ||
13 | DEPENDS = "\ | ||
14 | autoconf-archive \ | ||
15 | openssl \ | ||
16 | p11-kit \ | ||
17 | " | ||
18 | |||
19 | SRCREV = "e2abc4a7ae33159f2fb21b9d87a05ea9e79ef584" | ||
20 | PV = "0.2+git" | ||
21 | |||
22 | SRC_URI = "git://github.com/latchset/${BPN}.git;branch=main;protocol=https" | ||
23 | |||
24 | S = "${WORKDIR}/git" | ||
25 | |||
26 | inherit autotools pkgconfig | ||
27 | |||
28 | FILES:${PN} += "${libdir}/ossl-modules/pkcs11.so" | ||