summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb b/meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb
new file mode 100644
index 0000000000..19412a517e
--- /dev/null
+++ b/meta-oe/recipes-support/pkcs11-provider/pkcs11-provider_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "An OpenSSL provider that allows direct interfacing with pkcs11 drivers"
2DESCRIPTION = "\
3This is an Openssl 3.x provider to access Hardware or Software Tokens using \
4the PKCS#11 Cryptographic Token Interface\
5\
6This code targets version 3.1 of the interface but should be backwards \
7compatible to previous versions as well.\
8"
9HOMEPAGE = "https://github.com/latchset/pkcs11-provider"
10SECTION = "libs"
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=b53b787444a60266932bd270d1cf2d45"
13DEPENDS = "\
14 autoconf-archive \
15 openssl \
16 p11-kit \
17"
18
19SRCREV = "e2abc4a7ae33159f2fb21b9d87a05ea9e79ef584"
20PV = "0.2+git"
21
22SRC_URI = "git://github.com/latchset/${BPN}.git;branch=main;protocol=https"
23
24S = "${WORKDIR}/git"
25
26inherit autotools pkgconfig
27
28FILES:${PN} += "${libdir}/ossl-modules/pkcs11.so"