summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-07 13:08:48 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-07 23:11:24 -0800
commite34a29f12444cd31fb6e6c11712603897e24a6d5 (patch)
treec1792040f14bd30ab9a2336e454b83fd561b9ccb /meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb
parent0fd1c5280ed31cb8e800df2f8076c11a494cf664 (diff)
downloadmeta-openembedded-e34a29f12444cd31fb6e6c11712603897e24a6d5.tar.gz
python3-jsonref: Upgrade 1.0.1 -> 1.1.0
Upgrade to version 1.1.0: - Fixes documents where the root is a reference object not being cached - Allows a reference object to refer to a fragment within itself - Extra properties of a reference object will now have references resolved License-Update: License remains the same Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb b/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb
new file mode 100644
index 0000000000..fae1da2686
--- /dev/null
+++ b/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "jsonref is a library for automatic dereferencing of JSON Reference objects for Python"
2HOMEPAGE = "https://github.com/gazpachoking/jsonref"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4ac1cccee5d43e11fc4eddcf445be64a"
5
6SRC_URI[sha256sum] = "32fe8e1d85af0fdefbebce950af85590b22b60f9e95443176adbde4e1ecea552"
7
8SRC_URI += "file://migrate-to-pdm-backend.patch"
9
10inherit pypi python_setuptools_build_meta
11
12BBCLASSEXTEND = "native nativesdk"
13
14DEPENDS += " \
15 ${PYTHON_PN}-pdm-native \
16 ${PYTHON_PN}-pdm-backend-native \
17"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-core \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23"